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Lesson 1: Introduction to Finite Element Analysis

CATIA is a robust application that enables you to create rich and complex designs. The goal of the course 
‘CATIA V5 for Analysis’ is to teach you how to assist designer to perform preliminary Static Analysis of 
parts and assemblies designed in CATIA. This course focuses on the Finite Element Analysis process for 
static analysis, concepts in static analysis and performing Static analysis for parts and assemblies using 
Generative Part Structural (GPS) Analysis workbench.

16 Hours

About this Course
Introduction

Course Design Philosophy

Target audience

Prerequisites

This course is designed using a process-based approach to training. Rather than focusing on individual 
features and functions, this course emphasizes on the processes and procedures required to complete a 
particular task. By using the case studies to illustrate these processes, you will learn the necessary 
commands, options, and menus within the context of completing a design task.

• Mechanical Designers, Structural Analysts

CATIA V5 Fundamentals
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About the Student Guide

Using the Student Guide
This student guide is intended to be used in a classroom environment under the guidance of a certified 
CATIA Instructor. The exercises and case studies are designed to be demonstrated by the instructor.

Exercises/Case Studies
This course illustrates the process-based approach in two ways: exercises and case studies. Exercises give 
you the opportunity to apply and practice the material covered during the lecture/demonstration portion of 
the course. They are designed to represent typical design and modeling situations. Extra exercises have 
been included in this guide to accommodate those students who may wish to practice more modeling. The 
case studies provide a context in which you would use particular tools and methods, and illustrate the 
process flow you would typically follow for a project.
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Conventions Used in the Student Guide

• Bold text within a sentence denotes options selected from 
the CATIA menu bar. 

• Red text denotes the name of a tool, icon, button, or window 
option. 

• Italic text within a sentence is used to apply emphasis on key 
words. 

• Numerical lists are used in sequential lists, such as the steps 
in a procedure. 

• Lower-case alphabetical sub-lists are used in sequential sub-
lists, as for steps in an exercise procedure. 

• identifies areas in a picture that are associated with steps 
in a sequential list, such as in an exercise. 

• Upper-case alphabetical lists are used in non-sequential lists, 
as for a list of options or definitions. 

• Text enclosed in < > brackets represents the names of 
keyboard keys that must be pressed. 

• Text enclosed in [ ] brackets identifies text that must be 
entered into a text field of a CATIA dialog box or prompt.

2b

Example page:
Use the following steps to create a new 
document in CATIA:

1. Click Start > Mechanical Design > Part 
Design.

2. Create new part.
a.Click File > New.
b.Select Part from the New window.
c.Select OK.

d.Press <CTRL> + <S> to save the 
document.

e.Enter [my first document] as the 
document name.

You can create the following profile types: 
A. User Defined Profiles
B. Pre-Defined Profiles
C. Circles

A B

2b

The following typographic conventions are used in the student 
guide:
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Case Study:  Introduction to Finite Element Analysis 
(FEA)
Lesson 1 will familiarize you with the Finite Element Analysis process. From lesson 2 onwards, 
each lesson in this course will contain a case study, which will help to explain the skills and 
concepts covered in the lesson. Models used in case studies come from the drill press assembly, 
which is also your master project. In this lesson, you will learn about the types of part or surface 
preparation that may be required before analysis, and how to open the GPS workbench. 

GPS pre-
processing

GPS 
Computation

GPS Post-
processing

•Exercises •Exercises •Exercises

Introduction 
to FEA

•Exercises

Mesh 
Refinement

•Exercises

Assembly 
Structural 
Analysis

•Exercises

Master Project(Case Study)
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Design Intent

Each case study contains a set of model requirements, known as the design intent. One   
interpretation of design intent is how the part model has been constructed in order to properly convey 
its functional requirements. In subsequent lessons the case study will be analyzed in order to verify 
these functional requirements. By the end of this lesson you should be able to :

� Understand FEA process
� Open GPS Workbench
� Changing Default Units
� Choosing Local co-ordinate System
� Applying Constraints on Part of Face
� Prepare Surfaces for GPS Analysis
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Stages in the Process

Each lesson explains the topics in steps. These steps outline how to pre-process, compute, 
and post-process the part or assembly in the case study. Each step contains the information 
needed to complete the exercise.

For Lesson 1, you will go through the following steps to start yourself with FEA in Generative 
Structural Analysis Workbench:

1. What is Finite Element Analysis Process
2. Introduction to Generative Structural Analysis (GPS) Workbench
3. Preparing Parts and Surfaces for Analysis
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Step 1: Finite Element Analysis Process

In this section, you will understand the 
general steps to be followed to perform 
Finite Element Analysis for structures.

To introduce yourself to 
Finite Element Analysis use 
the following steps:

1. Finite Element Analysis 
(FEA) Process

2. Introduction to GPS workbench
3. Preparing Parts and Surfaces for 

analysis
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What is Finite Element Analysis (1/4)

The most common Finite Element (FE) technique is 
displacement-based. In this approach, displacement is 
assumed to be an unknown quantity. 

The problem is solved using FE methods to find out 
displacements. 

The overall process can be subdivided into smaller 
steps as shown in the illustration. 

Finite Element Analysis (FEA) is a numerical tool used to 
simulate a physical system. With this method the modeled 
system is broken down into simple geometric shapes, 
called finite elements, whose behavior can be described 
mathematically.  The elements and their interrelationships 
are converted into a system of equations which are solved 
numerically.

Computation 
(Solving FE Model)

Pre-processing
(FE Modeling)

Post-processing
(View Results)

Mesh Refinement 
Iterations

Create 
Reports

Finite Element Analysis Process
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What is Finite Element Analysis (2/4)

� The actual physical Boundary 
Conditions are converted into 
equivalent FE Boundary Conditions.

In this step, the actual physical problem is 
converted into equivalent Finite Element 
problem.

� The physical structure is converted 
into an equivalent Finite Element (FE) 
model.

� The actual material properties are 
defined for FE model.

� Actual physical Forces are converted 
into equivalent FE Loads.

Actual part to 
be analyzed

Finite Element  Model 
representing actual part

Applying Load on 
the FE Model

Applying boundary  
conditions to FE model

A. Pre-processing
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What is Finite Element Analysis (3/4)

� You can study the deformation of 
structure, variation of strains and 
stresses throughout the structure.

� The FE problem provided by the 
pre-processing step is solved to 
find out the unknown displacement 
values. 

� Using these displacement values, 
strains and stresses are calculated 
for the complete structure.

B. Computation

C. Post-processing
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What is Finite Element Analysis (4/4)

� Once the required accuracy level is achieved, 
various plots such as Displacement, Principle 
Stress, Von-Mises Stress can be obtained. 

� The first solution provides initial estimation of 
stress / strain values. If this is considered to be 
sufficiently accurate, no further computation 
will be required.

� To get a more accurate solution, the mesh 
needs to be refined and the computation is to 
be done again.

� A number of mesh refinement and computation 
iterations are performed till the required 
solution accuracy is achieved.

D. Mesh Refinement

E. Report Generation
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Why to Use Finite Element Analysis

FEA can be applied to practically any problem having an arbitrary shape including various 
boundary and loading conditions. This flexibility is not possible with classical analytical 
methods. Apart from this you have the following advantages:

� You can verify a proposed product or structure 
which is intended to meet the customer 
specification, prior to manufacturing or 
construction. 

� You can validate product 
modifications to meet new conditions. 

� You can evaluate advantages and 
effectiveness of various product design 
alternatives without having any kind of 
experimental test setup.

� It helps to implement the product concept ‘first 
time right’ with corresponding cost savings thus 
minimizes  the product life cycle time 
significantly.

� With FEA software tools, you can optimize 
your product for minimum weight and volume 
with negligible cost, thus increasing product 
life and improving product reliability.
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Application of Finite Element Analysis

The FEA is a very important tool for engineering design. It is used to solve various complex 
problems.

• Structural Analysis
• Dynamic analysis
• Buckling Analysis

• Vibrations Analysis
• Acoustic Analysis
• Shock Analysis
• Crash Analysis

• Flow Analysis 
• Thermal Analysis
• Coupled Analysis
• Mass diffusion 
• Metal Forming 
• Electrical Analysis
• Electromagnetic evaluations
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To introduce yourself to 
Finite Element Analysis use 
the following steps:

1. Finite Element Analysis (FEA) 
Process

2. Introduction to GPS 
workbench

3. Preparing Parts and Surfaces for 
analysis

Step 2: Introduction to GPS workbench

In this section, you will learn: 
1. How to perform FEA process 

steps in Generative Part 
Structural Analysis 
workbench.

2. How to access the GPS 
workbench

3. What is Static Analysis
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General FEA Process in GPS Workbench (1/2)

The GPS workbench provides tools and functionalities to perform FEA in CATIA. Illustrated 
below are the FEA process steps that can be performed using GPS workbench.

1. Open the Generative Structural Analysis workbench. Apply material, 
mesh the part, apply the restraints and loads. (Pre-processing)

2. Compute the Analysis. (Computation)

2

1

FEA Process Steps in GPS WorkbenchGeneral FEA Process

Computation 
(Solving FE Model)

Pre-processing
(FE Modeling)
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General FEA Process in GPS Workbench (2/2)

3. Visualize the results. (Post-processing)
4. Interpret the results and Mesh Refinement. (Mesh Refinement Iterations)
5. Manage the results. (Report Generation)

5

4

3

FEA Process Steps in GPS WorkbenchGeneral FEA Process

Post-processing
(View Results)

Mesh Refinement 
Iterations

Create 
Reports
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Finite Element Analysis Types (1/3)

FEA for structures can be broadly classified in the 
following two ways:
1. According to variation of load with respect to time.

A. Static analysis
Static analysis is performed when load 
vectors and boundary conditions remain 
constant with respect to time.
Example: Static loading on machine frames 
due to weight, static loading on trusses, 
pressurized containers subjected to internal 
static pressure. 

B. Transient Analysis
Transient analysis is performed when load 
vectors and boundary conditions change with 
respect to time.
Example: Load on connecting rod in piston-
cylinder assembly.

Truss

Connecting
rod

Load 
(N)

Time (Sec)

Static

Time (Sec)

Load 
(N)

Transient
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Finite Element Analysis Types (2/3)

C. Harmonic Analysis
Harmonic Analysis is performed when Load 
vectors change with the frequency.
Example: Analysis of crankshaft of an 
automobile engine, analysis of turbine and 
propellers.

2. According to the way the structure reacts to the load.
A. Linear Analysis

Linear analysis is performed when the 
structural deformations due to loads are 
within the elastic limit of stress-strain curve 
for structure material.
Example. Static analysis of components 
where deformations produced are very small. 
(Static Load on bearing support) 

Frequency (�)

Load 
(N)

Harmonic

Strain (�)

Stress
(�)

Linear 
Zone

Linear
Bearing 
support

Propeller
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Finite Element Analysis Types (3/3)

Strain (�)

Stress
(�) Non-linear 

Zone

Non-linear

Airplane 
fuselage section

B. Non-Linear Analysis
Non-linear analysis is performed when 
structural deformations due to load do not 
follow linear stress-strain relationship.
Example: Analysis of components using non-
linear materials like composites, analysis 
involving non-linear phenomena like plastic 
deformation (metal forming), friction, crash 
analysis of automobiles, airplane structures

In CATIA, you can perform Static linear analysis, 
free vibration analysis to find out mode shapes of 
a structure, linear transient analysis and harmonic 
analysis. SIMULIA helps you to perform non-linear 
analysis.

Using the GPS workbench with a GPS license, 
you can perform Static Linear analysis and free 
vibration analysis.
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Accessing the Generative Structural Analysis Workbench

You can access Generative Structural Analysis (GPS) workbench using the 
following steps.

1

2

3

1. From the main menu select
Start > Analysis & Simulation > Generative Structural Analysis

2. Select the Static Analysis.
3. Click OK.
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GPS Static Analysis Tree Structure

Entities created during process of GPS Static Analysis get mapped in tree structure as shown.

Links to CATPart,
CATAnalysisResults and 
CATAnalysisComputations files

Definition for Mesh, 
Property and Material

Definition for 
Restraints and Loads

Plots for 
Result Quantities

Sensors for 
Result Quantities
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Exercise 1A
Recap Exercise

15 min

By the end of this exercise you will be able to:

� View licensing information for CATIA V5

� Open the GPS workbench

� Change default units

In this exercise, you will open a Generative Structural Analysis (GPS) workbench, study the 
specification tree for analysis and see licensing information. Detailed instructions for this 
exercise are provided.
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Exercise 1A (1/4)

1. Open a part.
� Open 1A_Change_Units_Start.CATPart

a. Select File > Open.
b. Browse the folder and click on the file.
c. Click OK.
d. While using the companion, click the link on the 

companion, Load a document, to open the part. 
1a

2. View Licensing Information.
a. Select on Tools > Options. 
b. Click on General in Options specification tree.
c. Select Licensing Tab.
d. Observe the checked products in List of 

Available configurations or Products.

2b
2c

2d

2a

Please ensure that GPS and 
GAS licenses are checked.
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Exercise 1A (2/4)

3. Access Generative Structural Analysis 
workbench.
� To access workbench from start menu.

a. Select Start > Analysis & Simulation > 
Generative Structural Analysis

3a

4. Create a Static Analysis Case.
� ‘Static Analysis’ case will be default 

selection.
a. Click OK.
b. A Static Case is added to the 

specification tree.

4a

Analysis Manager 
Specification tree.
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Exercise 1A (3/4)

5. Study specification tree.
� Expand various nodes in the specification tree 

to observe the details.
a. Click Links Manager.1 node on “+” sign to 

expand. Observe how the part is linked to 
Analysis Document.

b. Double-click Nodes and Elements in 
specification tree. Click on OCTREE 
Tetrahedron Mesh.1 : Cylinder. See which 
type of mesh is applied on Part. 

c. Double-click Properties.1 node in 
specification tree. Observe the Property 
Type applied to Part.

d. Double-click Materials.1 node in 
specification tree. Then double-click on 
Material.1. Observe the Material applied to 
Part.

e. Double-click Static Case node in 
specification tree. Observe the new nodes 
added like  Restraints, Loads, Static Case 
Solution and Sensors.

5a

5b

5c

5d
5e
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Exercise 1A (4/4)

6. Change Units.
� Change the unit of length to meters.

a. Select Tools > Options.
b. Click on Parameters and Measures in 

Options specification tree.
c. Select Units Tab.
d. Click on Length in Units field.
e. Select Meter in the dropdown box.
f. Click OK. 6a

6b

6c

6d

6e
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Exercise 1A: Recap

� View licensing information for CATIA V5.

� Open the GPS workbench.

� Change default units.
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To introduce yourself to Finite 
Element Analysis use the 
following steps:

1. Finite Element Analysis (FEA) 
Process

2. Introduction to GPS workbench

3. Preparing Parts and 
Surfaces for analysis

In this section, you will learn 
which tools are used to 
prepare part and surface 
models for Analysis.

Step 3: Preparing Parts and Surfaces for Analysis
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Preparing Parts and Surfaces for Analysis

Before you switch to Generative Structural Analysis workbench, you may need to make some 
modifications in the existing CATIA geometry or modify some of the CATIA settings. This may 
include :

7. Lowest Mesh size value for Analysis

In addition, having switched to the Generative Structural Analysis 
workbench, you may need to take into account the following when 
meshing very small models :

1. Changing default units
2. Creating support on part of a Face 
3. Creating Local Axis System
4. Handling Non-Manifold Surfaces
5. Handling Overlapping Surfaces
6. Preparing Surfaces with Gaps for Analysis



Student Notes:

CATIA V5 Analysis
����������	��

Copyright DASSAULT SYSTEMES 31

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

Changing Default Units

You may need to change the default CATIA units as per your requirements. 
This can be done in following way.

1

2

3

4

1. In main menu select Tools > Options. 
2. Click on Parameters and Measure in 

options tree and click on Units Tab.
3. Click on the unit in Units field which you 

want to change.
4. From the drop-down list select the 

required unit and click OK.
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Creating support on part of a Face (1/3)

Consider a case where you have to apply a 
load or constraint on part of a face as shown in 
the picture. In this case it is not possible to 
select only part of the face as shown, as a 
support for applying a load or constraints. 

You will see how to create such a support 
using Part Design and Generative Shape 
Design tools. 
The general steps to create such a support are:    

Part of Face where 
Load is to be applied

Base Face

a. Extract the Base surface

c. Create the sketch/circle directly on 
the base surface with base surface 
as geometry support. 

Circle created

1b

1a

Extracted 
surface

1. Create the required surface you want to 
select as support on the base face as 
geometry support. You can create this by 
following methods in Generative Shape 
Design Workbench:
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Creating support on part of a Face (2/3)

c. Split the extracted surface 
with sketch.

Split surface

d. Create the sketch/circle directly on 
the base surface with base surface 
as geometry support. You can also 
create User coordinate system to 
create this sketch/circle.

You can also create such support 
surface using following steps:

1d

Circle created 
directly on part 
surface

1c
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Creating support on part of a Face (3/3)

2

e. Fill the sketch/circle using to 
create required surface.

Surface is 
created 
using Fill.1e

2. Sewing the created surface to the Part.
In Part Design Workbench, click Sew
icon from Surface-Based Features
toolbar. Select the created surface and 
click OK with options shown 
unchecked. 
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Creating Local Axis System (1/2)

The loads applied on the FE model are by 
default applied with respect to Global Axis 
System. Consider a case where part is not 
aligned with global Axis System as shown in 
the figure. In this case, you have to apply a 
distributed force vertically downward on the 
highlighted surface.
You can create your own user coordinate 
system with one axis vertically downward and 
apply a load with respect to this user 
coordinate system. The general steps to 
create a user coordinate system are:

Highlighted surface where vertically downward 
Load to be applied. Load with respect to global 
axis is not vertically downward.

Global coordinate system 
not aligned with part

1

2

1. Switch to GSD Workbench.
2. In main toolbar select Insert > Axis-System
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Creating Local Axis System (2/2)

User-defined Axis System

3

4
Load applied using user 
defined Axis System

3. Create user-defined Axis System 
using various options available.

4. While applying the load, select the
Type as User and select Axis 
System.1 from specification tree.
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Handling Non-Manifold Surfaces for Analysis (1/2)

Before you start FE modeling for a surface, ensure that it is a manifold surface as non-
manifold surfaces cannot be meshed.

However in certain situations where you have 
to analyze part with a non manifold surfaces, 
you can use the following process:

Non-manifold 
surface

Mesh error

1a

a. In Join-Healing toolbar, click 
Disassemble icon. 

b. Click on the surface to be 
disassembled. 

c. Select All Cells option and click OK.

1. Switch to GSD workbench.
2. Disassemble the surfaces.

1c
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Handling Non-Manifold Surfaces for Analysis (2/2)

2. Mesh each surface independently using Surface 
Mesher with Automatic mesh capture option 
checked. (This option is available with the 
Advanced Meshing Tools Workbench).
This will help to capture the nodes of adjacent 
surface meshes.

2
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Handling Overlapping Surfaces for Analysis (1/5)

a. Double-click the surface to enter in GSD 
workbench.

b. In main toolbar select Insert > Analysis > 
Connect Checker and select the surface 
to be checked.

c. Enter Minimum Gap and Maximum gap
value. This should be greater than Max:
Value.

d. Check the overlapping option.
e. Click OK. The overlapped area will get 

highlighted.

Two surfaces are overlapped 
at common boundary

1a

Mesh error

1. Check for overlapping surfaces.

If there are overlapping surfaces, an error message will 
be displayed while attempting to generate the mesh.

Overlapped area is highlighted 
using Connect Checker

1b
1e

1d

1c
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Handling Overlapping Surfaces for Analysis (2/5)

2b

2. Correction of the overlapping surface

a. Double-click on the surface to enter 
GSD workbench.

b. In Join-Healing toolbar, click 
Disassemble icon. 

c. Click on the surface to be 
disassembled. 

d. Select All cells option and click OK. 2c

2d
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Handling Overlapping Surfaces for Analysis (3/5)

2. Correction of the overlapping surface 
(continued). Project the edge of one 
surface on overlapping surface. 

e. In Project-combine toolbar, click 
Projection icon. 

f. In Projected textbox, select edge of 
larger surface to be projected on 
smaller surface.

g. In support select smaller surface 
and click OK.

Highlighted edge to be projected 
on overlapping surface

Overlapping

Smaller surfacelarger surface

2f

2e



Student Notes:

CATIA V5 Analysis
����������	��

Copyright DASSAULT SYSTEMES 42

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

Handling Overlapping Surfaces for Analysis (4/5)

2h

Surfaces after removing overlapped part

Overlapping 
removed

Split 
surface

h. In Trim-Split toolbar, click Split icon. 
i. Select smaller surface from 

specification tree (newly created using 
disassemble) in Elements to cut. 

j. Select the Project.1 just created in 
Cutting Elements.

k. Click on Preview to ensure that 
overlapped portion of surface is 
removed.

Smaller surfacelarger surface

2. Correction of the overlapping surface 
(continued). Cut the overlapped portion 
of the surface.
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Handling Overlapping Surfaces for Analysis (5/5)

l. In Join-Healing toolbar, click Join
icon. 

m. Select newly created split.1 surface 
and disassembled, larger surface 
Surface.11 from specification tree. 
This will create new surface Join.1 in 
specification tree.

Now the geometry can be meshed.

2l

Joined surface

Split 
surface

2m

2m

2. Correction of the overlapping surface 
(continued). Joining the newly created 
Split Surface and Non-overlapping 
surface.
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Preparing Surfaces with Gaps for Analysis (1/4)

Nodes are not interconnected in 
meshing if surfaces have gaps

If the surfaces have gaps, the surfaces will be 
meshed, but you will find that the nodes on the 
gap edges are not interconnected.
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Preparing Surfaces with Gaps for Analysis (2/4)

1. Find location of gaps.

Gap within surface is highlighted

You will see how to correct the surfaces which 
have gaps.

a. Double-click the surface to enter in GSD 
workbench.

b. In Extracts toolbar, click the Boundary
icon. Select the Surface.25 by directly 
clicking on it. You can also select it 
through the specification tree. If the 
surface has gaps the internal boundaries 
will be highlighted. Click OK.

1a

1b
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Preparing Surfaces with Gaps for Analysis (3/4)

2. Check gap value

a. Use Connect Checker tool to find gap 
size. In main toolbar select Insert > 
Analysis > Connect Checker.

b. Select the surface to be checked. 

c. Select G0 option. Enter its value as 
0.04, keep the value less than G0 value 
of  Max Deviation. Say Max Deviation
is 0.05 mm then enter 0.04 mm in G0
field. This will help to highlight the gap.

2a

Max Gap 
highlighted

2b

Max Gap
value

2c
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Preparing Surfaces with Gaps for Analysis (4/4)

4. To ensure that gaps are merged, in the
Extracts toolbar use the Boundary
icon again. Now it will show you only 
the outer boundary highlighted.

3a

4

No gap 
present

Only Boundary 
is highlighted

3. Merging the Gaps

a. In Join-Healing toolbar, select Healing
icon. 

b. Select the surface to heal. 
c. Enter 0.1 in Merging Distance field 

and click OK. (Merging distance should 
be greater than Max gap) 

3c
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Lowest Mesh size value for Analysis (1/2)

The lowest recommended value for mesh size is 0.2 mm. 
Mesh size values below this may lead to error while meshing 
due to the automatic meshing algorithm. You will try meshing 
the surface with the following mesh sizes. 1a
1. Create a mesh whose size is too small.

a. In Mesh Parts toolbar, select OCTREE
Triangle Mesher icon. 

b. Select the surface to mesh.
c. Enter 0.003 in Size field. Check Absolute

sag option and enter 0.0003. Select 
Element Type as Parabolic and click OK. 

d. Right-click on Nodes and elements in 
specification tree and  click on Mesh
Visualization.

e. An error message will be displayed.

1c

1dError message with 0.003 mm mesh size

1e
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Lowest Mesh size value for Analysis (2/2)

2b

Mesh Image with 0.1 mm mesh size

2a
2. Modify the mesh to an acceptable size.

a. Double-click on OCTREE Triangle Mesh.1
in the specification tree. Enter 0.1 in Size
field. Enter Absolute sag as 0.01 and click 
OK.

b. Double-click on Mesh.1. 
c. You will get a warning message to update 

the mesh. Click OK to update.
d. The mesh will be created and displayed.

2d

2c
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In the following slides you will find a summary of the topics covered in this lesson.

To Sum Up
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Finite Element analysis (FEA) is a numerical tool 
used to simulate the physical system. In this 
method the modeled system is broken into smaller 
geometric shapes, called finite elements, whose 
behavior can be described mathematically. The 
elements and their interrelationships are converted 
into a system of equations which are solved 
numerically. The overall process is divided into 
smaller steps as follow 

1. Pre-processing: Conversion of actual problem 
into Finite element problem

2. Computation: Solution of the of the FE 
problem provided by pre-processing to find 
out unknown displacement values

3. Post-processing: Calculation of strains and 
stresses using displacement values. Study of 
displacements strains and stresses

4. Mesh Refinement: Refinement of the mesh 
and computation to achieve the required level 
of accuracy

5. Report Generation: Generation of various 
plots such as displacements, strains and 
stresses once the required level of accuracy 
is generated

Finite Element Analysis Process

Finite Element 
Analysis Process

Computation 
(Solving FE Model)

Pre-processing
(FE Modeling)

Post-processing
(View Results)

Mesh Refinement 
Iterations

Create 
Reports

Pre-processing

Computation

Post-processing
Mesh-Refinement

Report Generation
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Introduction to GPS workbench
The GPS workbench provides tools and 
functionalities to perform FEA in CATIA. Following 
are the FEA process steps that can be performed 
using GPS workbench.

1. Open the Generative Structural Analysis 
workbench. Apply material, mesh the part, 
apply the restraints and loads

2. Compute the Analysis
3. Visualize the results
4. Interpret the results and Mesh Refinement
5. Manage the results

Entities created during process of GPS Static 
Analysis gets mapped in the tree-structure as 
shown.

GPS Static Analysis Tree Structure

� Static Analysis
� Transient Analysis
� Harmonic Analysis

� Linear analysis
� Non-linear Analysis

According to variation in load with respect to time, 
the FEA for structures can be classified as: 

According to the way the structure reacts to the 
load, the FEA for structures can be classified as:
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Preparing Parts and Surfaces for Analysis
Before you switch to Generative Structural 
Analysis workbench, you may need to make some 
modifications in the existing CATIA geometry or 
modify some of the CATIA settings. This may 
include:

� Changing default units
� Creating support on part of a Face 
� Creating Local Axis System
� Handling Non-Manifold Surfaces
� Handling Overlapping Surfaces
� Preparing Surfaces with Gaps for Analysis

In addition, when meshing very small models you 
may need to take into account Lowest Mesh Size 
value for Analysis. 
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Tools Used for Preparing Parts and Surfaces for Analysis (1/2)

1

2

3

4

5

6

1

2

3

4

Extract: lets you perform an extract from 
elements (curves, points, surfaces, solids, 
volumes etc).

Split: lets you split the surfaces.

Fill: lets you create fill surfaces between number 
of boundary segments.

Sew Surface: lets you add or remove material by 
modifying the surface of the volume.

Disassemble: lets you disassemble the multi-cell 
bodies into mono-cell or mono-domain bodies, 
whether curves or surfaces.

Surface Mesher: lets you mesh the surface part 
by entering into the Surface Mesher workshop.

Connect Checker: lets you analyze the 
connection between the surfaces’ borders and 
their projection on a surface. 

5

6

7

7



Student Notes:

CATIA V5 Analysis
����������	��

Copyright DASSAULT SYSTEMES 55

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

Tools Used for Preparing Parts and Surfaces for Analysis (2/2)

8

9

10

11

8

9

10

11

Projection: lets you create geometry by 
projecting one more elements onto a support.

Join: lets you join the multi-sections and swept 
surfaces.

Healing: lets you heal the surfaces (i.e. fill any 
gap that may be appearing between two 
surfaces).

Boundary: lets you create the boundary curve of 
a surface or the boundary point of a curve.
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Exercise 1B
Recap Exercise

30 min

By the end of this exercise you will be able to:

� Create a support to apply constraints or loads 
on a part of the face

� Create a user defined Axis System

� Apply a load with a user-defined coordinate 
system

In this exercise, you will apply a load on a part of the face. You will use a User-defined  
coordinate system to apply a Distributed load. Detailed instructions for this exercise are 
provided.



Student Notes:

CATIA V5 Analysis
����������	��

Copyright DASSAULT SYSTEMES 57

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

Exercise 1B (1/8)

2. Extract the outer surface of shaft. 
� Extract the outer surface of the shaft to 

provide the base surface.
a. Access the GSD workbench.
b. In Extracts toolbar, click on the Extract

icon.
c. Select the outer surface of shaft as 

shown.
d. Click  OK.

1. Open a part.
� Open 1B_Part_of_Face_Start.CATPart

a. Select File > Open.
b. Browse the file and select the file.
c. Click OK. 1a

2b

2c

2d
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Exercise 1B (2/8)

3. Create an Axis System for geometry on support surface.
� Define an Axis system by creating a plane tangent to 

the surface.
a. In Reference Elements toolbar, click on the Point

icon. 
b. Use options as shown and enter 39.554mm in the 

Length: field. Click OK.
c. In Reference Elements toolbar, click the  Plane icon. 
d. Select Plane Type as Tangent to surface.
e. Select surface in Surface field as shown.
f. Select Point.2 in Point field as shown.
g. Click OK.

3a

Curve to be 
selected to as 
support to create a 
point

3b

3d

3c

3e

Point to be selected
3f3g
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Exercise 1B (3/8)

h. Select Insert > Axis System…
i. In Origin field, select the Point.2 from specification 

tree.
j. In X axis field, select the vertical surface of shaft as 

shown. Keep Y axis field as it is.
k. In Z axis field, select the Plane.3 just created, from 

specification tree. Check Reverse option to make 
upward direction positive.

l. Click OK.

7a
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Exercise 1B (4/8)

4. Create a geometry on support surface.
� Create a circle using User-defined Axis System.

a. In Circle-Conic toolbar, click Circle icon.
b. Select Center and radius in Circle type.
c. In Center field, right-click to open the contextual 

menu and select Create Point option.
d. In Point Definition dialogue box, select Point type

as Coordinates. 
e. Enter distance 30 mm in X = field.
f. Click OK. Point.3 will be created in Center field.

4b

4c

4a

4d

4e

4f
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Exercise 1B (5/8)

g. In Circle Definition dialogue box, click in the Support
field and select Extract.1 from specification tree.

h. Enter Radius as 15 mm.
i. Check the option Geometry on support.
j. Click OK.

4g

4i
4h

4j

Circle created
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Exercise 1B (6/8)

5. Cut the extracted surface with geometry.
� Cut the surface with geometry to create support 

surface.
a. In Trim-Split toolbar, click Split Icon.
b. Select Extract.1 in Element to cut field.
c. Select Circle.2 in Cutting elements field.
d. Click OK.

5a

Split surface

5b

5c

5d
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Exercise 1B (7/8)

6. Sew the support surface to Part.
� Sew the surface created to part.

a. Switch to Part Design workbench.
b. In Surface-Based Features

toolbar, click Sew Surface icon.
c. Click OK on the warning message.
d. Select Split.1 from specification 

tree in Object to sew field.
e. Uncheck Simplify geometry

option.
f. Click OK.

6a

6b

6d

6e 6f

6c
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Exercise 1B (8/8)

7. Apply Force using user-defined Axis System
� Apply Distributed Force.

a. Select Start > Analysis & Simulation > 
Generative Structural Analysis. Click OK to the 
warning detected.

b. In Forces toolbar, click Distributed Force icon.
c. Select SewSurface.1 from the specification tree 

in Supports field.
d. In Axis System, select User in Type dropdown.
e. Select Axis System.1 in Current axis field.
f. In Force Vector, enter -1N in Z field.
g. Click OK.

8b

8g

8f

8e

8d

8c
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Exercise 1B: Recap

� Create a support to apply constraints or 
loads on a part of the face.

� Create a user defined Axis System.

� Apply a load with a user-defined coordinate 
system.
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Exercise 1C
Recap Exercise

60 min

By the end of this exercise you will be able to:

� Detect overlapping surfaces

� Correct the overlapping surfaces

� Mesh the corrected surface

In this exercise, you will mesh an overlapping surface, correct the overlapping 
surfaces and re-mesh the corrected surface. Detailed instructions for new topics are 
provided for this exercise.
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Exercise 1C (1/8)

1. Open a part.
� Open 1C_Overlapping_Start.CATPart

2. Create a Static Analysis Case.
� Access the Generative Structural 

Analysis workbench.
� Create a Static Analysis Case. Click OK

for the warning message.

3. Mesh the surface.
� Mesh the surface with OCTREE Triangle 

Mesher.
a. In Mesh Parts toolbar, click OCTREE 

Triangle Mesher icon.
b. Click on the surface.
c. Keep default values as shown and 

click OK.

3a

3c

3b

Please ensure that you are set to mm.
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Exercise 1C (2/8)

4. View the mesh.
� Create Mesh visualization to create Mesh image.

a. Right-click on Nodes and Elements.
b. Select Mesh visualization.
c. Click OK for the warning message to update 

the mesh.
d. Double-click on the Mesh Error.1.

4a

4b

4c

4d
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Exercise 1C (3/8)

5. Correct overlapping surfaces.
� Double-click on the surface to switch to GSD 

workbench.
� Disassemble the surfaces.

a. In Join-Healing toolbar , click Disassemble
icon. 

b. Select the surface to be disassembled.
c. Select All cells option and click OK to create 

the two new surfaces. 
d. Hide the original surface Surface.10 in order to 

see only the new surfaces. The different colors 
shown below are only to simplify identification.

5a

5c

5c5b

5d
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Exercise 1C (4/8)

� Use Connect Checker tool to highlight gap.
e. Select Insert > Analysis > Connect 

Checker.
f. Select the Surface.11 and surface.12.
g. Select the Surface-Surface 

connection as type.
h. In the Quick tab select overlap Defect

option. 
i. Enter 0.15 mm in Maximum gap and 

click OK. The overlapped area will get 
highlighted.

5f

5g

5h

5i

5f
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Exercise 1C (5/8)

� Split an overlapping surface.
j. In Project -Combine toolbar, click 

Projection icon.
k. In Projected field, select edge of large 

surface to be projected on overlapping 
surface.

l. In Support field, select small surface and 
click OK.

Overlapping

5j

6d

5k
5l

5l

5k
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Exercise 1C (6/8)

m. In Trim-Split toolbar, click Split icon.
n. Select the small surface surface.12 in 

Elements to cut field.
o. Select the projected edge Project.1 in Cutting 

elements field.
p. Click OK.

The different colors shown below are only to 
simplify identification of the new split surface.

5m

5n

5o

5p
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Exercise 1C (7/8)

6. Create a single surface element.
� Join the two surfaces.

a. In Join-Healing toolbar, click Join icon.
b. Select newly created Split.4 surface and 

disassembled, larger surface Surface14.
c. Click OK. This will create new surface Join.1

in specification tree.

6a

6b

6b

6b

6c
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Exercise 1C (8/8)

7. Create and view the Mesh Image.
� Switch to GPS workbench.

a. Double-click on Nodes and Elements to switch 
to GPS workbench.

� Create new Mesh.
b. Right-click on OCTREE Triangle Mesh.1 and  

select Delete.
c. In Mesh Parts toolbar, select OCTREE 

Triangle Mesher icon.
d. Click the surface.
e. Keep default values as shown and click OK.

� Create Mesh visualization to create Mesh image.

7a

7b

7c

7e
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Exercise 1C: Recap

� Detect overlapping surfaces.

� Correct the overlapping surfaces.

� Mesh the corrected surface.
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Exercise 1D
Recap Exercise

15 min

By the end of this exercise you will be able to:

� Check the gaps in surface

� Merge the gaps in surface

� Mesh the corrected surface

In this exercise, you will mesh the surface having gaps, check for the gaps, merge the gaps 
and mesh the corrected surface. Detailed instructions for new topics are provided for this 
exercise.
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Exercise 1D (1/4)

1. Open a part.
� Open 1D_Gaps_Start.CATPart

2. Create a Static Analysis Case.
� Access Generative Structural Analysis 

workbench.
� Create a Static Analysis Case.

3. Mesh the surface.
� Mesh the surface with OCTREE Triangle Mesher

with mesh Size 20 mm and Absolute sag 2 mm.
� Visualize the mesh.

Nodes are not interconnected in 
meshing if surfaces have gaps
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Exercise 1D (2/4)

4. Check if there are gaps.
� Switch to GSD workbench.
� Check the Boundary.

a. In Extracts toolbar click Boundary
icon. 

b. Select the Surface.25 by directly 
clicking on it. You can also select it 
through specification tree. The 
surface is highlighted with gap.

c. Click OK.
d. In Multi-Result Management window 

select the option keep all the sub-
elements.

e. Click OK

4a

4b

4c

4d
4e
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Exercise 1D (3/4)

5. Merging the gap.
� Use Healing to merge the gaps.

a. In Join-Healing toolbar, click Healing
icon.

b. Select the surface to heal. 
c. Enter 0.1 in Merging Distance field 

and click OK. Merging distance
should be greater than gap

� Ensure the merging of gaps.
d. In Extracts toolbar, click Boundary

icon again. Now it will show you only 
Outer boundary highlighted.

Only Boundary 
is highlighted

No gap 
present

5a

5b

5c

5d
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Exercise 1D (4/4)

6. Mesh the corrected surface.
� Mesh the surface using OCTREE 

Triangle Mesher.
a. Delete existing OCTREE Triangle. 

Mesh.1 using Delete in contextual 
menu.

b. Create new mesh OCTREE Triangle 
Mesher.

c. Activate the Mesh.1 Image.

6a
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Exercise 1D: Recap

� Check the gaps in surface.

� Merge the gaps in surface.

� Mesh the corrected surface.
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Exercise 1E
Recap Exercise

5 min

By the end of this exercise you will be able to:

� Mesh the surface with recommended mesh size

In this exercise, you will mesh the surface with value less than 0.2 mm and then with higher 
values. Detailed instructions for new topics are provided for this exercise.
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Exercise 1E (1/2)

1. Open a part.
� Open 1E_Mesh_Size_Start.CATPart

2. Create a Static Analysis Case.
� Access Generative Structural Analysis 

workbench.
� Create a Static Analysis Case.

3. Mesh the surface.
� Mesh the surface with OCTREE Triangle Mesher.

a. Enter 0.003 in Size field. 
b. Check Absolute sag option and enter 0.0003.
c. Select Element Type as Parabolic and click OK.

4. View Mesh.
� Generate Mesh Image. The following warning 

message will be displayed. When you select OK, 
following four mesh errors are seen in the 
specification tree.
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Exercise 1E (2/2)

5. Change the mesh size.
� Change the mesh size to 0.1 mm

a. Double-click on OCTREE Triangle Mesh.1 in 
specification tree. Enter 0.1 in Size field. 
Enter Absolute sag as 0.01 and click OK.

b. Generate the Mesh Image. Once again you 
will get the same warning message to 
update the mesh. When you select OK, 
Mesh.1 will appear in the specification tree. 

Mesh Image with 0.1 mm mesh size

The minimum mesh size value 0.2 mm is a purely theoretical limit above 
which you are sure to be able to create a mesh. If you have less than this 
value, may or may not be able to create a mesh. This will be indeterminate 
because will depend upon the geometry.
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Exercise 1E: Recap

� Mesh the surface with value above 
recommended mesh size.
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Exercise 1F
Recap exercise

5 min

By the end of this exercise you will be able to:

� Verify that non-manifold surfaces can not be 
meshed with the GPS workbench

In this exercise, you will mesh the non-manifold surface. High-level instructions are provided 
for this exercise.
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Exercise 1F

1. Open a part.
� Open 1F_NonManifold_Start.CATPart.

2. Create a Static Analysis Case.
� Access Generative Structural Analysis 

workbench.
� Create a Static Analysis Case.

3. Mesh the surface.
� Mesh the surface with OCTREE Triangle 

Mesher with default values.

4. View Mesh.
� Generate Mesh Image. The following error 

message will be displayed.

In order to mesh such a part, Advanced Meshing 
Tools workbench has to be used.
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� Understand that non-manifold surfaces can 
not be meshed.

Exercise 1F: Recap


