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About this course
Objectives of the course
Upon completion of this course you will be able to:
-Create and reuse advanced replication tools like Power Copies 
-Store components and Power copies into catalog and reuse them 
in a new context
-Analyze and convert CATIA V4 models to CATIA V5.

Targeted audience
Advanced Users

Prerequisites
Students attending this course should have knowledge of CATIA 
BASICS and Part Design 1 Day
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Creating and Using Power Copy
You will learn how to create, save, and instantiate a Power Copy.

Power Copy Presentation
Creating a Power Copy
Saving a Power Copy
Instantiating a Power Copy
Summary
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Power Copy Presentation
In this lesson, you will have an overview of ‘Power Copy’ and the ways it can be 
used.

Power Copy definition

Power Copy instantiation
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What is a Power Copy?

Power Copy tools are available in the Insert menu (Advanced Replication Tools) of those 
workbenches:

Part design,
Wireframe and Surface,
SheetMetal Design

Power Copy is a set of design features grouped together in order to be reproduced. It is a 
kind of advanced copying tool.

While defining it, you can specify the inputs that the user should provide.
During instantiation, you can customize it and insert it in the design of any part.
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Example of Power Copy (1/3)

In this example, we want to create a ‘Power Copy’ which will require only a 
single ‘Line’ and ‘Plane’ as an input and create a ‘Drafted Rib’ from it.

These are the inputs that the user will specify during the instantiation of the ‘Power 
Copy’.



Student Notes:

CATIA Tools for Proficient Users
����������	��

Copyright DASSAULT SYSTEMES 	

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

Example of Power Copy (2/3)

During the instantiation of the ‘Power Copy’, the user 
has to select inputs with respect to the destination part.



Student Notes:

CATIA Tools for Proficient Users
����������	��

Copyright DASSAULT SYSTEMES �


C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

Example of Power Copy (3/3)

In this case, these are the geometries that the ‘Power Copy’ feature creates automatically.

Creation of rectangular sketch from the 
selected rib line.

Extrusion of this sketch up to the selected 
‘Limiting Surface’

Application of ‘Draft’ to the extruded faces.

Thus, in this example you have seen how a power copy feature can create a ‘Drafted Rib’
from a single ‘Line’ as input. 
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Creating a Power Copy
You will learn to create a Power Copy.
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Setting Icon and 
preview properties

Publishing 
Parameters

Identifying and 
naming inputs

Setting 
Definition

Making the Part ready 
for the creation of the 
Power Copy

Creation of Power Copy consists of the following steps:

Process for Power Copy Creation

1 2 543
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1a

Once you have the right geometry in your CATPart, you can create the Power Copy.

How to Create a Power Copy (1/4) 

Select Power Copy from the menu. (Insert > Knowledge Templates > Power Copy)

1b Type the name of the Power Copy in the ‘Definition 
Tab’ of the ‘Powercopy Definition’ dialog box.

1c From the specification tree, select the features that will make your ‘Power Copy’.

On selecting the features, the ‘Inputs of components’ are 
identified. These depend upon the features that you select 
to make your PowerCopy.
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After selecting features making the power copy, you can give names to the geometric 
inputs. During instantiation, the user will be prompted to select the geometries based 
on these new names.

How to Create a Power Copy (2/4)

In our case there are three inputs:

A. The edge (Edge.1) from ‘Rib_Sketch’ - > Using this sketch, the power copy 
creates the ‘Rectangular Sketch’

B. The YZ plane on which the ‘Rib_Curve’ has been created.

C. The shell face (Face.10) upto which the ‘Pad.5’ was extruded.

2c Type a new name 
for the input.

Select inputs tab 2b Select the input to be 
renamed

Let us give new names to these inputs from instantiation point of view.

2a

New Name:

Limiting_Face

Rib_Curve_Plane

Rib_Curve

2a

2b

2c
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After renaming the geometric inputs, you can publish parameters. During 
instantiation, the user can specify values for these published parameters.

How to Create a Power Copy (3/4)

3a Select parameters tab

To publish the parameters:

3b Select parameter 

3c Check the ‘Published’
option

3d If necessary, rename the 
parameter

Note that it will be easier for you to recognize them if you have already 
renamed parameters with knowledgeware tools. [ f(x) ] 
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Once parameters are published, you can select the icon for your Power Copy and 
make a screen grab to create a preview of your Power Copy for catalogs.

How to Create a Power Copy (4/4)

4a Select ‘Properties’ tab

4b Select any icon from the available list.

4c Prepare the CATPart window for the 
screen grab

Click ‘Grab screen’ to make a screen 
grab and click OK to validate. 

4d

To prepare the screen grab, you can remove tree and compass from the 
window and get the correct zoom and orientation.
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Saving a Power Copy
You will learn to save the Power Copy in a catalog.



Student Notes:

CATIA Tools for Proficient Users
����������	��

Copyright DASSAULT SYSTEMES ��

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

If you do not save the CATPart containing the Power Copy, you will not be able 
to instantiate the Power Copy.

Saving a Power Copy

You can save the Power Copy in a new catalog and also in an existing catalog.

You can also update a catalog which makes reference to the Power Copies of your CATPart
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If you do not save the CATPart containing the Power Copy, you will not be able 
to instantiate the Power Copy.

Saving a Power Copy in a Catalog

You can save the Power Copy in a new catalog and also in an existing catalog.

You can also update a catalog which makes reference to the Power Copies of your 
CATPart.
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Instantiating a Power Copy
You will learn to instantiate a Power Copy differently at different places by 
varying geometric inputs and parameters while instantiating.

Power Copy instantiation
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1

First step of the Power Copy instantiation is accessing the Power Copy. 
You can access it:
a) From the CATPart file containing it.  
b) From a catalog having its reference.
c) By using a VB macro (described in the CATIA documentation)

2

How to Instantiate a Power Copy (1/4)

From the menu, select:

Insert > Instantiate From Document

3 Select the CATPart file which contains 
your Power Copy.

2 Click on Catalog browser and 
browse for the catalog.

3 After opening the catalog, double-click on 
‘PowerCopy’, then on ‘3 inputs’ and finally on 
‘Drafted_Rib’ to open the instantiation dialog.

OR

OR

Before proceeding, please save all the CATIA documents that are attached to this screen to a local folder. 

Open the CATPart in which you want to instantiate the Power Copy.

2x 2x 2x
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Second step of the instantiation is selecting the geometric inputs of the Power Copy.

3a

How to Instantiate a Power Copy (2/4)

Select the geometric inputs of the PowerCopy as shown. For this example select the 
‘Limiting Surface’ and ‘Rib_Curve_Plane’ as shown.

Now the first two inputs remain the same for all the three green
‘Rib_Curves’. So in this case you can use the ‘Repeat’ option.

3b Select the ‘Repeat’ option, select any one of the three green lines and click OK. Repeat 
the same process for any one of the remaining two green rib lines. 
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You can also change the values of the parameters that you have published during the 
Power Copy creation.

4a

How to Instantiate a Power Copy (3/4)

In this example, we will enter different values for the last rib line.

Enter the values for the parameters as shown and close 
the ‘Parameters’ dialog box.

0.75 deg

2.0 mm

Select the remaining Rib_Curve and click the 
‘Parameters’ button.

4b

Click OK to the ‘Insert Object’ dialog box to instantiate the last rib and then click ‘Cancel’ to dismiss it.4b
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The result of the Power Copy instantiation is inserted after the “in work object”.

How to Instantiate a Power Copy (4/4)

The result of PowerCopy instantiation is a set of editable features. They 
are not linked to the original features of the PowerCopy CATPart.
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What is a Power Copy? Power Copy is a set of design features grouped together to be 

reproduced. It is advanced copy tool. Power Copy tools are available in Insert menu in Part 

design, Wireframe and surface, sheet metal design workbenches.

How to create a power copy? During creation you have to set definition, Identify and name 

inputs, publish parameters, select icon and preview.

How to  save a power copy? Saving of power copy is necessary, if not saved, power copy can 

never be instantiated. This can be done through Insert  > Advanced replication tools > save in 

catalog.

Ways to instantiate a power copy? For instantiation you have to first select power copy which 

is previously created. This can be done through two ways. First way is through catalog and 

second way is from Insert  > Instantiate from document.

Summary

You have learned:
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Creating Catalogs of Components
You will learn the main features of Catalog Workbench and tools to create and 
manage catalogs.

Catalog Workbench Presentation
Browsing Catalogs
Creating Catalogs
Creating Chapters
Creating Families
Creating Keywords
Creating Components
Creating Part Family Components
Referencing Data from External Catalogs
Checking the Catalog Preview
Creating Catalogs in Batch Mode
To Sum Up
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Catalog Workbench Presentation
You will learn about the Catalog Workbench by 

Accessing the Workbench 

Exploring the User Interface

Exploring the Terminologies

Understanding General Process
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A Catalog is a file which provides fast access and pre-visualization of CATIA 
documents and features. It also classifies the documents or features on the 
basis of Chapters, Sub-Chapters and keywords.

A catalog references chapters and end chapters. 
Example: Fasteners can reference Screws, Nuts, Bolts...
Syntax used for creating catalogs and query comes from ‘Knowlegeware’

What is a Catalog?



Student Notes:

CATIA Tools for Proficient Users
����������	��

Copyright DASSAULT SYSTEMES �	

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

Anywhere from the: 

A- Start menu                

B- File / New menu

C- File / Open menu                           
A

B

Accessing the Workbench

Note that when you are in another workbench, 
you can browse existing catalogs using the 
‘Catalog’ tool the ‘Tools’ toolbar.

To create and edit catalogs:

C
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User  Interface: Toolbars

You will get acquainted with Toolbars

Chapter
Toolbar

Tree 
Structure of 
the catalog,
also called 
catalog 
navigator Content 

description and 
preview of the 
catalog entities

Browsing Toolbar

Data (description)
Toolbar
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User  Interface: Commands

Chapter

Link to other Catalog

Part Family

Keyword

Component

Family

Catalog Browser

Part Family Components

Catalog filter Resolved Components

Synchronize chapters
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Family: A set of 
references. Made of 
entities which have the 
same classification.

Terminologies

Component: Reference to an entity. It is displayed 
with its keyword values.
Entities: CATIA documents (CATPart or 
CATProduct...)that are referenced.

1

5

4

Structure tree of the catalog 
indicates if the feature is :
a Catalog
a Chapter
a family 
if the feature comes from 
another catalog

2

3

You will now get acquainted with Catalog terminology.

Catalog: A way of classifying many objects. A V5 
catalog is in the form of a tree structure made up of 
chapters and families.

Chapter: A set of 
references. Made of 
chapters and families.

Keyword: The references are described using 
keywords such as name, type, diameter, length, etc. 
Keywords are then used to make a query in a catalog.
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General Process

Creating a new 
catalog

Browsing 
catalogs...

Insert objects in a 
document
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Browsing Catalogs
You will learn how to search and use objects from catalogs

Catalog browser dialog box
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The Catalog Browser is a tool available in several workbenches which allows you to view 
catalogs. Using the catalog browser, you can have previews and know the descriptions of 
elements referenced in them.You can also sort them out with queries and insert them in your 
current document.

Catalog browser dialog box

What is Browsing a Catalog

Query field to narrow 
down your search

Access to father chapter

Current chapter 
displayed

Query Launcher

Launch the 
supporting 
document in an 
external 
process

Selects another 
catalog

Descriptions table

Elements referenced 
in the current 
chapter

Display Modes

Selected 
element preview
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Click the ‘Up one level’ icon 
to go back to the parent 
chapter

Click on an element 
icon to get its preview

2 x

In a catalog, you can have chapters, families, documents and features that are 
referenced. Here is a way to navigate through them. 
Save and close the GeneralEnd.catalog.

Click the Open icon to select 
a catalog. 

Browsing Catalogs

Click the Catalog 
tool. It opens the 
catalog browser

1
2

Double click a 
chapter icon to 
open it

3

4
You get the preview and the 
description of the selected 
object
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3 Open chapters until you get the  
last chapter in which the 
element you want is referenced.

To insert an object you can also drag and 
drop it into your destination document 

Inserting a Component from a Catalog

Select component in which 
part from catalog  is to be 
added.

1

Use contextual 
menu and copy the  
element

Paste the object 
into your document

4

2

Here is one of the method to insert a component from a Catalog.

Click the Catalog 
icon. It opens the 
catalog browser

5
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While browsing a catalog family, you can apply a filter to sort components 
respecting your query.

Sorting Out Components with Queries (1/4)

1 Have a look at the keywords and note the 

keywords.
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Sorting Out Components with Queries (2/4)

2 Click on this tool

Specify your query for the filter

The ‘Filter’ panel will open.
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The way to build a specification will be different depending upon whether 
the value of the concerned keyword is numeric or alphanumeric.

Sorting Out Components with Queries (3/4)

3

For numeric values (Length, 
Weight…) use expressions like :

x.Length >= 50mm 

x. for “value of...”

Keyword (with 
exact spelling) 

Operator (<=, 
>=, or== for 
comparison) 

Reference 
value (do not 
forget the 
unit!)

Key your specification in the Filter field Click on             to apply the filter4

Only components respecting the 

specification are displayed
5

Same kind of expression 
as for the numeric 
values (but only == does 
work as Operator and 
you need to delimit 
Reference value with ”)

For alphanumeric values (string,…) 
use expressions like :

x.Name ==”H-M6-30”
or

x.Name.Search(“H-M6-30”)>=0

To select all the values of the 
keyword containing the chain of 
characters H-M6-30
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Sorting Out Components with Queries (4/4)

You can also combine effects of two specifications to build a query

Intersection of 
results of both 
specifications

Union of 
results of both 
specifications

Result of first 
specification

6 Apply the first filter condition then you can use 

the ‘add’ operator for next condition.

Original list of 
components

Result of first 
specification
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Creating Catalogs 
You will learn how to create catalogs file from scratch

A catalog
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There are several options to create CATIA V5 Catalogs…

Creating Catalogs

…You can create an 
empty catalog from 
scratch…

…You can save a 
CATPart containing 
Power copies as a 
catalog …

…Or you can save 
CATDrawing files 
containing details 
sheets and dittos as a 
catalog
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1

Activate the catalog workbench using 
the Start or the File > New menu.

A new catalog is created with one 
chapter

Starting the ‘Catalog Editor’ workbench will create an empty catalog with a first 
chapter.

Save the catalog to rename 
it (File > Save As...)

Creating a New Catalog (1/2)

Chapter

2

Chapter.1 can 
be renamed
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Creating a New Catalog (2/2)

Creating a new 
catalog

Adding chapters & 
families

Defining keywords

Linking 
components to 

CATIA documents

Saving the catalog

1

3

4

2

5

Creating a catalog interactively involves the following process
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You can save CATdrawing files containing details sheets and dittos as catalogs

Creating a Catalog from a CATDrawing file (1/2)

1 Select “Save as…”
command from File menu 2 Select catalog for the 

type of the file

Only 2dComponents that are in detail 
sheets will be referenced in the created 
catalog.
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3

Creating a Catalog from a CATDrawing file (2/2)

Save the catalog 
file.

4 The resulting catalog will contain one family 
for each detail sheet of the drawing. Each 
family will contain as many components as 
there were 2D Components in the 
corresponding Detail Sheet.
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Creating Chapters
You will learn how to create chapters.
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A Chapter is a set of references. It references other Chapters or Families.

Chapter Definition Box

Chapter referencing 
another chapter

What is a Chapter?

Chapter 
referencing two 
Families
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2

Select the “Chapter” icon 3

A chapter is a set of references. It can refer to other chapters or to families.

Edit the Chapter under which you 
want to create a new chapter

Type the name of the Chapter

• A Family will reference CATIA 
documents or features whereas a 
Chapter will reference other Chapters or 
Families

• You cannot create any Chapter under a 
Family

Click OK to confirm the chapter creation
The chapter is added in the tree

Adding a Chapter to a Catalog

4

1

5

Open the catalog you want to 
modify (File > Open)
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Creating Families
You will learn how to create families that can contain reference to CATIA 
documents and Features.
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A family is a set of references. It references components  that can be CATIA documents 
(CATProduct or CATPart) or CATIA Features (Details or Power copies).

Family Definition Box

Families

What is a Family?
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2
Select ‘Family’ icon 3

A family is a set of references. It refers to CATIA documents (CATPart or CATProduct) 
or features (Drawing Details or Power Copy)

4

5

Edit the Chapter 
under which you want 
to add the family.

Type the name of the 
family to create

• A Family will reference CATIA documents or features 
whereas a Chapter will reference other Chapters or 
families

• You can not create any Chapter under a Family

Click OK to confirm the 
creationThe new family 

appears in the tree

Adding a Family

1 Open the catalog you want to 
modify (File > Open)
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Creating Keywords
You will learn how to create keywords in order to describe contents of chapters 
and families



Student Notes:

CATIA Tools for Proficient Users
����������	��

Copyright DASSAULT SYSTEMES ��

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

Keywords allow you to characterize references in a chapter or family. Values of 
keywords will help you sort them out when searching for an object (query).

Keywords’
name

Keywords’ value

What is a Keyword?
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2

Activate the Family 
or Chapter in which 
you want to add a 
keyword. 

1

Select the 
Keyword icon

The keywords allow you to characterize the references in the chapter or 
family. Values of keywords will help you to sort out references with queries.

3

Type the name of 
the keyword 

From the list, select the 
desired type of the 
keyword. 

4

The new keyword appears in the 
Table tab in the result window.

6 Click OK 

Creating a Keyword in a Catalog

5 Set the default value 
of the Keyword. 

This option will 
determine if values of 
this keyword are 
visible through the 
browser or not 

To modify a keyword you can use the 
contextual menu on a chapter 
(objectname... > Keywords...) or on a 
component (Keywords...)
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Creating Components
You will learn how to create references to CATIA documents or Features.
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A Component is a reference to an external document or 
feature. 

Description definition box

A component

What is a Component?

Path of the CATIA 
document
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Select the 
Component tool.

A Component is a reference to an external file or feature described with keyword settings.

4

2

Activate the family in which you 
want to add a component

Select the desired CATIA file 

3
Click on 
Select document 
to link a CATIA 
document

In the Keyword tab, set 
values for keywords by 
selecting the keyword 
and typing the value

Description 
is created

6 Click OK

Adding a Component

1

You can edit the 
default name

The path of the selected document 
will be displayed in the File Name 
field

5

The Select external feature button
allows you to select PowerCopies or 
Details.

You can preview the 
associated documents 
(Preview tab)
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Creating Part Family Components
You will learn how to create complete sets of components from single CATPart
file.
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All possible 
configurations of this part 
are stored in the file 
leading the Design Table
(Exel file or tabulated text 
file)

Part Family Components are sets of components generated from a single Part which has 
several configurations referenced in a Design Table. For each configuration described in 
the Design Table, a part family component will be created.

What are Part Family Components? (1/2) 

This icon allows you to 
generate a complete 
family from a single 
CATPart

Keywords will be created directly from 
names of the parameters (columns) in 
the Design Table

In the Design Table where all 
the configurations are 
defined, a column describing 
the  PartNumber is required.
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What are Part Family Components? (2/2)

You can either edit a Chapter
and create a Part Family in it
that references all components 
described by the Design Table

Or you can edit an 
already existing family
and create all references
of components 
described by the Design 
Table in it. 
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Select the “Add 
Part Family”
tool

A Part Family will display several components but all of them will be generated from 
configurations of a single CATpart file. Those configurations are defined in a Design Table.

4

2
Activate the chapter 
under  which you want 
to add the part family.

Select the desired CATIA file 

3 Click on “Select document” to link a CATIA 
document

Adding a Part Family (1/2)

1

In the Design Table where all the 
configurations are defined, a column 
describing the  PartNumber is required.

3
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if not resolved, the description of each 
component will refer to the same .CATPart
File

Adding a Part Family (2/2)

Click OK5

The Part family is created 
and contains as many 
components as the number
of rows in the Design Table 
of the Part.

6

Each component has 
a preview available 
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Select the “add 
Part Family 
Component” tool

A Part Family component is a set of components. All of them will be generated from 
configurations of a single CATpart file. Those configurations are defined in a Design Table .

4

2

Activate the family
under  which you want 
to add the part family
component

Select the desired CATIA file 

3 Click on “Select 
document” to link 
a CATIA document

Adding a Part Family Component (1/2)

You can edit the 
default name

The path of the 
selected document will 
be displayed here.

1

In the Design Table where all the 
configurations are defined, a 
column describing the  PartNumber
is required.

3
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If the part number is not resolved, the 
description of each component will refer to 
the same .CATPart File

Adding Part Family Components(2/2)

Click OK5

The Part family Component is 
created and contains as many 
components as the number of rows 
in the Design Table of the Part.

6

Each component has 
a preview available
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Part Family Resolution (1/2)

Unresolved: Part  Family Components 
refer to the same single CATPart file 
which is driven by a Design Table

Resolved: each component 
refers to its proper CATPart 
File which has no external
Link

You can choose to generate all files corresponding to components of your PartFamily
in a storage folder.
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Part Family Resolution (2/2)

Whole PartFamily resolution Single  PartFamily Component resolution

Path of Storage Folder
is a Setting:
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Referencing Data from External Catalogs
You will learn how to create references to chapters of other catalogs and to 
create sets of components that are the result of a query on an external catalog.
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1 Open the catalog for which you 
want to add a link to an external 
chapter( File > Open)

3

If the Chapter you want to create already exists in another catalog, this 
capability  will allow you to add a link to this chapter from the current catalog

Adding a Link to Another Catalog (1/2)

Open the catalog from which you 
want to get the chapter (File > 
Open)

2

Activate the chapter under 
which you want to add the link.
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Click the “Link to other 
catalog” icon

If the Chapter you want to create already exists in another catalog, this 
capability  will allow you to add a link to this chapter from the current catalog

5 Select the chapter or 
family to import

A new chapter 
appears in the 
receiving Catalog. 

A link has been 
created

If you change anything in the linked chapter it will be changed in both catalogs

Adding a Link to Another Catalog (2/2)

4

When a family or a 
chapter comes from 
another catalog it is 
indicated in the tree.

Family from 
another catalog

Chapter from 
another catalog

If you want to know 
precisely where it 
comes from, use the 
Edit>Links command
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What are Catalog Filter Resolved Components 

Result of a query on 
all components of 
the external catalog

External Catalog

You can create lists of components that are result of filter applied on components of 
an external catalog. Those lists are Catalog Filter resolved Components.



Student Notes:

CATIA Tools for Proficient Users
����������	��

Copyright DASSAULT SYSTEMES ��

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

Catalog Filter Resolved Components (1/2)

Activate the Family

Select the external catalog

Define your query
Validate

1

2 Select the 
command 3

4 5

You first need to select the external catalog and define your query.
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Catalog Filter Resolved Components (2/2)

2 x

Generated components of selected
query

Resolved Query

Components generated from a query are 
referenced as external description

Next step consists in making resulting components of the query available by resolving
the query.

6 Select Generative
Data tab

7 Double click the 
query

8 Click on ‘Apply
Filter’ button.

9 Click on OK
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Checking the Catalog Preview
You will learn how to preview catalog files.

A catalog
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What is Catalog Preview

You will not have the same view of a Catalog whether you open it with the Catalog 
Editor or with the Catalog Browser.

Catalog Editor

Catalog Browser

Browser icon is available in the Catalog 
Editor workbench in order to browse the 
Catalog currently edited. Let us have a look 
at the differences between the views.
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Catalog Preview (1/2)

You have a global 
view of the structure 
of your catalog

Structure tree of the catalog 
indicates if the feature is :
a Catalog
a Chapter
a family 
if the feature comes from another 
catalog

The Table tab displays all 
the contents of the active
Chapter or Family

The active Chapter or Family 
is Highlighted

View from the Catalog Editor...

To get a Chapter or a 
Family active, just double 
click on it



Student Notes:

CATIA Tools for Proficient Users
����������	��

Copyright DASSAULT SYSTEMES ��

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

Catalog Preview (2/2)

View from the Catalog Browser...

You can load the 
currently edited 
Catalog by 
clicking on this 
icon

The folder icon behind the main icon indicates that there is a content. 
Content can be Chapters , Families or Components. When you do not have 
folder icon behind the main icon        , it means that there is not content and 
that it is a Component

To see the content 
of an element, just 
double click on it

2 x

2 x

To see the details 
of an element, just 
double click on it
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Keywords Visibility

You can control the visibility of a keyword in the browser.

In contextual menu of the family, select 
“Keywords Default values”

1



Student Notes:

CATIA Tools for Proficient Users
����������	��

Copyright DASSAULT SYSTEMES �


C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

Keywords Visibility

Deactivate this option

Select the 
keyword 2

3

Click on OK

4

You will hide the Part 
number in the display
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Creating Catalogs in Batch Mode
You will learn how to create catalogs in batch mode using Text or Excel files 
and macros. 

Definition file

.csv
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CATIA documents 
(parts or assemblies)  
referenced in catalogs

Catalog files generated after 
running a macro 

Macro scripts used to generate catalogs

Text or Excel files (.csv format) used to create &    
define, and modify catalog content

Reports generated by macros

Sample source files

Catalogs can be stored with parts they reference. Otherwise, the Search Order must be correctly set

What is Behind Catalogs ?
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How Does it Work ?

.csv

.csv

Catalog in CATIA Chapter definition 

End-chapter definition 

CATIA document

MacroChapter

Family

Filenames of parts

Filenames of 
catalogs

Terminology:
A chapter references catalogs 
An end-chapter references CATIA parts / products
Keywords are used in queries to search for parts
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.csv

E:\users\images\screw.bmp

.cs
v

When you create catalogs of parts, you define 
chapters and families (see example below)

Save the files as .csv (usable on UNIX)

You can check the report resulting from the 
catalog creation

Edit csv files: define chapters and families, 
keywords, names of referenced catalogs or parts & 
products, and component characteristics 

(Knowledgware syntax)

CATIA settings:  reference (if not already done) the 
CclTypeLib library from intel_a\code\bin using Tools > 
Options > General > Automation > Add

2

3

4 Edit macro BuildCatalog.CATScript (input & output 
catalog names & location) & Run it

You can customize a catalog 
icon by entering the location 
and name of the image to be 
used in cell C1 of the table

5
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Note that you can define absolute location of catalogs and parts

1

You can have one macro per catalog. Then, you do 
not need to edit the macro each time (input / output 
names already defined)

Creating Catalogs in Batch Mode
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Create Catalog. You can create empty Catalog, CATPart containing Power copies as Catalog, 

CATDrawing containing detail sheets and dittos as Catalog

Create Chapters. A Chapter is a set of references. It will refer to other Chapters or Families.

Create Families. A Family is a set of references. It refers components that can be CATIA 

documents (CATPart or CATProduct) or CATIA features (Details or Power copies).

Create Keywords. Keyword allows you to characterize references in a Chapter or Family. 

Values of Keywords will help you sort them out when searching for an object.

Create Components. A Component is a reference to an external document or feature. The 

components keyword values are displayed.

Reference data from external Catalogs. Create references to chapters of other catalogs and to 

create sets of components that are the result of a query on an external Catalog.

Create Catalogs in Batch mode. Creating Catalogs in batch mode using text or excel files and 

macros.

To Sum Up ...

You have learned how to:
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You will learn how to read a simple CATIA V4 model and copy it into a 
V5 document, and to manage your visualization using layers and filters

Working with a CATIA V4 Document

From CATIA V4 to V5 Basics
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Working with a CATIA V4 Document
You will learn how to copy CATIA V4 data in CATIA V5

V4 model loaded in CATIA V5
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About CATIA V4 and CATIA V5 Analogy 

.CATPart.Model

.CATDrawing

.CATProduct

.Catalog

.Model

.session, .asm, ditto

.lib

Solid, Surface and
Wireframe

Drawing

Part Positioning

Library

V4 Files V5 FilesData
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User Interface: CATIA V4,V3,V2 Workbench

Geometry Check : Check by transferring the solid’s geometry through Copy-Paste 
Special as CATIA_Result

Using the Check Tools

Geometry Specification : Check by transferring the solid with  geometry and the 
history tree through Copy-Paste Special as CATIA_Spec

V4 Integration 
workbench

Check Tools
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About Copy and Paste Options

CATIA_RESULT: the result is a Boundary Representation 
feature i.e. Brep feature

Example:  V4 surface becomes a surface in an Open 
Body & V4 solid becomes a Solid in a Part Body

CATIA_SPEC: the result is a full Spec containing entire 
history of the actions performed to obtain the V5 Part.

Note : you can modify the features in the history tree

Using the Paste Special Tools
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In CATIA V5 you can read a V4 model, check its content, and manipulate the 
geometry, but not save it directly. First, you need copy it into a V5 document.

There are two methods:

What are the Different Methods ?

A B

Copy without history Copy with history

A simple copy generates a Solid 
object which cannot be modified but 
can be used as reference

A special copy takes into account the V4 
specifications and generates V5 features. 
You can edit the part body as well as the 
features (as shown on right picture) 
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General Process

Interactive mode using:
Copy���� Paste Special����CATIA_SPEC

+
Update

Using Part Design Workbench 
capabilities to analyze/check 
the result CATPart 

Batch mode (not covered in this 
course)

Saving the integrated 
document 
As a .CATPart

43

Before Copying the CATIA model: 
Checking its 

Geometry and Specifications

Integrating V4 CATIA model to 
CATIA V5 CATPart Document  

Two ways of doing :

From CATIAV4,V3,V2 workbench
Opening & Visualizing a CATIA 
model

2

1
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You need to check either the geometry or the specification of CATIA V4 
model data

2
The Check Validity dialog box appears

Click Geometry 
Check icon

Open the CATIA V4 model and 
select one or more geometrical 
elements in the geometry area 

Checking CATIA V4 Model Data before Copying it to CATIA V5 
Document (1/2)

CATIA V4Integration workbench & 
toolbar "3 operations not implemented" : 3 operations will

be unavailable in a migration to CATIA V5.

Click Specifications Check icon. The 
Check Validity dialog box appears

3

You can transfer the solid’s geometry 
only through copy - paste special - As a 
Result. 

1
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To view the results of a specification check,
double-click on the contents of the selected 
line  in the Check Validity dialog box. 

The $ symbol means that the 
Pipe item is an unresolved 
feature in V5 (same symbol in 
the V4 tree).

Checking CATIA V4 Model Data before Copying it to 
CATIA V5 Document (2/2) 

4

5 Right-click the red element 
to discover the problem

In the Check Validity dialog box there are four columns:  
The first column showing the overall result, color-coded as follows:  
G (green): will be copied as is to CATIA Version 5. The check is OK. 
R (red): will NOT be copied to CATIA Version 5 as is. This is a KO Check. 
Y (yellow): will NOT be copied to CATIA Version 5 as is because of a link to a red-coded   
item. This is KO Check due to the element supporting by the solid.

CATIA identifies the identifier & the format i.e. Specifications 
The Message column provides the number and type of problems.
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2

File > Open

Open a (new) V5 
document

V4 
Workspaces

1

V4 Integration 
workbench & tools

Select mode
Geometry check

3 Click V4 geometry (if simple 
part) or the desired object in 
the tree, then Copy (Edit 
menu or MB3)

4

Click in V5 tree, 
then Paste Special 
(Edit menu or MB3) Click CATIA SPECS then 

OK to keep the V4 model 
history

Edit > Update the 
geometry to visualize it

7

Double click 
MASTER to 
see its content

Copying a CATIA V4 Solid into CATIA V5 

6

Resulting tree.5
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To Sum Up ...

Draw analogy between CATIA V4 and V5 data.

Manage CATIA V4 Documents with CATIA V5 using copy paste options.

Check CATIA V4 data before copying it to CATIA V5 data.

You have learned how to:
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Creating and Using Power copies

Creating Catalogs of Components

Working with documents from CATIA V4 to V5

You have seen some advanced functionalities of CATIA V5 such as :

Course Summary


