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Introduction to CATIA

About this Course 

Introduction
CATIA is a robust application that enables you to create rich and complex designs. The aim of the 
CATIA V5 Fundamentals course is to teach you how to build parts and assemblies in CATIA, and 
how to make simple drawings of these parts and assemblies. This course focuses on the 
fundamental skills and concepts that enable you to create a strong foundation for your designs.

Course Design Philosophy
This course adopts a process- or task-based approach to training. Rather than focus on individual 
features and functions, it emphasizes the process and procedure to complete a particular task. 
Using case studies that illustrate these processes, you will learn the necessary commands, 
options, and menus within the context of completing a design task.

Target audience
The target audience for this course are new CATIA V5 mechanical designers.

Prerequisites
Students attending this course should have:

5 days
• Experience in Mechanical design.

• Experience of using the Windows operating system
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About the Student Guide

Using the Student Guide
This student guide is intended to be used under the guidance of a certified CATIA instructor. It 
contains examples and case studies that are designed to be demonstrated by the instructor.

Exercises/Case Studies
This course illustrates the process-based approach in two ways: exercises and case studies. 
Exercises give you the opportunity to apply and practice the material covered during the 
lecture/demonstration. These exercises have been created to represent typical design and 
modeling situations. Extra exercises have been included in this guide to accommodate students 
who may want to practice more modeling. 
Case Studies provide a context in which you would use particular tools and methods, and illustrate 
the process flow you would typically follow to complete a project.
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Conventions Used in the Student Guide

The following typographic conventions are used in 
the student guide:

� Bold blue text within a sentence denotes options selected 
from the CATIA menu bar. 

� Bold brown text denotes the name of a tool, icon, button, or 
window option. 

� Italic text within a sentence is used to apply emphasis on 
key words. 

� Numerical lists are used in sequential lists, such as the 
steps of a procedure. 

� Lower-case alphabetical sub-lists are used in sequential 
sub-lists, such as the sub-steps in an exercise procedure. 

� identifies areas in a picture that are associated with 
steps in a sequential list, such as in an exercise. 

� Upper-case alphabetical lists are used in non-sequential 
lists, such as a list of options or definitions. 

� Text enclosed in < > brackets represents the name of the 
keyboard key that must be pressed. 

� Text enclosed in [ ] brackets corresponds to the text that 
must be entered into a text field of a CATIA dialog box or 
prompt. 

� Information whose availability depends on a particular 
configuration is marked using the symbol: 

2b

Example page:
Use the following steps to create a new document 
in CATIA:

1. Click Start > Mechanical Design > Part 
Design.

2. Create new part.
a.Click File > New.
b.Select Product from the New dialog box.
c. Click OK.

d.Press <CTRL> + <S> to save the 
document.

e.Type [my first document] as the document 
name.

You can create the following profile types: 
A. User Defined Profiles
B. Pre-Defined Profiles
C. Circles A B

2b

Conf. Dep.
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Case Study: Introduction to CATIA

Each lesson in this course contains a case study, which helps explain the skills 
and concepts covered in the lesson. The case study will be described at the 
beginning of each lesson, and the student will be able to do the case study 
exercise once the theory for that lesson has been covered. 
All models used in the case studies come from the Drill Press assembly, which is 
also your master project. In this lesson, you learn how to open and navigate 
models in CATIA. 

Part 
Design

Product
Design

Generative 
Drafting

•Exercises •Exercises •Exercises

Familiarization

•Exercises

Master Project(Case Study)
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Design Intent

Each case study contains a set of model 
requirements, known as the design intent. Design 
intent is discussed later in this lesson. The first case 
study does not contain a design intent because you 
are not going to design anything.  However, by the 
end of this lesson you should be able to:

� Change the orientation of a model.

� Change the visualization properties 
of a model.

� Manipulate the specification tree.

� Access the Help system of CATIA.
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Stages in the Process

Each lesson consists of steps. Each step contains the 
information you need to complete the case study and 
maintain its design intent.

For Lesson 1, you will go through the following steps to 
introduce yourself to CATIA:

1. Understand the CATIA software.

2. Open CATIA.

3. Understand the CATIA interface.
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Understand the CATIA Software
In this section, you will learn about PLM and how it relates to CATIA. This section also 
introduces the key features of CATIA.

Use the following steps:

1. Understand the 
CATIA software.

2. Open CATIA.
3. Understand the CATIA 

interface.
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PLM – Product Lifecycle Management

PLM is a set of standards used by companies to successfully maintain innovation in 
engineering and reduce manufacturing costs.

PLM can be defined as follows:

A strategic business approach that applies a consistent set of business solutions in support 
of the collaborative creation, management, dissemination, and use of product definition 
information across the extended enterprise from concept to end of life – integrating people, 
processes, business systems and information.

Source: CIMdata Inc.
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• PLM breaks down the barriers in technology that have so far limited the interaction between 
people who design products and people who build, sell, buy, and use them. 

• Using the collaborative power of Dassault Systemes Solutions, people can now experience 
PLM with organizations beginning to create and develop innovative product design, while 
reducing cycle times, streamlining manufacturing, and cutting production costs.

• Let’s see a real-life example of how PLM can change people’s experiences as innovators, 
manufacturers, and consumers…

PLM in Practice

Searching for a new bike!
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For the following functions CATIA plays an integral part of the PLM solution:

CATIA Within the PLM Solution

Purchasing

Test
Maintenance

Analysis

Suppliers

Planning

Engineering

Simulation
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CATIA’s Scope  From Concept To Realization

• CATIA acts as the backbone for concept, product definition, manufacturing, simulation, and 
after-market information found within various lifecycle stages of a product.

• It provides the specifications and geometrical data related to a product across several lifecycle 
phases.

������� �	
����� 
���	�� ��
	��� �
���� �������
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What is CATIA V5?

CATIA is a mechanical design software. It is a feature-based, parametric solid modeling design 
tool that takes advantage of the easy-to-learn Windows graphical user interface. You can create 
fully associative 3D solid models, with or without constraints, while using automatic or user-defined 
relations to capture the design intent. 

To clarify this definition, the terms that are in italics above will be explained in the coming pages:
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Key Terms (1/4)

Like an assembly is made up of a number of 
individual parts, a CATIA document is made up of 
individual elements. These elements are called 
features.

While creating a document, you can add features 
such as pads, pockets, holes, ribs, fillets, 
chamfers, and drafts. As the features are created, 
they are applied directly to the work piece.

Features can be classified as sketch-based or 
dress-up:

• Sketch-based features are created using a 2D 
sketch. Generally, the sketch is transformed 
into a 3D solid by extruding, rotating, sweeping, 
or lofting.

• Dress-up features are created directly on the 
solid model. Fillets and chamfers are examples 
of this type of feature.

Feature-based
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Key Terms (2/4)

CATIA graphically displays the feature-based 
structure and other non-graphical data of your 
model in the form of a specification tree. The 
specification tree shows the sequence in which 
the features were created, and enables you to 
easily access all the underlying associated 
information and elements. You will learn more 
about the specification tree throughout this 
course.

Feature-based (continued)
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Key Terms (3/4)

Parametric

The dimensions and relations used to create a feature are stored in the model. This enables you 
to capture the design intent, and to easily make changes to the model using these parameters.

• Driving dimensions are used while creating a feature. These include the dimensions that are 
associated with the sketched geometry, as well as dimensions that are associated with the 
feature itself. Let us consider the example of a cylindrical pad. The diameter of the pad is 
controlled by the diameter of the sketched circle, and the height of the pad is controlled by the 
depth to which the circle is extruded.

• Relations include information such as parallelism, tangency, and concentricity. This type of 
information is typically communicated in the drawings using feature control symbols. By capturing 
this information in the sketch, CATIA enables you to fully capture your design intent in the initial 
stage itself.

Solid Modeling

A solid model is the most complete type of geometric model used in CAD systems. It contains all 
the wireframe and surface geometry necessary to fully describe the edges and faces of the 
model. In addition to geometric information, solid models also convey their topology, which relates 
the geometry together. For example, topology might include identifying which faces (surfaces) 
meet at which edges (curves). This intelligence makes it easier to add new features. For example, 
if a model requires a fillet, you simply select an edge and specify a radius to create it.



Student Notes:

CATIA V5 Fundamentals- Lesson 1: Introduction
����������	��

Copyright DASSAULT SYSTEMES 1-17

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

Key Terms (4/4)

Fully Associative

A CATIA model is fully associative with the drawings and parts or assemblies that reference it. 
Changes in the model are automatically reflected in the associated drawings, parts, and/or 
assemblies. Likewise, changes in the context of the drawing or assembly are reflected back in 
the model.

Constraints

Geometric constraints (such as parallel, perpendicular, horizontal, vertical, concentric, and 
coincident) establish relationships between the features of a model by fixing their positions 
with respect to one another. In addition, equations can be used to establish mathematical 
relationships between parameters. By using constraints and equations, you can guarantee 
that design concepts such as through holes and equal radii are captured and maintained.
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Design Intent (1/3)

Design Intent is the plan of how to construct the solid model of a part in order to properly 
convey its visual and functional aspects. In order to efficiently use a parametric modeler like 
CATIA, you must consider the design intent before and while modeling the part. The 
techniques used to create the model will affect how the model behaves when it is changed 
during its life cycle. 

The manner in which a solid model is built can affect many aspects, including its flexibility to 
change, its stability during the change process, and the resources it requires to compute a 
new result. Therefore, it is important to take the design intent into account for creating an 
efficient solid model of the part.

The following factors contribute to how the design intent is captured:

� Automatic (Implicit) Relations: Based on how the geometry is sketched, automatic 
relations provide common geometric relationships between objects, such as tangency, 
parallel, perpendicular, horizontal, and vertical.

� Equations: Equations relate the dimensions mathematically; they provide an external way 
to force changes.

� Additional Relations: Relations that are defined while creating the model provide another 
way to connect related geometry. Some common relations are concentric, coincident, and 
offset.

� Dimensioning: The manner in which a sketch is dimensioned impacts the design intent. 
You must add dimensions in a way that reflects how you would like to change them to 
control the elements.
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Design Intent (2/3)

The following examples show different design intents for the 
same sketch:

A. This sketch is dimensioned to keep the holes at a 
distance of 20mm from the left and right edges, 
regardless of the overall plate width (110mm).

B. Baseline dimensions keep the holes positioned relative 
to the left edge of the plate. The positions of the holes 
will not be affected if the width of the plate is changed.

C. Dimensioning from the left edge, and then from the 
center of the first hole to the center of the second hole 
maintains their distance from the left edge and between 
themselves, regardless of the overall plate width.

C

B

A
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Design Intent (3/3)

The example below shows a simple hand-drawn sketch of a modeling plan that details the complete 
design intent of the part. This type of pre-planning, even before starting to model the part using 
CATIA, is an excellent strategy to ensure the desired outcome is clear and precise. 
Through pre-planning, you can become efficient at creating a robust model design that provides 
both flexibility and stability during modifications.
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How Features Affect Design Intent (1/2)

In addition to how a sketch is dimensioned, the choice 
of features and the modeling methodology affect the 
design intent. Consider the stepped shaft (Final 
Result) shown below. You can build this part in several 
ways:

A. "Layered" Approach

• The layered approach builds the part one 
piece at a time, adding a layer or feature 
onto the previous one until the desired 
solution is obtained.

• Changing the thickness or the shape of one 
layer has a ripple effect; it changes the 
position or location of all the other layers that 
were created after it.

+

+

+

+

A

Final Result
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How Features Affect Design Intent (2/2)

You can build this part in several ways (continued):

B. "Potter's Wheel" Approach 

• The potter's wheel approach builds the part 
as a single, revolved feature. A single 
sketch, representing the cross-section, 
includes all the information and dimensions 
necessary to make the part as one feature. 
While this approach may seem the most 
efficient, having all the design information 
contained within a single feature limits 
flexibility and can make changes difficult.

C. "Manufacturing" Approach 

• The manufacturing approach to modeling 
mimics the way the part would be 
manufactured. For example, if this stepped 
shaft was turned on a lathe, you would start 
with a piece of bar stock and remove 
material using a series of cuts.

-

-

-

B C
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Exercise: Design Intent
Recap Exercise

20 min

In this exercise, you will identify and describe the key terms of CATIA and identify the 
design intent for various parts.

By the end of this exercise you will be able to:

� Define the key terms of CATIA

� Identify and describe the design 
intent for various parts
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Do it Yourself

Identify the correct definition for the following 
terms:

----- Solid modeling
----- Feature-Based
----- Parametric
----- Constraints
----- Design Intent
----- PLM

A. Geometric elements, such as pads, 
pockets, holes, ribs, fillets, chamfers, etc. 
that are applied to a work piece to form a 
part. 

B. A geometric model that contains all the 
topology, wireframe and surface geometry 
necessary to fully describe the edges and 
faces of a part. 

C. The dimensions and relations used to 
create a feature are captured and stored in 
the model. 

D. The plan that explains how to construct or 
develop the solid model of a part, in order to 
properly convey the visual and functional 
aspects of the part.

E. A strategic business approach that applies 
a consistent set of business solutions in 
support of the collaborative creation, 
management, dissemination, and use of 
product definition information across the 
extended enterprise, from concept to end of 
life.

F. Geometric relationships, such as parallel, 
perpendicular, horizontal, vertical, 
concentric, and coincident, or equations to 
establish mathematical relationships among 
parameters. 
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Exercise Illustration

Using the drawings, identify all items that should 
be reflected in the design intent:

Support Plate

Suspension Arm

Suspension Arm

Support Plate



Student Notes:

CATIA V5 Fundamentals- Lesson 1: Introduction
����������	��

Copyright DASSAULT SYSTEMES 1-26

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

Open CATIA
In this section, you will learn how to open CATIA in a Windows environment.

Use the following steps:

1. Understand the CATIA 
software.

2. Open CATIA.
3. Understand the CATIA 

interface.
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Starting CATIA Using the Start Menu

In a Windows environment, you can start the CATIA application in several ways:

A. Select CATIA from the Start > Programs > CATIA menu.
B. Double-click the CATIA icon on your Windows desktop.
C. Double-click on an existing CATIA document.

C

B

A
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Opening an Existing Document

Use the following steps to open an existing 
document within CATIA:

1. Select File > Open, or click the Open icon.

2. Browse to the file’s location using the Look 
in list of the File Selection dialog box.

3. In the Files of type list, select the type of 
document you want to open.

4. Select the Show Preview checkbox to see a 
preview of the selected file.

5. Click Open.

1

5

4

3

2

Note that if you are working in an environment 
where CATIA V5 is connected to a Product Data 
Management (PDM) system, CATIA documents 
will not be stored as files on a local disk, but will 
be managed by the PDM system. The interface 
will differ from that shown above.
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Understand the CATIA Interface
In this section, you will become familiar with the CATIA User interface.

Use the following steps:

1. Understand the CATIA 
software

2. Open CATIA
3. Understand the CATIA 

Interface
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Windows Philosophy (1/4)

CATIA V5 is specifically designed for the Windows operating environment, and it behaves in the 
same manner as other Windows applications.  

Traditional menus provide access to all the CATIA commands. 

Some menu options have additional options related to them:

A. An arrow pointing to the right indicates a sub-menu.  

B. A command name followed by a series of dots indicates 
that selecting the command will open a dialog box with 
additional options.

A

B
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Windows Philosophy (2/4)

Toolbars contain icons for quick access to the most 
frequently used commands. Toolbars are organized 
into workbenches. They can be customized, 
rearranged, and relocated as per your preferences.

For example, the Standard toolbar contains 
commands to open, save, print, cut, undo, and 
access online documentation.

Some toolbar icons have additional icons related to 
them:

A. An arrow (pointing downwards) besides an icon 
means more tools of the same type are 
available under it.  

A
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CATIA V5 uses a three-button mouse for selecting and indicating input from the user.  
Mentioned below are the general functionalities of the mouse buttons. A complete 
description of their use will be covered later.

Windows Philosophy (3/4)

A

B

C

A. The left mouse button is used to the select 
displayed elements or items on the screen.

B. The center mouse button (or the thumb wheel) is 
used to indicate or point to a direction on the 
screen.

C. The right mouse button is used to display a 
contextual menu for the currently selected or pre-
selected elements on the screen.
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CATIA provides various levels of system feedback to users, such as:

Windows Philosophy (4/4)

A. The mouse cursor is represented by different 
symbols to indicate various statuses.

B. Messages are displayed to convey 
information about the progress, failure, or 
result of a procedure.

C. A ToolTip and a short help message is 
displayed when you place the mouse cursor 
over a particular tool (without selecting it).

C

A

B
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Introduction to V5 Documents

You can create, modify, and save different types of 
documents in CATIA. These documents contain the 
geometrical information and specifications that define an 
object. The most common documents are:

A. A part document (.CATPart)

B. An assembly document (.CATProduct)

C. A drawing document (.CATDrawing)

C

B

A



Student Notes:

CATIA V5 Fundamentals- Lesson 1: Introduction
����������	��

Copyright DASSAULT SYSTEMES 1-35

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

The Workbench Concept

To work on a CATIA document, you must use 
one of the workbenches assigned to the 
document type. Each workbench contains a set of 
tools that is dedicated to perform a specific task. 
Following is a list of workbenches that are most 
commonly used:

Current workbench’s icon 

Documents

• Part Design: For designing parts using the 
solid modeling approach

• Sketcher: For creating  2D profiles with 
associated constraints, which can then be 
used to create other 3D geometry.

• Wireframe & Surface: For creating  
complex part features with 3D wireframe and 
surface elements.

• Assembly Design: Create constraints, 
features, and specifications for parts in the 
context of an assembly.

• Generative and Interactive Drafting: 
For creating  drawings from parts and 
assembly designs.
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CATIA User Interface (1/2)

CATIA’s user interface adopts the Windows interface, 
and contains the following key features.

• Separate workbenches and their respective 
toolbars

• Easy navigation from one workbench to another

• Standard and specific menus & toolbars (File, 
Edit, Insert...)

• Standard manipulations (Copy-Paste, Drag-and-
Drop, Edit in Place...).

• Intuitive (highlighting, copilot, pointer shapes...).

• Multi-document support

• Contextual menu (MB3) support

• Specification tree, which includes technological 
features, constraints, and relationships



Student Notes:

CATIA V5 Fundamentals- Lesson 1: Introduction
����������	��

Copyright DASSAULT SYSTEMES 1-37

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

CATIA User Interface (2/2)

Below is the layout of the elements of the standard 
CATIA application:

A. Menu Commands

B. Specification Tree

C. Window of the active document

D. Filename and extension of current document

E. Icons to maximize, minimize, and close the 
window

F. Icon of the active workbench

G. Toolbars specific to the active workbench

H. Standard toolbar

I. Compass

J. Geometry area

A

B

C
D E

F

G

H

I

J
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Workbenches contain various tools that you may 
need to access while creating a part. You can 
switch between any primary workbench using the 
following two ways:

Workbenches (1/2)

A. Use the Start menu to open the required 
workbench.

B. Click File > New to create a new 
document of a particular file type. The 
associated workbench automatically 
opens.

B

A
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You can create an direct access to a favorite 
workbench in the Start menu as follows:

Workbenches (2/2)

A. Click Tools > Customize to access the 
dialog box.

B. Using the Start Menu tab, select the 
workbench from the list.

C. Select the arrow to add the workbench to 
the Favorites list.

D. Click Close to exit. 

E. The workbench will be displayed when the 
Start menu is next selected.

B

A

C

D

E
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Toolbars provide quick access to tools that are also available in the menus. Use the 
following steps to activate/deactivate a toolbar:

Menus and Toolbars (1/3)

1. Click View > Toolbars.

2. A list of toolbars is shown with respect to the 
current workbench. 

3. Activated toolbars have checkmarks beside 
them.

4. Select a particular toolbar to activate or 
deactivate it. 

1

2
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Menus and Toolbars (2/3)

You can further manipulate toolbars to close, reorganize, or 
display them:

A. Click Close to deactivate a floating toolbar.

B. Reorganize the toolbars by dragging the 
separator of any toolbar and moving it to 
another location on the screen. 

C. A double-arrows (>>) symbol in the corner of 
the toolbar area indicates that there are 
more tools available, but are not visible due 
to the window’s size. Drag the symbol to the 
Geometry Display Area to view these tools.

B

C

A
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Menus and Toolbars (3/3)

You can reset the original toolbar configuration 
as follows:

B

A. Click Tools > Customize to access the 
dialog box.

B. Using the Toolbars tab, click the Restore 
Position button.

C. Confirm by clicking OK.

D. The floating toolbar will be reset to its original 
fixed position.

E. Click Close to exit. 

C

E

D



Student Notes:

CATIA V5 Fundamentals- Lesson 1: Introduction
����������	��

Copyright DASSAULT SYSTEMES 1-43

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

Finding Tools

Since CATIA contains a large number of tools and 
toolbars, it is not possible to display all of them within 
the limited window space. CATIA manages this using 
collapsible toolbars and by stacking extra toolbars at 
the corners of the window.

If you are unable to find a tool/toolbar, ensure that:

A. the tool you are looking for is not located as a 
“fly out” optional tool. CATIA groups variants 
of the same tool into a single display group, 
which can be accessed by clicking the black 
arrow.

B. the tool/toolbar is not located outside the 
display area. Look for the >> symbols at the 
corners of the window. You can drag the 
toolbar out to see all the tools.

C. the toolbar is active.

C

A

B
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The Specification Tree

CATIA V5 provides a specification tree, which keeps 
the hierarchy of features, constraints, and processes, 
and the assembly information for a CATIA document. 
The specification tree provides a visual step-by-step 
record of the sequence followed while creating a solid 
model.

You can edit, reorder, or remove steps in the design 
process and specifications to achieve a new finished 
part without having to recreate the model. 

The specification tree can suppress certain features 
and information by temporarily removing them from 
consideration for the model.

For example, the model on the right contains several 
hole features. You can simply “turn off" (suppress) the 
holes and have the model reflect the base area 
without actually deleting the holes. 
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Manipulating the Specification Tree

CATIA allows you to manipulate the specification tree in a manner similar to the geometric 
area.
Refer to the list below for more information:

Manipulation Action Description

Hide the tree Press the <F3> key to hide or 
show the tree.

Activate/Deactivate 
the tree

Click anywhere on the tree structure or 
press <Shift> and <F3> simultaneously to 
activate or deactivate the tree.

Or
Shift+

Move the tree Drag and drop the tree structure using the 
left mouse button.

Expand/Collapse a 
node of the tree

Click on the [+] sign to expand the node, 
and on the [–] sign to collapse it.
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Selecting Objects with the Mouse

CATIA, like any other Windows environment 
application, has an interface that is primarily 
mouse-driven. When working in CATIA, there are 
two ways to select the objects: 

A. Simple Selection 
• To select an object, press the left mouse 

button.
• You can select an object directly from the 

model or by selecting its corresponding 
feature in the tree. Selecting the geometry 
highlights the tree feature and vice versa.

B. Multi-Selection
• To multi-select, press the <Ctrl> key while 

using the left mouse button to select the 
objects.

• Multi-selection can also be done by trapping 
objects within a selection area.

+

+

B

A
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To display the Pre-selection Navigator automatically, 
select Tools > Options then the Navigation tab. Check 
the Pre-selection Navigator button.

The Pre-selection Navigator

In certain cases the element that you wish to select is 
not visible, for example, an internal or hidden face. To 
select the rear face of the example part shown:

�

�

�

�

A. Position the cursor at a position where the face 
would be located.

B. Select the Right or Left arrow on the keyboard to 
display the Pre-selection Navigator. The nearest 
element will be pre-selected by default.

C. Select the Up or Down arrow to scroll through the 
displayed list of elements until the required 
element is highlighted.

D. Click within the circular zone to select the element.

B

A

D

C

Note: once the Pre-selection Navigator is displayed, the 
left/right arrows can then be used to scan the model feature 
hierarchy i.e. the parent features of the pre-selected element.
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The Object/Action and Action/Object Approaches

CATIA is different than other Windows application. You can control the order of selection for 
the elements and tools. You can either:

A. First select the object(s) to be processed, then select the tool required to perform the 
operation.

B. First select the tool required to perform the operation, then select the object(s) to be 
processed.

A B
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Using the CATIA Dialog Boxes (1/2)

The CATIA dialog boxes provide various parameters for the definition of features. They are 
standardized and easy-to-use to define the inputs for a feature or a process. For example, the Hole 
Definition dialog box is shown below. 

Following is a list of common items you might find in a CATIA dialog box:

A. Name of the dialog box

B. Tabs that group similar types of 
parameters

C. Drop-down list box for various options

D. Spin box to increase or decrease the 
input value

E. Locked fields to protect data

F. Iconic buttons to activate other actions

A

B

C

D

E

F
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Using the CATIA Dialog Boxes (2/2)

The following lists common items you might find in a window (continued):

G. Check boxes to activate the options

H. Inactive fields that do not apply to a particular 
case

I. OK button to confirm the action

J. Cancel button to quit the command

K. Preview button to pre-visualize the result

L. Help for the dialog box dialog box

M. Close button to close the dialog box

N. Visual Aid Assistants to show the intent of the 
selected options

G
H

I J K

L M

N
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Using Dialog Boxes and Right-click

Data can also be entered into certain fields of a dialog box by clicking the right mouse 
button (right-clicking) on them. The options that appear in the contextual menu are 
dependent on the type of data that the field is capable of receiving.
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Moving Objects with the Mouse (1/3)

Since CATIA is a 3D environment, you can 
view the model in various ways. 

The easiest way to change the view of a 
model is to zoom, pan, and rotate it.

pointer

A. Panning enables you to move the model on 
a plane parallel to the screen. It involves 
dragging the mouse while clicking and 
keeping the middle (#2) mouse button 
pressed.

B. Rotating enables you to turn the model 
around a point. It involves dragging the 
mouse while clicking and keeping the 
middle (#2) and left (#1) mouse buttons 
pressed.

B

A
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Moving Objects with the Mouse (2/3)

The easiest way to change the view of a model 
is to zoom, pan, and rotate it (continued…)

C. Zooming enables you to move closer to the 
model or away from it along a plane 
perpendicular to the screen. It involves 
clicking and keeping the middle (#2) mouse 
button pressed while clicking the left (#1) 
mouse button once, and then dragging the 
mouse up (to move closer) and down (to 
move away).”

C
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Moving Objects with the Mouse (3/3)

To centralize an object on the screen simply 
click the middle (#2) mouse button on the 
geometry that you wish have at the center of 
the screen. The orientation and the scale of the 
view will remain unchanged.

To see all displayed objects, click the Fit All In
tool.



Student Notes:

CATIA V5 Fundamentals- Lesson 1: Introduction
����������	��

Copyright DASSAULT SYSTEMES 1-55

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

Compass (1/2)

Besides being an orientation reference tool that 
helps while performing view rotations, the 
Compass is a powerful tool that can be used to 
physically move and manipulate objects. This is 
especially useful in Assembly Design, 
Freestyle, and Digital Mockup workbenches. 

By default, the base of the Compass (also 
called the Privileged Plane) is the XY plane.
The default orientation of the compass is 
parallel to the reference XYZ axis system and 
is located to the top right corner of the screen.

If the 3D view is changed, the Compass 
updates its orientation to reflect the new 
viewing angle/direction.
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Graphic Properties

The Graphic Properties toolbar enables you to change various 
graphical properties of elements displayed on the screen.
It provides tools to change the following properties:

A B C D E F G H

A. Fill color

B. Transparency

C. Line thickness

D. Line type

E. Point symbol

F. Rendering style

G. Active Layer

H. The Painter tool copies the graphic 
properties of one feature to another 
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Changing the Graphic Properties

Use the following steps to change the graphic properties of an 
element:

1. Select the element(s) using the left mouse 
button. 

2. Right-click and select Properties in the 
contextual menu.

3. Select the Graphic tab, and  change the 
required graphic properties. 

1

2

3
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Rendering Styles

CATIA has the ability to apply different styles of 
rendering to visualize the geometry and provide 
more clarity to the model. The View toolbar 
contains the rendering styles of:

A. Shading (SHD)

B. Shading with Edges

C. Shading with Edges without smooth Edges

D. Shading with Edges with Hidden edges

E. Shading with Material

F. Wireframe(NHR)
F

B

A

D

C

E

A B C D E F
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Applying Rendering Styles

Use the following steps to apply a rendering style:

1. Select the current rendering style icon in 
the View toolbar. 

2. Select the new rendering style to apply. It is 
applied automatically to the geometry.

1

2
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CATIA User Companion

CATIA contains many assets to help you learn the 
finer details of all the functionalities and tools. One 
such asset that focuses on workplace learning is 
the User Companion. 

The Companion is a self-contained series of 
learning objects, that aims to allow you to learn at 
your own pace, to get some additional knowledge 
or some extra practice on the following topics:

� CATIA V5 (Mechanical Design, Hybrid 
Design, Generative Sheet Metal Design, 
Analysis) 

� DMU
� ENOVIA
� SMARTEAM
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Help Documentation

Another asset that focuses on providing 
information is the online Help Documentation.

The help system is a self-contained series of 
HTML documents that break down the vast 
CATIA information into workbenches, products, 
and solutions. 
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Message Bar

Another useful tool that can helps you to 
determine what is required, when trying to 
perform a command, is the Message Bar. 

When you select a tool, CATIA uses the 
message bar to prompt you for the particular 
inputs that are needed to complete a command.  
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In the following slides you will find a summary of the topics covered in this lesson.

To Sum Up
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CATIA is a mechanical design software. It is a 
feature-based, parametric solid modeling design 
tool that takes advantage of the easy-to-learn 
Windows graphical user interface. You can create 
fully associative 3D solid models, with or without 
constraints, while using automatic or user-defined 
relations to capture the design intent. 

� CATIA acts as the backbone for concept, 
product definition, manufacturing, simulation, 
and after-market information found within 
various lifecycle stages of a product.

� It provides the specifications and geometrical 
data related to a product across several lifecycle 
phases.

Open CATIA
Concept Planning Develop Qualify Launch SupportIn a Windows environment, you can start the 

CATIA application in several ways:

A. Select CATIA from the Start > Programs > CATIA menu.
B. Double-click the CATIA icon on your Windows desktop.
C.Double-click on an existing CATIA document.

Test

Maintenance

Analysis

Suppliers

Planning

Engineering

Simulation

Purchasing

CATIA Within the PLM Solution

CATIA’s Scope From Concept To Realization

Understand the CATIA software
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Understand the CATIA interface

A. Separate workbenches and their respective toolbars.

B. Easy navigation from one workbench to another.

C.Standard and specific menus & toolbars (File, Edit, 
Insert...).

D.Standard manipulations (Copy-Paste, Drag-and-
Drop, Edit in Place...).

E. Intuitive (highlighting, copilot, pointer shapes...).

F. Multi-document support.

G.Contextual menu (MB3) support.

H.Specification tree, which includes technological 
features, constraints, and relationships.

CATIA’s user interface adopts the Windows 
interface, and contains the following key features:

CATIA V5 is specifically designed for the Windows 
operating environment, and it behaves in the same 
manner as other Windows applications. Traditional 
menus provide access to all the CATIA commands. 
Toolbars contain icons for quick access to the most 
frequently used commands. 
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1

2

3

5

Rendering Styles

4

6

1

2

3

4

5

6

CATIA has the ability to apply different styles of 
rendering to visualize the geometry and provide 
more clarity to the model. 

View Tools

Shading (SHD)

Shading with Edges

Shading with Edges without smooth Edges

Shading with Edges with Hidden edges

Shading with Material

Wireframe (NHR)
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Exercise: CATIA V5 User Interface
Recap Exercise

20 min

In this exercise, you will start CATIA and open existing documents within a file based 
environment.

By the end of this exercise you will be able to:

� Launch CATIA

� Open an existing document

� Identify the fundamental CATIA document types

� Close a file
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Do it Yourself (1/5)

1. Start the CATIA application.
� Start the application using the Windows START 

menu.
a. Double-click on the CATIA icon on your 

desktop or select it through the START > 
Program files menu.

2. Review the default window and document.
� Review the default CATIA window.

a. Notice that CATIA opens a CATProduct 
document by default and automatically 
launches the Assembly Design workbench.

b. Examine the various tools and menus that 
appear. Try to locate the Design Table tool by 
using the tool tips.

3. Close the Product1.CATProduct window.
� Select Close to close Product1.

1a

2
3
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Do it Yourself (2/5)

4. Open a part file.
� Open a file using the Open icon.

a. Click File > Open.
b. Browse to the Orientation.CATPart.
c. Highlight the file.
d. Select Open.

5. Customize the toolbars.
a. Press and hold the left mouse button on the 

Workbench toolbar separator.
b. Drag the toolbar to the middle of the screen. The 

toolbar is now “floating”.

4a

4c

4d

5a

5b
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Do it Yourself (3/5)

5. Customize the toolbars (continued):
c. Drag the toolbar back to the right-hand side of the 

screen until the outline changes thickness.
d. Release the left mouse button. A second row of 

toolbars is added to the right-hand side.
e. Move other toolbars to customize your screen.

5c
5d
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Do it Yourself (4/5)

6. Change the Orientation.
� Use the mouse and the view icons to 

change the orientation of the model.
a. Select the Front View icon.
b. Press and hold the middle mouse 

button to pan the model.
c. Press and hold the middle and the left 

mouse button to rotate the model. 
d. Press and hold the middle mouse 

button, and click the left mouse button 
to zoom.

e. Experiment with the other view 
orientations, using the mouse buttons 
and View icons.

6a
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Do it Yourself (5/5)

7. Change the properties.
� Make the top surface of the model red.

a. Select the Isometric View icon.
b. Select the top face of the table.
c. Right mouse click and click Properties.
d. Change the color of the surface to 

Red.
e. Select OK to apply the change and 

close the window.

8. Close the file.
a. Click File > Close to close the part file.
b. Select No to the Close window.

7c

7b

7d

7e
8a
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Exercise Recap: CATIA V5 User Interface

� Launch CATIA
� Open an existing Document
� Identify the fundamental of CATIA 

document types
� Close a file
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Case Study: Introduction to CATIA
Recap Exercise

20 min

In this exercise, you will review the master project assembly. With the knowledge you 
have learned in this lesson, you should be able to:

� Change the orientation of a model

� Change the visualization properties of a model

� Manipulate the specification tree

� Access the CATIA help system
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Case Study (1/6)

1. Open Introduction_Drill_Press.CATProduct.

2. Change the Orientation of the assembly.
a. Change the model orientation to Front.
b. Zoom in on the area as shown.

3. Change the Visualization properties.
a. Select the front face of the support part 

as shown and change the color to red.

1

3a

2b

2a
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Case Study (2/6)

4. Zoom out on the model.

5. Change to the Isometric view.

6. Change the rendering style to Wireframe.

7. Change the rendering style to Shading with Edges.

6

7

5
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Case Study (3/6)

8. Change the display of the specification 
tree.

a. Press the <F3> key to toggle the 
specification tree on and off. 

b. Select one of the branches of the 
specification tree and notice that 
the model darkens.

c. Try zooming out; notice that the 
specification tree is being 
manipulated and not the model.

d. Press <Shift> and <F3> to re-
activate the model.

8b
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Case Study (4/6)

8. Change the display of the specification tree 
(continued)

e. Expand the Casing_sup node of the 
tree. Notice that the features of the 
part are now displayed in the tree.

f. Collapse all the nodes to show only the 
top level of the tree.

8f

8e



Student Notes:

CATIA V5 Fundamentals- Lesson 1: Introduction
����������	��

Copyright DASSAULT SYSTEMES 1-79

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
TE

M
E

S

Case Study (5/6)

9. Review the areas of information.

a. Hover the mouse over the various tools 
and areas of the toolbars and notice the 
tool tip comments.

b. Review the message bar as you pause the 
mouse cursor over the icons for more 
information.

9b

9a
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Case Study (6/6)

9. Review the areas of information (continued).
c. Click Help > CATIA V5 Help.
d. A web browser launches, with the 

CATIA Help start page loaded. 
e. Spend few minutes browsing the 

various links within the system.

10. Close the assembly without saving changes. 

9d

9c
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Case Study: Introduction to CATIA Recap

� Change the orientation of a model
� Change the visualization properties of a model
� Manipulate the specification tree
� Access the CATIA help system


