
Chapter 11

Assembly Modeling

After completing this chapter you will be able to:
• Insert components into an assembly file.
• Create bottom-up assemblies.
• Insert components into a product file.
• Move and rotate components inside an assembly.
• Add constraints to the individual components.
• Create top-down assemblies.
• Edit assembly designs.
• Create the exploded state of an assemblies.

Learning Objectives
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ASSEMBLY MODELING
Assembly modeling is the process of creating designs that consist of two or more components
assembled together at their respective work positions. The components are brought together
and assembled in Assembly Design workbench by applying suitable parametric assembly
constraints to them. The assembly constraints allow you to restrict the degrees of freedom of
components on their respective work positions. The assembly files in CATIA are called Product
files. There are two methods to invoke the Assembly Design workbench of CATIA. The
primary method to start a new product file is by selecting File > New from the menu bar to
open the New dialog box From this dialog box select Product, as shown in Figure 11-1. The
other method of invoking the Assembly Design workbench is by choosing Start > Mechanical
Design > Assembly Design from the menu bar.

A new file is started in the Assembly Design workbench. The screen display of CATIA after
starting the new file in the Assembly Design workbench is as shown in Figure 11-2. You will
notice that the toolbars related to assembly are displayed. The tools available in these toolbars
will be discussed later in this chapter.

Types of Assembly Design Approach
In CATIA you can create assembly models by adopting two types of approaches. The first
design approach is the bottom-up approach, and the second one is the top-down approach.
Both these design approaches are discussed below.

Bottom-up Assembly
The bottom-up assembly is the most preferred approach for creating assembly models. In
this of approach, the components are created in the Part Design workbench as (*.CATPart)
file. Then the product (*.CATProduct) file is started and all the previously created components
are inserted and placed in it using the tools provided in the Assembly Design workbench.
After inserting each component, constraints are applied to position them properly in the 3D
space with respect to other components.

Adopting the bottom-up approach gives the user the opportunity to pay more attention to
the details of the components as they are designed individually. Because the other components
are not present in the same window, it becomes much easier to maintain a relationship between

Figure 11-1  The Product option
selected from the New dialog box
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the features of the current component. This approach is preferred for large assemblies,
especially those having intricate individual components.

Top-down Assembly
In the top-down assembly design approach, components are created inside the Assembly
Design workbench. Therefore, there is no need to create separate part files of the components.
This design approach is completely different from the bottom-up design approach. Here you
have to start the product file first and then, one by one, create all components. Note that
even though the components are created inside the product file, they are saved as individual
part files and can be opened separately later.

Adopting the top-down design approach gives the user the distinctive advantage of using the
geometry of one component to define the geometry of the other. Here the construction and
assembly of the components takes place simultaneously. As a result of this, the user can view
the development of the product in real time. This design approach is highly preferred, while
working on a conceptual design or a tool design where the reference of previously created
parts is required to develop a new part.

Note
An assembly can also be created by using the combination of both the top-down and bottom-up
assembly design approaches.

Figure 11-2  Screen display after starting a new file in the Assembly Design workbench
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Menu: Insert > Existing Component
Toolbar: Product Structure Tools > Existing Component

CREATING BOTTOM-UP ASSEMBLIES
As mentioned earlier, while creating an assembly using the bottom-up approach, the
components are created in separate part files and are then inserted into the assembly file.
They are assembled at their working position by applying assembly constraints to them. To
create an assembly using this approach, it is recommended to insert the first component and
fix its position after properly orienting it in the 3D space. The other components can be
inserted and positioned with reference to the first component. The method used for placing
components inside the product file is discussed below.

Inserting Components in a Product file

To insert the first component in the product file, choose the Existing Component
button from the Product Structure Tools toolbar. You are prompted to select a
component into which the existing component will be inserted. You need to select

Product1 from the Specification Tree. After you do so, the File Selection dialog box is
displayed. Browse the location where the part files are saved and double-click on the
component to be inserted; the component will be inserted in the current product file. You
will notice a new entry in the Specification Tree, which is referred to as Part1. Part1 is a
default part number assigned by the software to the component. A default part number is
assigned to each component that is inserted in the assembly, unless it is changed by the user.
Inside the assembly, the components are referred to by their part number and not by their
file name. The process of changing the part number of the component is discussed later in
this chapter. It is always recommended to fix the first component using the Fix constraint
after inserting. The method of applying the Fix constraint to the component is discussed
later in the chapter.

The above procedure needs to be repeated for inserting the next component. When you
insert additional components, the Part number conflicts dialog box is displayed, as shown
in Figure 11-3. This dialog box is displayed because there is a clash between the part numbers
of the previously inserted component and the currently inserted component. Note that in
the selection area of the dialog box, the numbers of both the components are displayed as
Part1, but the names of the files are different. You can change the part number of the

Figure 11-3  Part number conflict dialog box
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component using the options available in this dialog box. There are two active buttons available
on the right of the selection area of this dialog box: Rename and Automatic Rename.

If you select the component to be renamed and choose the Automatic rename button, the
part number of the selected component is renamed from Part1 to Part1.1. Choose the OK
button from the Part number conflicts dialog box to insert the second component into the
Product file. Follow the same procedure to rename the part number, while inserting other
components. Note that while inserting the third component, the first time when you rename
the component using the Automatic Rename option the part number is changed to Part1.1.
Because this part number is already assigned to the second component, the Part number
conflicts dialog box is again displayed after choosing the OK button and shows the conflict
between the second and third component. You need to choose the Automatic rename button
again to change the part number of the third component. Now, the third component will be
renamed from Part1.1 to Part1.1.2. Choosing the OK button will insert the third component
into the product file. This means if you are inserting the nth component, the automatic rename
button has to be used n-1 times. This way the part number of every new component keeps on
changing in a similar fashion, and the same is represented in the Specification Tree, as
shown in Figure 11-4.

If you choose the Rename button from the Part number conflicts dialog box, the Part Number
dialog box is displayed, as shown in Figure 11-5.

In this dialog box, you can enter the new part number for the selected component based on
your requirement. After typing the new part number in the text box provided in the dialog
box, choose the OK button to exit the Part Number dialog box. Now, choose the OK from
the Part number conflicts dialog box to insert the component in the product file. Ideally the
part number entered should be the same as the file name. If you enter the same part number
for two different components, it will not be accepted by the software, and the Part number
conflicts dialog box will again be displayed. Again choose the Rename button and enter a
unique name for that part such that it does not conflict with any other part number. The
advantage of using this option is that the user can enter the desired part number, which can

Figure 11-4  Specification Tree showing four components

Figure 11-5  The Part Number dialog box
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Figure 11-6  Specification Tree showing
four components with unique part numbers

be useful especially when the individual components are referred to in the an assembly using
number coding. The Specification Tree showing individual part numbers is shown in
Figure 11-6.

Note that in the Specification Tree, the part numbers of each component is suffixed by the
instance number, which is displayed within parenthesis. This instance number is generated
by the software itself and is unique for each component.

When a component is inserted into a product file, its placement in the 3D space depends on
the location of its default planes. The default planes of the component are placed over the
default planes of the product file. The default planes of the product file are not visible, but
are present at the center of the screen, unless moved by panning. When more than one
components are inserted into the product file, the default planes of all components are placed
one over the other hence appearing as one set of default planes. When the components are
moved away, the defaults planes of each component are distinctly visible. You will learn more
about moving the components later in this chapter.

Note
If the default planes of the inserted components are not visible, this means its visibility is turned
off in its part file. Therefore, you need to turn on the visibility of the reference planes in the part
file to display them in the assembly file.

Moving Individual Components
Generally, the components when inserted in a product file are overlapped by other components
placed earlier. As a result, their visualization is hampered, and it becomes difficult to apply
constraints to them. Therefore, it is necessary to reposition the components in the 3D space
such that they are distinctly visible, and the mating references are accessible in the assembly.
CATIA allows you to move and rotate the individual unconstrained components inside the

Tip. You can also insert components in the product file using the Copy and Paste
method. To insert the components using this method, open the part file of the
component that you need to insert. Select the name of the component from top of the
Specification Tree, and choose Copy from the contextual menu. Now, switch to
the product file, and select the name of the assembly on top of the Specification
Tree. Invoke the contextual menu, and choose Paste from it; the component will
be placed in the assembly.
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product file without affecting the position and location of the other components. The
reorientation of the component can be carried out using three different methods, which are
discussed in the following sections.

Moving and Rotating Using the Manipulation Tool

The Manipulation tool is used to move or rotate the component freely by dragging
the cursor. To translate or rotate any component, choose the Manipulation button
from the Move toolbar; the Manipulation Parameter dialog box is displayed, as

shown in Figure 11-7.

This dialog box contains buttons arranged in three rows. The currently active button is
displayed on the top of the dialog box. The buttons in the first row are used to translate the
component along a particular direction. There are four buttons in this row, which are discussed
below:

The Drag along X axis button is the first button and is chosen by default. This
button is used to translate the selected component along the X-axis of the assembly
coordinate system. To move the component, select the component to move and then

drag it. After moving the component to the desired location, release the left mouse button.

The Drag along Y axis button is used to translate the component along the Y-axis of
the assembly coordinate system. It works similar to the button discussed above. After
choosing the Drag along Y axis button, select the component to move and then drag it.

The Drag along Z axis button is used to translate the component along the Z-axis of
the assembly coordinate system.

The Drag along any axis button is used to move the component along a selected
direction. After choosing the Drag along any axis button, you need to select a direction
to define the translation axis. This direction can be a line, an edge, or an axis of a

Toolbar: Move > Manipulation
Menu: Edit > Move > Manipulate

Figure 11-7  Manipulation Parameter dialog box
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cylindrical feature. After selecting the axis of translation, drag the selected component along
the selected direction.

The buttons in the second row of the Manipulation Parameter dialog box are used to move
the selected component along a particular plane. These planar translation buttons are
discussed below.

The Drag along XY plane button is used to translate the selected component parallel
to the XY plane of the assembly coordinate system.

The Drag along YZ plane button is used to translate the selected component parallel
to the YZ plane of the assembly coordinate system.

Drag along XZ plane button is used to translate the selected component parallel to
the XZ plane of the assembly coordinate system.

Drag along any plane button is used to move the selected component parallel to a
specified plane. After choosing the Drag along any plane button, you need to select
a plane for planar translation. This plane can be a construction plane, a planar face,

or a surface. After selecting the plane for translation, select the component to move and then
drag it on the selected plane.

The buttons on the third row of the Manipulation Parameter dialog box are used to rotate the
selected component around an axis. These rotation buttons are discussed below.

The Drag around X axis button is used to rotate the selected component around the
X-axis of the assembly coordinate system.

The Drag around Y axis button is used to rotate the selected component around the
Y-axis of the assembly coordinate system.

The Drag around Z axis button is used to rotate the selected component around the
Z-axis of the assembly coordinate system.

The Drag around any axis button is used to rotate the selected component around a
specified axis. After choosing the Drag around any axis button, you need to select a
line to define the rotation axis. This line can be an edge of the component or an axis

of a cylindrical feature. After selecting the axis for rotation, select the component to rotate
and then drag it.

The With respect to constraints check box is selected to move or rotate the components
within its available degrees of freedom after applying constraints. You will learn more about
applying constraints later in this chapter.
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Moving Components Using the Snap Tool

The Snap tool is used to move the component by snapping the geometric element of
first component on the other component or on the same component. The movement
of the component depends on the selection of the geometric elements. The element

selected first will move to snap the second element. For example, if you first select a line and
then a point, the line will be reoriented in such a way that it passes through the selected
point.

To move a component using the Snap tool, choose the Snap button from the Move toolbar.
You are prompted to select on a component the first geometric element: an axis system, a
point, a line or a plane. Select a suitable geometrical element that will be projected on the
next selection. In Figure 11-8, the upper right edge of the left component is selected as the
first geometrical element.

Next, you are prompted to select on the same component or on another component the
second geometric element: a point, a line or a plane. Select the second geometric element on
which you need the first selection to be snapped. In Figure 11-8, the upper left edge of the
right component is selected as the second geometric element. The first selection will be
snapped to the second selection, and a green arrow will be displayed at the snapping location,
as shown in the Figure 11-9. You can click on the arrow to reverse the snapping direction, else
click anywhere in the geometry area to exit the tool. Figure 11-10 shows the components,
after the snapping direction is reversed.

In some cases the arrows are not displayed when you snap the two elements such as snapping
a point to a point, a point to surface, a point to a cylindrical surface or a planar surface, and
so on.

Toolbar: Move > Snap > Snap
Toolbar: Edit > Move > Snap

Figure 11-8  Geometric elements selected to snap
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Moving Components Using the Smart Move Tool

The Smart Move tool works as a multipurpose tool. This tool has the capability of
manipulating and snapping components and can also apply constraints to them, if
required. To invoke this tool, choose the down arrow besides the Snap button to

invoke the Snap toolbar. Choose the Smart Move button to invoke the Smart Move dialog
box. Choose the More button to expand it, as shown in Figure 11-11.

If the Automatic constraint creation check box is selected, a permanent constraint will be
applied between the selected elements of the components to be snapped and the same will
be displayed in the Specification Tree. If this check box is not selected, the components will

Figure 11-10  Position of components after
snapping direction is reversed

Figure 11-9  Position of components after
snapping

Toolbar: Move > Snap > Smart Move
Menu: Edit > Move > Snap

Figure 11-11  The expanded Smart Move dialog box
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be repositioned but no permanent constraint will be applied. You will learn more about
applying constraints later in this chapter.

The Quick Constraint area displays the constraints in a hierarchial order. These constraints
will be applied to the components, while they are being snapped. If more than one constraint
can be applied to the current selection set, then priority will be given to the constraint, which
on the top in the hierarchy. To change the position of a constraint, select it and choose the
Up or Down arrows on the right side of the Quick Constraint area.

After settings the options in this dialog box, select the first geometric element on a component,
which can be a point, line, plane, planar face, or circular face. Now, select the second geometric
element on the other component. The suitable constraint will be applied between the two
components, depending on the current selection set. A green arrow may be displayed at the
constraint location. You can click on this green arrow to reverse the orientation of the
mating components. The component from which the first selection is made will move to snap
the component on which the second element is selected. After the components are reoriented,
choose the OK button from the Smart Move dialog box to complete the operation. Figure 11-12
shows two cylindrical surfaces to be selected and Figure 11-13 shows the resulting concentric
constraint applied between the two surfaces.

The Smart Move tool can be invoked along with a viewer, which makes the selection of
geometric elements easier. To invoke the viewer, first select the components that need to be
moved and then choose the Smart Move button from the Snap toolbar. This time the Smart
Move dialog box is displayed with a viewer on top of it. The partial view of the Smart Move
dialog box is shown in Figure 11-14. The component selected first is displayed in the viewer.
The part number of the displayed component is displayed on top of the viewer. Only one
component is displayed in the viewer and its geometric element can be easily selected as you
can zoom in and rotate the component in it. This is especially helpful when there are a
number of components in the geometry area and some of the components are fully or partially
placed inside another component. After selecting the geometric element of the first
component, choose the Next component button from the Smart Move dialog box. Note that
this button will not be available if you select only one component before invoking the Smart

Figure 1-13  Resulting constraint appliedFigure 11-12  Surfaces to be selected
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Move dialog box. Now, the other component is displayed in the viewer and you can select its
geometric element. Note that while you zoom or rotate the component in the viewer, the
actual orientation of the component in the geometry area is not changed. After the selections
are made from the viewer, the components are reoriented in the geometric area. Now, choose
the OK button to close the Smart Move dialog box.

Manipulating Components using the Compass
The orientation of the components can also be manipulated using the compass available on
the top right corner of the geometry area. To move a component using the compass, you first
need to associate it with the component that needs to be moved or rotated. To associate the
compass to a part, move the cursor over the red square displayed on the base of the compass.
When the selection cursor is replaced by the move cursor represented by four
directional arrows, hold down the left mouse button, and drag the compass on the surface of
the component to be manipulated. Once the compass is moved, a black dot appears at its
original location. To associate the compass with a component, place it on the surface of the
component by releasing the left mouse button. The black dot is no longer displayed. To
move the component, place the cursor on any of the straight edges of the compass. The edge
are highlighted in orange and the cursor is replaced by the hand symbol. Press and hold
down the left mouse button and drag the cursor along the highlighted edge to move the
component in that direction. After moving it to the desired location, release the left mouse
button. Similarly, to rotate the component, place the cursor over any of the circular edges
and when the hand symbol is displayed, drag the cursor along that edge.

Once the manipulation is over you need to place the compass back at its original position. To
do so, move the cursor on the red square on the base of the compass. Once the move cursor
symbol is displayed, drag the cursor anywhere in the geometry area away from all the
components in the assembly and release the left mouse button.

Figure 11-14  The partial view of the Smart Move dialog box
with viewer
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Note
When the compass is placed back in its original location, the orientation of the compass remains
the same as it was after manipulating the component. This may lead to confusion. To bring the
compass back to its default orientation, place the compass over a perfectly horizontal surface.
Then place the compass back at its default location.

Applying Constraints
After placing the components in the product file, you need to assemble them. By assembling
the components, you will constrain the degree of freedom of the components. As mentioned
earlier, the components are assembled using the constraints. Constraints help you to precisely
place and position the components with respect to the other components and the surroundings
in the assembly. If all degrees of freedom of all components of the assembly are restricted, it
is called a fully constrained assembly. Else it is called a partially constrained assembly. If
some mechanism needs to be created after assembling the components, some degrees of
freedom of the assembly needs to be kept free intentionally, so that movements can be achieved
in that direction. Various types of constraints available in CATIA are discussed below.

Fix Component Constraint

The Fix Component constraint is used to fix the location of the selected component
in the 3D space. Once the orientation of the component is fixed, its orientation
cannot be changed. To invoke this tool, choose the Fix Component button from the

Constraints toolbar; you are prompted to select the component to be fixed. You can select
the component from the geometry area or from the Specification Tree. Once the component
is selected, an anchor symbol  is displayed on the component. Now, other components can
be constrained with respect to the fixed component. While doing so, the orientation of the
base component will not be altered and the other components will be reoriented to apply the
constraints. It is always advisable to fix the base component at its default location so that it
can be used as a reference for other components. The Fix Component constraint is displayed
in the Specification Tree. To view the applied constraints, expand the Constraints option
from the Specification Tree.

Coincidence Constraint

The Coincidence Constraint is applied to coincide the central axis of the cylindrical
features that are selected from two different components. This option can also be
used to apply Coincident constraint between edges, points, planes or planar faces.

To invoke this tool, choose the Coincidence Constraint button from the Constraints toolbar;
the Assistant dialog box is displayed that provides information about the selected constraint.
You can select the Do not prompt in the future check box, if you do not want to display this
dialog box again. Now, move the cursor over a cylindrical surface to display the central axis.
When the preview of the central axis is displayed, as shown in Figure 11-15, click the left

Menu: Insert > Coincidence
Toolbar: Constraints > Coincidence Constraint

Menu: Insert > Fix
Toolbar: Constraints > Fix Component
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mouse button to select it. Similarly, select the axis of the second component, as shown in
Figure 11-16.

Once the two axes are selected, the Coincidence constraint is applied between them and the
coincidence symbol  is displayed, as shown in Figure 11-17. You will notice that although
the Coincidence constraint is applied between the two components, the components are
not assembled with respect to the constraint applied. Instead, a line connecting the two
constraint is displayed. To position the components, choose the Update All button from the
Tools toolbar or press CTRL+U from the key board. Now, the components will be placed
such that the two selected cylindrical surfaces become concentric, as shown in Figure 11-18.
Click once in the geometry area to remove the constraint from the current selection set. The
symbol of the constraint is displayed in green on the assembled components.

Figure 11-16  Central axis of the second
component to be selected

Figure 11-15  Central axis of the first component
to be selected

Figure 11-18  Position of the components after
updating

Figure 11-17  Coincidence constraint applied
between two components

Tip. If you select planar faces or planes to apply the coincident constraint, the
Constraint Properties dialog box is displayed. Choose the OK button from this
dialog box. You will learn more about this dialog box later in this chapter.
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Contact Constraint

The Contact Constraint is applied to make a surface to surface contact between two
selected elements from two different components. The elements to be selected can
be  planes, planar faces, cylindrical faces, spherical faces, conic faces, or circular

edges. To invoke this tool, choose the Contact Constraint button from the Constraints toolbar;
you are prompted to select the first geometric element of the Contact constraint. Select the
element from the first component. Next, you are prompted to select the geometric element
to place in contact with the first selection. Select the element from the second component. A
Contact constraint will be applied between the two elements and the component will be
placed with respect to the constraints after updating. The Contact constraint symbol  will
be displayed on the assembled components. Figure 11-19 shows the faces to be selected and
Figure 11-20 shows the resulting constraint applied to the components.

Note
If you apply Contact constraint between two cylindrical surfaces or a cylindrical surface and a
planar face or plane, the Constraint Properties dialog box is displayed. You can set the
orientation of the constraint using the option available in the Orientation drop-down list.
After setting the orientation option, choose the Constraint Properties dialog box.

Offset Constraint

The Offset Constraint is used to place selected elements at an offset distance from
each other. It also makes the two planar faces parallel to each other. To invoke this
tool, choose the Offset Constraint button from the Constraints toolbar. After invoking

the tool, you are prompted to select the first geometric element for the Offset constraint.
Select a planar face, circular face, plane, axis, or a point from the geometry area. You are

Menu: Insert > Contact
Toolbar: Constraints > Contact Constraint

Figure 11-20  Position of components after
constraint is applied and updated

Figure 11-19  Planar faces to be selected

Menu: Insert > Offset
Toolbar: Constraints > Offset Constraint
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prompted to select the second geometric element. Select a planar face of another component;
the Constraint Properties dialog box is displayed, as shown in Figure 11-21.

If you select two planar faces, then two arrows will be displayed on them. The arrows represent
the orientation of the plane with respect to each other. The planes can either face in the same
direction or opposite direction. To flip the direction or arrows, click on any one of the arrow,
or use the options available in the Orientation drop-down list. The options available in the
dialog box are discussed next.

The Name edit box displays the name assigned to this particular constraint. You can also
enter a new name of your choice. If the Measure check box available on the top left corner of
the dialog box is selected, the present distance between the two selected surfaces will be
measured from the geometry, and will be assigned the same value as the offset distance.

The Supporting Elements area displays the type of geometrical element selected for applying
the constraint, the name of the component on which the geometrical elements are present,
and the status of the constraint. The status should display Connected. If it is displaying
Disconnected, you need to choose the Reconnect button, and select the geometric element
again.

The Orientation drop-down list has three options namely, Undefined, Same, and Opposite.
If the Undefined option is selected, then the software automatically orients the component
either in the same or in opposite direction, depending on the orientation of the planes.
Otherwise, you can select the required option from the drop-down list. In the Offset spinner,
you need to enter the required offset distance between the planes. After setting all parameters,
choose the OK button from the Constraint Properties dialog box. Select the Update button
to place the components defined by the constraint. Now, the two selected planes will be
placed parallel to each other and will have the specified separation between them. Figure 11-22
shows the faces to be selected. The orientation arrows are shown in the Figure 11-23.

Figure 11-21  The Constraint Properties dialog box
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Figure 11-24 shows the orientation of the selected planes after updating. After the Offset
constraint is applied, the constraint symbol is displayed as the offset distance between the
two selected faces.

Angle Constraint

The Angle Constraint is used to position two geometric elements at a particular
angle with respect to each other. You can also use this tool to make two selected
elements parallel or perpendicular to each other. To invoke this tool, choose the

Angle Constraint button from the constraint toolbar. Now, select the two planar faces from
the two different components that you need to place at some angle from each other. You can
also select a plane, circular face or an edge as the geometric element. Once the selection is
complete, the Constraint Properties dialog box is displayed, as shown in Figure 11-25. You
will note that in the Constraint Properties dialog box, the Angle radio button is selected by
default. If required, you can select the Parallelism or Perpendicularity radio buttons. If
the Perpendicularity radio button is selected, the angle between the faces is automatically

Menu: Insert > Angle
Toolbar: Constraints > Angle Constraint

Figure 11-24  Components after updatingFigure 11-23  Arrows in the same direction

Figure 11-22  Faces to be selected
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Figure 11-25  Constraint Properties dialog box for Angle constraint

set to 90-degree and the display of the Angle spinner is turned off. If the Parallelism radio
button is selected then the Orientation drop-down list is displayed. From this drop-down
list, select the required orientation option. If the Angle option is selected then the Angle
spinner and the Sector drop-down list is displayed. Before specifying the angle, you need to
select the appropriate sector in which it will be applied. Select the sector from the Sector
drop-down list. The selected sector will also be displayed in the geometry area. After setting
all parameters, choose the OK button from the Constraint Properties dialog box. Figure 11-26
shows the faces to be selected and Figure 11-27 shows the resulting orientation of the faces
after applying the Angle constraint and updating.

After the constraint is applied, the angle value is displayed attached to the selected faces. In
case the perpendicularity constraint has been applied, the perpendicular symbol appears
between the selected faces. The parallel symbol  is displayed between the selected faces, if
the parallelism constraint is applied. The name of the resulting constraint is also displayed
in the Specification Tree.

Figure 11-27  The orientation of the faces after
applying the Angle constraint and updating

Figure 11-26  Faces to be selected
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Fix Together

The Fix Together constraint is used to fix the position of the selected components
with respect to each other. Once the selected components are fixed together, they
can be moved as a single component such that the position of one component with

respect to another component remains the same. To invoke this tool, choose the Fix Together
button from the Constraints toolbar; the Fix Together dialog box is displayed. Now, select
components to be linked. The part number of the selected components are displayed in the
Fix Together dialog box, as shown in the Figure 11-28. If you want to remove a particular
component from the list, click on its part number in the Components selection area. Choose
the OK button from the Fix Together dialog box to apply the Fix Together constraint.

Quick Constraint

In CATIA, there is an option in which the software applies the most appropriate
constraint to the entities in the current selection set. To apply constraints using this
method, choose the Quick Constraint button from the Constraints toolbar. The

possibility of applying constraints depends on the priority of constraints in the Quick
Constraints priority list. You can invoke this list to set the priority by choosing Tools >
Options from the menu bar. From the Options dialog box, choose Assembly Design from
the Mechanical Design on the left of the Options dialog box. The Quick Constraint priority
list is displayed.

Menu: Insert > Fix Together
Toolbar: Constraints > Fix Together

Tip. After applying the Fix Together constraint, if you need to move the linked
components by using the Manipulation tool, select the With respect to constraints
check box. If you are moving the linked components using the compass, hold down
the SHIFT key on the keyboard, and then move the component. Else the components
will move separately.

Figure 11-28  The Fix Together dialog box

Menu: Insert > Quick Constraint
Toolbar: Constraints > Quick Constraint
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Now, select the two geometric elements to be constrained. The software will automatically
apply the most appropriate constraint between the selected geometric elements. This saves
time in assembling components. However, you need to be careful while selecting the geometric
elements because the orientation of the components depends on it.

Reuse Pattern

Sometimes, while assembling the components, you may need to assemble more than
one instance of the component in a specified arrangement. Consider a case of a
flange coupling where you need to assemble eight instances of nuts and bolts to

fasten the coupling. This is very tedious and time-consuming process. Therefore, to reduce
the time in the assembly design cycle, CATIA provides you with the Resume Pattern tool to
insert and constrain multiple copies of a component over an existing pattern. The pattern
can be rectangular, circular, or a user pattern.

The first step of using this tool is to insert the first instance of the component and constrain
it with any instance of the pattern in the other component. Figure 11-29 shows a Plate with
holes created using circular pattern and a Pin that needs to be placed in each instance of the
hole. After inserting the Plate and the Pin into the product file, constrain the Pin to any one
instance of the holes on the Plate, as shown in Figure 11-30. To assemble the Pin with a hole
in the Plate, apply a Coincident constraint to the central axis of the Pin and the instance of
the hole on the Plate. Next, apply the surface Contact constraint between the bottom face of
the head of the Pin and the top face of the Plate.

Next, you need to select the constraint that associates the position of the pin with the pattern
instance. Therefore, in this case the Coincidence constraint needs to be selected. After
selecting the constraint, choose the Reuse Pattern button from the Constraints toolbar. The
preview of Pins assembled with all instances of hole is displayed in the geometry area. The
Instantiation on a pattern dialog box is displayed, as shown in the Figure 11-31. Note, that
the Pattern area of the dialog box indicates the name of the pattern, the number of instances

Menu: Insert > Reuse Pattern
Toolbar: Constraints > Reuse Pattern

Figure 11-30  The Pin assembled to one of the
instances of the patterned hole

Figure 11-29  The Pin and the Plate having
patterned holes
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to be created, and the name of the component in which the pattern has been created. The
name of the component to be repeated is displayed in the Component to instantiate area.
The Keep Link with the pattern check box, at the top of the dialog box, is selected by
default. This makes the newly created instances of the pattern associative with the pattern
geometry.

The First instance on pattern drop-down list has three options. These options are used to
define the first instance of the component to be duplicated, and are discussed below.

re-use the original component
This option is used to retain the original component at its location, generate the instances,
and populate only the vacant locations.

create a new instance
This option is used to place the new instance of the component on all the patterned
instances, including the original instance. As a result, there will be two over lapping
instances at the location of the original component.

Figure 11-31  The Instantiation on a pattern dialog box
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cut and paste the original component
This option is used to remove the original component from its location and place the
new instance of the component at all locations.

By default, the pattern’s definition radio button is selected in the Generated component’s
position with respect to area of the Instantiation on a pattern dialog box. This option
facilitates in placing and constraining all instances based on the selected reference pattern. If
you select the generated constraints radio button, the constraints applied to the parent
instance are also applied individually to all pattern instances.

After setting all options, choose the OK button from the Instantiation on a pattern  dialog
box. Figure 11-32 shows the resulting assembly after using the Reuse Pattern tool. The list of
instances created is displayed in the Specification Tree shown in Figure 11-33. Note that the
part number of every instance remains the same, but the instance number displayed in
parenthesis is different. A new entity, called Assembly Features, will be created in the
Specification Tree and the Reused Circular Pattern.1 is displayed under it.

Note
You can choose the Reuse Pattern button without selecting any constraint. The dialog box will
not display any selections. Now, select the pattern instance and the component to instantiate
from the Specification Tree or from the geometry area.

Inserting Existing Components With Positioning

The Existing Component With Positioning tool is used to insert, position, and apply
constraints to a component in a single operation and is an enhanced form of the
Insert Existing Component tool. To invoke this tool, choose the Existing Component

With Positioning button from the Product Structure Tools toolbar. Now, click on the Product1
in the Specification Tree. The File Selection dialog box is displayed. Select the part to be

Menu: Insert > Existing Component With Positioning
Toolbar: Product Structure Tools > Existing Component With Positioning

Figure 11-33  The Specification Tree after
creating the component pattern

Figure 11-32  The assembly after the selected
component is patterned
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inserted and choose the Open button. The Smart Move dialog box, along with the viewer,
will be displayed. Use the Smart Move dialog box to position and constraint the newly inserted
component. You need to make sure that the Automatic constraint creation check box is
selected. Else, the component will only be placed and the constraint will not be applied. The
applied constraint is displayed in the Specification Tree. By using this tool, you can save
the assembly creation time.

Note
By using the Existing component and Existing Component With Positioning tool you can
insert an existing product file into the currently active product file as a subassembly. You can use
the individual parts of the subassembly to apply the constraints. The parts and the subassemblies are
associative with the parent product file. Therefore, if any modifications are made to the part or
the subassembly, they will be visible in the product file.

CREATING TOP-DOWN ASSEMBLIES
As discussed earlier, in the top-down assembly design approach, all components of the assembly
are created inside the Assembly Design workbench. To create the components, you need to
invoke the Part Design workbench within the Assembly Design workbench to draw the
sketches and then use them for creating features.

Creating Base Part in Top-Down Assembly

To start working on the top-down assembly, start a new product file. Click on Product1
in the Specification Tree and select the Part button from the Product Structure
Tools toolbar. A new component named Part1 is displayed in the Specification Tree

and a default name is assigned to it. Once a new part is inserted into the product file, the
geometry area will display the default planes. These planes belong to the new part and can
be used to draw sketches and create features. By default, the origin of these planes is placed
over the origin of the assembly coordinate system. .

To change the name of the part, choose Properties from the contextual menu invoked by
right-clicking on the part name displayed in the Specification Tree. The Properties dialog
box is displayed. The Product tab is selected by default in the Properties dialog box. Specify
the name of the part in the Instance name and Part Number edit box. After making the
changes, choose the OK button. The part names are modified in the Specification Tree.

To create the model, you need to invoke the Part Design workbench. Click on the plus sign
(+) displayed on the left of part name in the Specification Tree to expand it. Now, double-click
on the part name that is displayed inside the expanded branch to expand it further and
simultaneously the Part Design workbench is invoked. The fully expanded Specification
Tree is shown in Figure 11-34.

After the part is completed, double-click on the Product1 in the Specification Tree to switch

Menu: Insert > New Part
Toolbar: Product Structure Tools > Part
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back to the Assembly Design workbench. Now, you can move and apply constraints to the
base component.

Creating Subsequent Components in the Top-down
Assembly
After the base component is created inside a product file, you need to create other components
of the assembly. The process of creating subsequent components is similar to that of creating
the base component. Click on the Product1 in the Specification Tree and then choose the
Part button. The New Part: Origin Point dialog box is displayed, which prompts you whether
to define a new origin point for the new part. Select the No button to define the origin point
of the assembly as the origin part for new part. A new part is created and its name is displayed
in the Specification Tree. Now, invoke the Part Design workbench.

While creating the subsequent components using the top-down approach, you can refer to
the geometry of components already created in the assembly to extract the geometry of the
sketches of the current component. You can also refer to the geometry of the already created
components, while creating the features of the current component. For example, you can
sketch a circle and then apply the tangent constrain to the circle with an edge of another part
in the assembly or extrude a sketch up to surface that belongs to another part. To retain this
kind of relation between the external references, you need to activate the Keep link with
selected object option. Choose Tools > Options from the menu bar to invoke the
Options dialog box. Select the Infrastructure option from the left of the dialog box to expand
the branch and select the Part Infrastructure option. Now, select the General tab if it is not
selected by default, to display the entries under it. In the External References area, select
the Keep Link with selected object check box. Now, choose the OK button from the Options
dialog box. After activating this option, the relations with external references will be
maintained.

You can select a planar surface of the base component or the default planes as the sketching
plane to draw sketches for creating the features of the new part. The edges of the base feature
can be used to constraint the sketch and its surfaces can work as limits, while creating the
extrude feature. Once the part creation is complete, double-click on Product1 to switch back
to the Assembly Design workbench.

Figure 11-34  The fully expanded Specification
Tree after inserting a part in the product file
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Similarly, you can create more parts in the current product file. Note that if you reorient a
part that has some relation with external references, then the product file needs to be updated
to re-establish the relation. Figure 11-35 shows two parts created inside the assembly file.
The cylinder is extruded up to the surface that belongs to the base part. Figure 11-36 shows
the Up to surface relation still maintained even after moving the cylinder base along
Z-direction.

Creating Subassemblies in Top-down Assembly
While creating complicated assemblies, you may need to have subassemblies inside an assembly.
While working in the top-down approach, you can directly create a subassembly inside the
product file. In CATIA V5, there are two types subassemblies that can be created in the
Assembly Design workbench: Product and Component. Both these subassemblies are
discussed next.

Product Subassemblies

If you create a subassembly using the Product tool, the resulting subassembly and
the parts created within it are saved as a separate product and part files within the
folder in which the main assembly file is saved. This gives the benefit of managing

the subassembly or the part files individually. You can also open these files separately and
work on the design changes, which results in greater flexibility. Once the modifications are
made and the files are saved, the changes are automatically reflected in the main assembly
file. To create a subassembly inside the product file, select Product1 from the Specification
Tree and choose the Product button from the Product Structures Tools toolbar. The new
subassembly named Product2 is displayed in the Specification Tree. The name of this
subassembly can also be modified using the method similar to that discussed while renaming
the parts. Because the newly created subassembly is already highlighted, choose the Part
button to create a new part inside it. In this way, you can create more subassemblies inside the
main assembly or inside the subassembly itself.

Figure 11-36  Up to surface relation
maintained even after moving the base downward

Figure 11-35  Two different parts created in a
product file and the cylinder extruded up to surface

Menu: Insert > New Product
Toolbar: Product Structure Tools > Product
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Note
You can activate the subassemblies by double-clicking on the name of the subassembly in the
Specification Tree. To switch back to the main assembly, double-click on the name of the main
assembly in the Specification Tree.

Component Subassemblies

If you create a subassembly using the Component tool, the resulting subassembly
becomes an integral part of the main assembly file and will not be saved as separate
product file. However, the individual parts are saved as separate part files. If you

need to make any modification in the subassembly, you need to access it from the main
assembly because the subassembly file is not saved separately. To create this type of subassembly
inside the product file, select Product1 from the Specification Tree and choose the Component
button from the Product Structures Tools toolbar. The newly created subassembly named
Product3 is displayed in the Specification Tree, as shown in the Figure 11-37. Now, you can
rename this file, if required, and create parts inside it.

Note
Save the product file once all parts and subassemblies are created inside it. There is no need to
save the parts and subassemblies separately. They will be automatically saved as separate files
inside the folder in which the main product file will be saved. The file names will be the same as
that given to parts and the subassemblies in the Properties dialog box.

EDITING ASSEMBLIES
After creating the assembly, you may need to modify the parts, subassembly, or the applied
constraints. You may also need to replace the existing part with another part. These editing
operations are discussed below.

Deleting Components
While working in the Assembly Design workbench, you may need to delete some of the
constituent parts and subassemblies. To delete a part or a subassembly, right-click on its
name in the Specification Tree and choose the Delete option from the contextual menu. You
can also delete a part or subassembly by selecting it from the Specification Tree and pressing

Figure 11-37  The Specification Tree having a
product and a component within an assembly file.

Menu: Insert > New Component
Toolbar: Product Structure Tools > Component
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the DELETE key on the keyboard. If there are some relations associated with the selected
part, the Delete dialog box will be displayed, as shown in the Figure 11-38.

The Selection area of the Delete dialog box will display the names of the parts to be deleted
and the name of the assembly to which the parts belong. Choose the OK button to complete
the deletion process. The associated constraints now become inconsistent and a yellow error
symbol is displayed in the Specification Tree. These constraints have to be deleted separately.

If you select the Delete all children check box in the Delete dialog box, all relations associated
with the selected part will be deleted along with it. Similarly, way the subassemblies can also
be deleted from the main assembly.

Note
In a Product file with more than one subassembly, you cannot delete the currently activated
subassembly. To do so, first activate any other subassembly and then delete the subassembly that
was active earlier.

Replacing Components

In CATIA you can replace an existing component with another component inside an
assembly. If the new component being placed has the basic geometry which is the
same as the original component, then it will be placed exactly at the location where

the original component was placed. Otherwise the replaced component will be placed
arbitrarily in space with no association with the location where the earlier component was
present. If the component to be replaced has more than one instance and you replace any
one of the instance, then all the instances of the component are replaced.

To replace a component, select it from the Specification Tree and choose the Replace button
from the Product Structure Tools toolbar. The File Selection dialog box will be displayed.
Select the component and choose the OK button from the File Selection dialog box. The
Impacts On Replace dialog box will be displayed. Choose the OK button from this dialog

Menu: Edit > Components > Replace Component
Toolbar: Product Structure Tools > Replace Component

Figure 11-38  The Delete dialog box
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box to replace the existing component with the selected component. Note that the constraints
that were earlier applied on the previous component now become inconsistent. You can
either reattach these constraints, or delete them and apply new constraints. The process of
reattaching a constraint is discussed later in this chapter. Figures 11-39 and 11-40 show the
example of replaced components. Note that you cannot undo a Replace Component
operation. Therefore, you need to be careful while performing this operation. If there is a
need to undo the Replace Component operation, use the same command again to replace
the new component with the previous component.

Editing Components Inside an Assembly
You can also edit the features and modify the sketches of the parts of assembly within the
Assembly Design workbench. For this you need to activate it by invoking the Part Design
workbench. To invoke the Part Design workbench for editing a part, click on the plus sign
(+) displayed on the left of the part name to expand it in the Specification Tree. Now,
double click on the part name that is displayed inside the expanded branch to expand it
further and simultaneously invoke the Part Design workbench. In the Part Design workbench,
you can make the required modifications to the features and sketches of the part. After you
have made all changes, double-click on the Product name to return back to the Assembly
Design workbench. Note that in the Part Design workbench, all parts of the assembly are
visible, but changes are made only to part that is active. Similarly, you can also edit the
components in the subassemblies.

Editing Subassemblies Inside an Assembly
You can also edit subassemblies that are placed inside the main assembly. To edit a subassembly,
double-click on the name of the subassembly in the Specification Tree; the subassembly will
be activated. You can insert or remove the components from the subassembly, or you can edit
the constraints applied to the components of the subassembly. After making the necessary
changes, double-click on the main assembly to switch back to the main assembly.

Figure 11-40  The replaced componentFigure 11-39  The original component
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Note
The changes made to a part or subassembly inside the product file are also reflected in their
respective part and product files. Therefore, the changes will take place whereever these parts
and subassemblies have been used.

Editing the Assembly Constraints
In an assembly, the constituent parts are positioned at their respective locations using the
constraints. Many a times, you need to replace the existing constraint with another constraint
or to change the entities to which the constraints are applied. The methods to modify the
constraints are discussed below.

Editing the Constraint Definition
All assembly constraints need to be associated with entities of two different components.
These entities can be planes, surfaces, axes, edges, and so on. In the Offset and Angle
constraints, some numeric values, which define the offset distance and the rotation angle,
are also specified. These associated entities and the numerical values can be modified by
editing the definition of the constraint. The definition of a constraint can be accessed by
double-clicking on its name in the Specification Tree or its symbol from the graphics area.
The Constraint Definition dialog box is displayed. Choose the More button from this dialog
box to expand it, as shown in the Figure 11-41.

The Value spinner is available on the left of this dialog box. You can modify the displayed
value to change the offset distance. The appropriate option from the orientation drop-down
list can be selected to change the position of the faces between which the Offset constraints
have been created. In the expanded region of the dialog box, the name of the constraint is
displayed. If required, you can enter a new name for the constraint and the same will be
displayed in the Specification Tree.

The Supporting Elements area displays the type of entities and their corresponding
components between which the constraint is applied. Ideally, the Status area should display
Connected. This means that the association of the constraint with the entity is present. If the

Figure 11-41  The Constraint Definition dialog box

Tip. If you double-click on the sketch of the feature of a component in the
Specification Tree, the Sketcher workbench is invoked directly. Modify the sketch
and exit the Sketcher workbench. You will be switched to the Part Design
Workbench. To switch back to the Assembly Design workbench, double-click on
Product in the Specification Tree.
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status shows Disconnected, the association has been broken and hence the constraint has
become inconsistent. In this case, the constraint has to be reconnected with the proper entity.
The Reconnect button is used to select the entity on which the constraint will be connected.
This button can also be used to replace an existing element with another element, even if the
status is connected. By default, the Reconnect button is disabled. To enable it, select the
reference that you need to replace from the Supporting Element display area. Next, select
the element from the geometry area; the new selection will be displayed in the dialog box.
Choose the OK button to complete the constraint editing operation. You need to update the
model to incorporate the changes. Figure 11-42 shows the Offset constraint applied between
faces of two components. Figure 11-43 shows the position of components after the Offset
constraint is reconnected to another surface, and the offset distance is modified.

Every type of constraint can be modified in a similar manner by editing its definition.

Replacing  a Constraint

To replace an existing constraint with another constraint, select it from the
Specification Tree or from the geometry area. Choose the Change Constraint button
from the Constraints toolbar to display the Change Type dialog box. This dialog box

displays all the possible constraints that can be used to replace the selected constraint. Select
the appropriate constraint and choose the OK button from the Change Type dialog box.
The previously applied constraint will now be replaced by the new constraint. You can change
the definition of the replaced constraint as per requirement. After making the changes,
update the assembly to bring the newly applied constraint into effect. Figures 11-44 and
11-45 show the replacement of the Contact constraint that is applied between the flange of
the pipes by the Offset constraint after modifying its definition and entering some offset
distance.

Simplifying  the Assembly
While working on large assemblies consisting of a large number of parts and subassemblies,

Figure 11-43  Components after editing the offset
constraint and updating it

Figure 11-42  The associated and replacing
surface for the Offset constraint

Toolbar: Constraints > Change Constraint
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you may face a difficulty while managing the components of the assembly. Therefore, it is
recommended to hide some of the parts to improve the visibility of other parts. While working
with a large assembly, you may experience some difficulty in updating the assembly because
all the parts of the assembly are rebuilt during updation. Therefore, it is recommended to
suppress the parts that are not required at that particular stage of design cycle. This reduces
the regeneration time of the assembly. Hiding and suppressing the components are discussed
next.

Hiding a Component

The Hide/Show tool is used turn off the display of the selected component of the
assembly. But the component exists in the hierarchy of the assembly and participate
in assembly updation. The symbol of the hidden component is displayed in light

grey color in the Specification Tree. The Hide/Show tool can also be accessed from the
contextual menu by right clicking on the name of the component to hide.

Deactivating a Component
Deactivating the component, removes it temporarily from the assembly. This
substantially decreases the regeneration time of the model. To deactivate a part, invoke the
contextual menu by right-clicking on the name of the component in the Specification Tree.
Now, place the cursor over the instance name to open the cascading menu and choose the
Activate/Deactivate Component option. A red symbol  is displayed on the left of the name
of the deactivated component in the Specification Tree. Follow the same procedure to
unsuppress the component and make it active. Note that once a component is suppressed
the constraints associated to it become inconsistent and a yellow symbol is displayed against
them in the Specification Tree. These constraints are no longer displayed in the geometry
area.

Menu: View> Hide/Show > Hide/Show
Toolbar: View> Hide/Show

Figure 11-45  Components after applying the
Offset constraint

Figure 11-44  Contact constraint to be replaced
by the Offset constraint
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Menu: Analyze > Sectioning
Toolbar: Space Analysis > Sectioning

Interference Detection

It is recommended to check the interference and clearance between the components
of the assembly to make sure that the components are not interfering with each other
and the right type of fit is maintained between the mating parts. The interference is

detected using the Clash tool, which is invoked by choosing the Clash button from the Space
Analysis toolbar. The Check Clash dialog box is displayed, as shown in Figure 11-46.

There are two drop-down lists available in the Type area. From the upper drop-down list,
select the type of analysis that you need to perform. From the lower drop-down list, you can
select the option for defining the selection of components between which the interference
will be calculated. Choose the Apply button to perform the analysis. The Check Clash dialog
box will expand and display the result of the analysis. The result display area serially lists the
name of components and the type of interference between them, which can be clearance,
contact, or clash. Selecting a particular interference from the list area will display the
corresponding interference value and the Preview window will be displayed to show the
location of the interference. Figure 11-47 shows the Preview window displaying the location
and value of interference between the two components.

There are three tabs available on top of the List area. They are used to change the display
format of the list. You can also use the drop-down lists of the Filter list area to display specific
type of interferences in the list area. After checking the required interferences, choose the
OK button to close the Check Clash dialog box.

Sectioning an Assembly

Sometimes it is required to section an assembly model to view its cross-section. This
is required to analyze the clearance and interference of internal parts, which may not
be visible from outside. To section an assembly model, choose the Sectioning button

from the Space Analysis toolbar; the Sectioning Definition dialog box is displayed, as shown
in the Figure 11-48.

Figure 11-46  The Check Clash dialog box

Menu: Analyze > Clash
Toolbar: Space Analysis > Clash
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The 2D representation of the section view is represented in another window, which is tiled
vertically with the assembly window. The assembly window displays the sectioning plane. By
default, the sectioning plane is coincident to the YZ plane. To change the position of the
sectioning plane, place the cursor over it to display a bidirectional arrow. This arrow will be
pointing normal to the sectioning plane. After the blue arrow is displayed, drag the plane to
reposition it. You can also use the red compass to rotate the sectioning plane in the same way
as it is used for reorienting parts. The size of the sectioning plane can be modified by dragging
its edges. You can also position the sectioning plane using the options available in the
Positioning tab of the Sectioning Definition dialog box. Figures 11-49 and 11-50 show the
2D sectional view generated by sectioning the model and the plane used to create the section,
respectively.

Figure 11-48  The Sectioning Definition dialog box

Figure 11-47  The Preview window
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The Definition tab is selected by default when the Sectioning Definition dialog box is invoked.
Under this tab, there are two buttons. The button on the left is used to select the type of
sectioning required. Choose the down arrow displayed on the right of this button to open the
flyout. This flyout displays the three sectioning options. The section can be created using a
plane or a slice of the model can be generated by sectioning it between two planes, or a
portion of the model can be sectioned out by placing  it in a bounding box. The next is the
Volume Cut button. If this button is selected, the solid section view of the assembly is displayed
in the assembly model window. If you need to view only the 2D section view of some selected
parts, then click in the Selection selection area and select the required parts from the
Specification Tree. Selecting the same part again will remove it from the current selection
set. To view the section of the whole assembly again, remove all parts from the current selection
set and select the product, if it is not available in the current selection set. After viewing the
required sectional view, choose the OK button to exit the Sectioning Definition dialog box.
The cross-section that is generated after sectioning the model is now displayed in the
geometry area and the corresponding section name is displayed in the Specification Tree
inside the Applications heading. Now, close the window with the section view and maximize
the product file.

Hide the section, if you do not want it to be displayed.

Exploding an Assembly

Generally, an assembly model consists of a large number of parts. Some of the parts
are assembled inside the other parts. Therefore, these parts are not visible and the
user is unable to see all components present in the assembly. To resolve this problem,

the assembly is exploded such that all components are moved from their original position to
a location where they are clearly visible. To explode an assembly, choose the Explode button
from the Move toolbar; the Explode dialog box will be displayed, as shown in the Figure 11-51.

Figure 11-50  The sectioning planeFigure 11-49  The 2D section view of the complete
assembly

Menu: Edit > Move > Explode in assembly design
Toolbar: Move > Explode
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Make sure Product1 is activated in the Specification Tree before invoking the Explode tool. If
there are multiple assemblies in the product file, you can select any one of them to explode.

You can set the parameters for exploding the assembly in the Explode dialog box. The
options of this dialog box are discussed below:

The Depth drop-down list is provided with two options. If the First level is selected from this
drop-down list, the parts of the subassembly are not exploded. Rather, the subassembly will
be treated as a single component. The components of the subassembly will be exploded only
if the All level option is selected from the Depth drop-down list. The Selection selection
area displays the number of products that have been selected for explosion. The Fixed Product
selection area is used to select a part of the assembly that needs to be fixed, while exploding
the assembly. All other parts will be moved with respect to it. In the Type drop-down list,
there are three options. By default, the 3D option is selected, which enables the assembly
model to explode in the 3D space and the components are placed arbitrarily in it. The
assembled view of the Belt Tightener assembly is shown in Figure 11-52 and Figure 11-53
shows the position of components, after the assembly is exploded using the 3D option.

If you select the 2D option from the Type drop-down list, the components are exploded and
placed parallel to the viewing plane. Figure 11-54 shows the Belt Tightener assembly exploded

Figure 11-53  Overlapping components in 3D
explosion of the assembly

Figure 11-52  The Belt Tightener in the
assembled state

Figure 11-51  The Explode dialog box



11-36        CATIA for Designers (Evaluation Chapter F007/004)

Ev
al

ua
ti

on
 c

ha
pt

er
. 

Lo
go

n 
to

 w
w

w
.c

ad
ci

m
.c

om
 f

or
 m

or
e 

de
ta

ils

using the 2D option, with the front plane parallel to screen. Figure 11-55 shows the top view
of the same exploded assembly.

The third option provided in the Type drop-down list is the Constrained. This option is
selected to explode the assembly in such a way that some of the constraints applied to the
parts are maintained. This results in a more organized explosion, as shown in the Figure 11-56.

After all selections are made in the Explode dialog box, choose the Apply button; the assembly
will be exploded and the Information Box will be displayed. This box intimates you that the
exploded parts can now be moved using the 3D compass. Move the components to arrange
them in a more realistic manner, if required. Choose the OK button to close this Information
Box. You can clear the Show this message next time check box to prevent the Information
Box from appearing every time you explode a model. Finally, choose the OK button from the
Explode dialog box to close it and then choose Yes from the Information Box. The exploded
assembly is shown in the geometry area.

Figure 11-55  Top view of the exploded Belt
tightener assembly

Figure 11-54  Front view of the exploded Belt
Tightener assembly exploded using the 2D option

Figure 11-56  Figure showing the exploded assembly
with Constrained selected as the type
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Tutorial 1

Figure 11-57  The Blower assembly

Figure 11-58  Exploded view of the Blower assembly

To switch back to the assembled view, choose the Update button from the Tools toolbar.

TUTORIALS

In this tutorial you will create all the components of the Blower assembly and then assemble
them together. The Blower assembly is shown in Figure 11-57. After creating the assembly,
you will generate the exploded view. The exploded view of the Blower assembly is shown in
Figure 11-58. The dimensions of all components are given in Figures 11-59 through 11-64.

    (Expected time: 2.5 hrs)
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Figure 11-59  Views and dimensions of the Upper Housing

Figure 11-60  Views and dimensions of the Lower Housing
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Figure 11-61  Views and dimensions of the Blower

Figure 11-62  Views and dimensions of the Motor
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Figure 11-63  Views and dimensions of the Cover

Figure 11-64  Views and dimensions of the Motor Shaft
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The following steps are required to complete this tutorial:

a. Create all components of the assembly as separate part files in the Part Design workbench.
b. Start a new file in the Assembly Design workbench.
c. Insert the Lower Housing into the assembly as the base component, set its orientation,

and apply the Fix constraint to it at its default location, refer to Figures 11-65 through
11-67.

d. Insert the Upper Housing into the assembly and place it over the lower housing by
applying proper constraints, refer to Figures 11-68 through 11-70.

e. Hide the Upper Housing. Insert and place the blower inside the lower Housing.
f. Now, insert and constrain the Motor, the Motor Shaft, and the Cover refer to Figures 11-71

through 11-77.
g. Turn on the display of the Upper Housing, refer to Figure 11-78.
h. Create the exploded state of the assembly, refer to Figure 11-79.
i. Save the assembly file.

Before you start creating components for this tutorial, create \My
Documents\CATIA\c11\Blower Assembly folder. You will save the parts of the blower assembly
in this folder. Note that you should change the Part Number of every component before
saving it. The process of changing the Part Number of a components has already been
discussed earlier in this chapter.

Creating Components of the Assembly
The Blower assembly will be created using the bottom-up approach. As mentioned earlier,
in bottom-up assemblies, all parts are first created as individual part files and then inserted
in the assembly file.

1. Create all parts of the assembly and save them as separate part files in the above mentioned
folder.

2. Close all the part files, if they are open.

Starting a New File in the Assembly Workbench
All components that you have created above need to be assembled in an assembly file.
The assembly file has a file extension *.CATProduct. You need to start a new file in the
Assembly Design workbench to assemble the parts.

1. Choose the New button from the Standard toolbar. The New dialog box is displayed.

2. Choose the Product option from the List of Types list box.

3. Choose the OK button to start a new product file. A new file is started in the Assembly
Design workbench, and the Product1 is displayed on the top of the Specification Tree.

Note
If you start a new session of CATIA, an assembly file is started automatically. Therefore, if you
start another file, it will be named Product2.
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Inserting the First Component and Fixing it
After the new product file is started, you can insert the base component into the assembly.
In this case, the Lower Housing is the base component. After inserting the Lower Housing,
you need to set the orientation of the Lower Housing and then fix its location.

1. Choose the Existing Component button from the Product Structure Tools
toolbar.

2. Select the Product1 from the Specification Tree; the File Selection dialog box is displayed.
From this dialog box browse the location of the file of Lower Housing and open it.

The Lower Housing is displayed in the geometry area and its name is shown in the
Specification Tree. The current orientation of the isometric view is not the same as that
required in the assembly. Therefore, you need to set the orientation of the model. The
orientation of the model will be set by using the Snap tool.

3. Choose the Snap button from the Move toolbar. Select the first element and the
second element, as shown in Figure 11-65. The orientation of Lower Housing is
changed and a flip arrow is displayed on it.

4. Click anywhere in the geometry area to exit the Snap tool. Set the orientation of the view
of the assembly to Isometric. The Lower Housing is placed in the correct orientation, as
shown in Figure 11-66.

Next, you need to apply the Fix constraint to lock it position.

5. Choose the Fix Component button from the Constraints toolbar and select the
Lower Housing from the geometry area or from the Specification Tree.

The symbol of the Fix constraint is displayed on the Lower Housing in the geometry area.
Figure 11-67 shows the Lower Housing after fixing it at its location.

Figure 11-66  Lower Housing after modifying its
orientation

Figure 11-65  First and second elements to be
selected
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Inserting the Upper Housing and Constraining it
The sequence in which the parts should be inserted into the assembly depends on the
user. In this case, the Upper Housing will be the second component to be inserted into
the Blower assembly.

1. Insert the Upper Housing in the similar way as discussed earlier. Note that the Part
Number of all components were modified before saving the part files. Therefore, the
Part Number Conflicts dialog box will not be displayed for any component.

The Upper housing is placed at its default location, as shown in the Figure 11-68.  You
need to apply constraints to place it properly over the Lower Housing.

The first constraint that will be applied to the Upper Housing is the Contact constraint.
This constraint will be applied between the upper face of the Lower Housing and the
lower face of the Upper Housing.

2. Choose the Contact Constraint button from the Constraints toolbar. Select the
two faces shown in Figure 11-68. You need to rotate the view of the assembly to
select the surface that is not visible in the current display.

3. Choose the Update All button, if it is active. If this button is not active, the assembly does
not need updation.

The Contact constraint is applied between the two surfaces and its name is displayed in
the Specification Tree under Constraints.

Next, you need to apply the Coincidence constraint between the cylindrical surfaces of
the two components to make them concentric.

Figure 11-68  The surfaces to be selected to
apply Contact constraint

Figure 11-67  Lower Housing after it is fixed at
its default location
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Tip. To check whether a part is fully constrained, try to reorient it using the
Manipulation tool with the With respect to constraints check box selected. If
the part is fully constrained, it will not move or rotate in any direction.

4. Choose the Coincidence Constraint button from the Constraints toolbar.
Now, select the two cylindrical surfaces, as shown in the Figure 11-69, to select
the central axes of these surfaces.

5. Choose the Update All button to reorient the Upper Housing.

Note
To confirm the presence of the free degree of freedom, double-click on the Upper Housing in the
Specification Tree. The Upper Housing is activated. Now, choose Analyze > Degree(s) of
freedom from the menu bar. The Degrees of Freedom Analysis dialog box is displayed along
with a set of arrows in the x direction. This set of arrows displays the degree of freedom which is
free. Choose the Close button from the Degrees of Freedom Analysis dialog box.

Next, you need to align the right face of the Upper Housing with that of the Lower
Housing. This can be done by applying the Offset constraint with 0 offset.

6. Choose the Offset Constraint button from the Constraints toolbar, and select
the faces shown in Figure 11-70, to apply constraint between them.

The Constraint Properties dialog box is displayed. Make sure that the Orientation is set
to Same, and the Offset value is set to 0.

7. Choose the OK button, and then choose the Update All button to apply the Offset
constraint. The Upper Housing is fully constrained.

Figure 11-70  The surfaces to be selected for
applying Offset constraint

Figure 11-69  Surfaces on which you need to
click to select the central axes
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Assembling the Blower after Hiding the Upper Housing
The Blower needs to be assembled between the Upper and Lower Housings. To ease the
process of assembling the Blower, you need to hide the Upper Housing.

1. Invoke the contextual menu by right-clicking on the name of the Upper Housing in the
Specification Tree and choose the Hide/Show option to turn off the display of the selected
component.

2. Now, insert the Blower in the assembly. Choose the Coincidence Constraints
button and select the faces shown in Figure 11-71 to select the central axes of
these faces.

3. Update the assembly.

Next, you need to place the left face of the Blower at an offset distance 0.635 from the
inner left face of the Lower Housing using the Offset constraint.

4. Apply the Offset constraint between the faces shown in Figure 11-72. Enter 0.635 as the
value in the Offset spinner and make sure that the Orientation is set to Opposite in
the Constraint Properties dialog box. Update the model to bring the blower to its proper
position.

Assembling the Motor Shaft
Next, you need to assemble the Motor Shaft.

1. Insert the Motor Shaft into the assembly file. By default, it is placed in the middle of the
existing assembly, as shown in Figure 11-73. You need to move it out of the assembly to
get a better view of the shaft.

Figure 11-72  Faces to be selected for applying
Offset constraint

Figure 11-71  Faces to be clicked to select the
central axes
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2. Select the Manipulation button from the Move toolbar. Choose the Drag along
X axis button and drag the Motor Shaft to move it out of the assembly, as shown
in Figure 11-74. Exit the Manipulation Parameters dialog box.

The direction of the Motor Shaft needs to be flipped. This is done because by default,
the orientation of the Motor Shaft is not the same as that required. The direction of
Motor Shaft will be flipped, while applying the constraint.

3. Choose the Offset button and then select the faces shown in the Figure 11-74.
The Constraint Properties dialog box is displayed. Set the Orientation to Same
and the Offset value to 0. Update the model to place the Motor Shaft at its
proper location.

Next, you need to apply the Coincidence constraint between the axis of the Motor Shaft
and the Blower hub. You will use the Quick Constraint tool to apply this constraint.

4. Choose the Quick Constraint button from the Constraints toolbar and move
the cursor over the Motor Shaft. The axis of the shaft will be displayed as a
center line. Select the axis by clicking over the center line. The axis will be now
highlighted in orange. Similarly, select the axis of the Blower hub. The Coincidence
constraint will be automatically applied between the two selected axes. Update the model
to place the Motor Shaft inside the Blower hub, as shown in Figure 11-75.

Assembling the Motor
Next, you need to assemble the Motor with the Motor Shaft.

1. Insert the Motor in the Blower assembly. By default it will be placed in such a way that its
body will overlap the existing assembly parts. Therefore, use the Manipulation tool to
move it out into the open space.

Figure 11-74  Faces to be selected for Offset
constraint

Figure 11-73  Motor Shaft inserted at its default
location
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2. Now apply the Offset constraint between the faces shown in the Figure 11-76. Set the
Orientation to Same and the Offset value zero.

3. Apply the Coincidence constraint between the axis of the shaft and the axis of the hole
on the back side of the Motor, refer to Figure 11-76. After applying both the constraints,
update the model.

You will notice that the base of the Motor and the Lower Housing appear to be parallel,
but there is no constraint applied to both the faces. Therefore, you need to apply the
Angle constraint to these two faces.

4. Choose the Angle button from the Constraints toolbar. Select the faces, as shown in
Figure 11-76. Select the Parallelism radio button to make the selected faces parallel.

Figure 11-75  Position of the Motor Shaft with
respect to the Blower shown from back side

Figure 11-76  Elements to be selected for applying various constraints
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Assembling the Cover and Turning on the Display of the Upper
Housing

The last component to be assembled is the Cover. After assembling all components, you
need to turn on the display of the hidden Upper Housing.

1. Insert the Cover into the Blower assembly. By default, it will be placed inside the blower.
Use the Manipulation tool to move the Cover away from the assembly. Next, you need to
apply constraints to the Motor Cover.

2. Apply the Contact constraint between the front face of the Motor and the bottom face of
the Cover.

3. Apply the Coincidence constraint between the central hub of the Cover and cylindrical
face of the Motor.

4. Apply another Coincidence constraint between one of the screw holes in the Cover and
Motor. Various faces to be selected for applying these three constraints are shown in
Figure 11-77. After all three constraints are applied, update the model to properly orient
the cover in the Blower assembly.

Next, you need to turn on the display of the Upper Housing.

5. Select the Upper Housing from the Specification Tree and choose the Hide/Show option
from the contextual menu. The Upper Housing is displayed in the geometry area.

6. Select all constraints available under the Constraints heading in the Specification Tree
and hide them. The Blower assembly is completed. The final assembly is shown in
Figure 11-78.

Figure 11-77  Various faces to be selected for applying the constraints
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Figure 11-78  The final Blower assembly.

Creating the Exploded State of the Assembly
After creating the assembly, you can create the exploded state of the assembly. In the
exploded state, all parts of the assembly are distinctly visible.

1. Select Product1 from the Specification Tree and choose the Explode button
from the Move toolbar. The Explode dialog box is displayed.

2. Select the All levels option from the Depth drop-down list and select 2D from the Type
drop-down list. Click in the Fixed product area and then select the Lower Housing as
the product to remain fixed, while exploding the assembly.

3. Choose the Apply button from the Explode dialog box to generate the exploded view.
The Information Box will be displayed. Choose the OK button from the Information
Box to close it. The exploded view of the Blower assembly is shown in Figure 11-79.

4. Choose the OK button from the Explode dialog box and then choose Yes from the
Warning dialog box. The exploded state of the assembly is displayed in the geometry
area.

5. To switch back to the assembled mode, choose the Update button from the Tools toolbar.

Saving the File
1. Choose the Save button from the Standard toolbar. The Save As dialog box will be

displayed.

2. Browse for the \My Documents\CATIA\c11\Blower Assembly folder and save the file.
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In this tutorial, you will create some components of a Press Tool Base assembly using the
top-down assembly approach. The Press Tool Base assembly is shown in Figure 11-80. The
exploded state of this assembly is shown in the Figure 11-81. The dimensions of all components
are shown in Figures 11-82 and 11-83. The drawing of the complete assembly is shown in
Figure 11-80.     (Expected time: 45 min)

Note
Note that this is not a complete assembly of a Press Tool Base and is only created to explain the
procedure of top-down assembly approach.

Figure 11-79  The exploded view of Blower assembly

Tutorial 2

Figure 11-80  The Press Tool Base assembly
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Figure 11-82  Views and dimensions of the Top Plate, Guide Pillar, and Guide Bush

Figure 11-81  The exploded state of the Press Tool Base assembly
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Figure 11-83  Views and dimensions of the Bottom Plate

Figure 11-84  Drawing views of the Press Tool Base assembly
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The following steps are required to complete this tutorial:

a. Start a new product file.
b. Create a new part inside the assembly. Modify its name and create features of the base

component, refer to Figure 11-85. In this assembly the Bottom Plate will be the base
component.

c. Create the Guide Bush and Guide Pillar as subsequent components inside the product
file, refer to Figure 11-86 through 11-88.

d. Guide Pillar and Guide Bush are to be duplicated using the Reuse Pattern tool, refer to
Figure 11-89.

e. Create the Top Plate, refer to Figure 11-90.
f. Finally save the Product file. The Part files will be saved automatically.

Before you start creating the top-down assembly, create the \My Documents\CATIA\c11\Press
Tool Base folder. You will save the product file of the Press Tool assembly in this folder. All
the Part files will also be automatically saved in the same folder.

Starting a New Product File
1. Choose the New button from the Standard toolbar and select the Product option from

the List of Types area of the New dialog box. Choose the OK button to start a new
Product file.

2. Invoke the contextual menu by right-clicking on Product1 in the Specification Tree.
Select Properties from the contextual menu to display the Properties dialog box.

3. Choose the Product tab, if it is not chosen, and change the part number to Press Tool Base
in the Part Number edit box. Choose the OK button from the Properties dialog box.
Note that now Press tool is displayed at the top of the Specification Tree.

When the Product file is saved, it will automatically assign the name Press Tool.

Creating a New Part Inside the Assembly
1. Select Press Tool Base from the Specification Tree and choose the Part button

from the Product Structure Tools toolbar.

A new part is started inside the product file and is represented by Part1 in the Specification
Tree. Also, default planes are displayed in the geometry area. These are the default
planes of the part and its origin is placed over the origin of the assembly coordinate
system.

2. Set the part number and the instance name of the new part to Bottom Plate in the Properties
dialog box invoked by right clicking on Part1 in the Specification Tree.

3. Choose Tools > Options from the menu bar to invoke the Options dialog box. Select
Infrastructure available on the left of this dialog box to expand this branch. Now, select
the Part Infrastructure from the Infrastructure branch. Select the Keep link with selected
object check box.



11-54        CATIA for Designers (Evaluation Chapter F007/004)

Ev
al

ua
ti

on
 c

ha
pt

er
. 

Lo
go

n 
to

 w
w

w
.c

ad
ci

m
.c

om
 f

or
 m

or
e 

de
ta

ils

Figure 11-85  The final model of the Bottom Plate

Creating Features of the Bottom Plate
After a new part file is created inside the assembly, you need to invoke the Part Design
workbench to create the features. Since, the Bottom Plate is the base component, you will
now create its features.

1. Click on the plus sign on the left of Bottom Plate in the Specification Tree to expand its
branch. Now, double-click on the Bottom Plate, which is displayed inside the expanded
branch to invoke the Part Design workbench.

2. Create the Bottom Plate using the part modeling tools. The final model of the Bottom
Plate is shown in Figure 11-85.

3. Double click on Press Tool Base in the Specification Tree for switching to the Assembly
Design workbench.

4. Apply the Fix constraint to the Top Plate.

Creating the Guide Pillar
Next, you need to create the Guide Pillar by referring to the geometry of the Base Plate.

1. Choose the Part button from the Product Structure Tools toolbar to insert the
second part in the assembly. The New Part: Origin Point dialog box is displayed.

2. Choose the No button from the New Part: Origin Point dialog box to place the origin of
the second part over the origin of the assembly coordinate system.

3. Rename the second component to Guide Pillar and invoke the Part Design
workbench by double-clicking on it.

4. For creating the Guide Pillar, you need to take the reference of the geometry of the
Bottom Plate. Select the bottom face of the Bottom Plate as the sketching plane and
invoke the Sketcher workbench.
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5. Select the circular edge of left hole having the diameter of 25 and choose the
Project 3D Elements button from the Operation toolbar. The geometry is extracted
from the selected edge and is projected over the sketch plane.

Note that there is no need to provide any dimension to the circle. The size of the extracted
circle is the same as that of the edge of hole from which it is extracted.

6. Exit the Sketcher workbench and extrude the sketch, refer to Figure 11-82 for dimensions.

7. Hide the Bottom Plate and apply chamfer on both the ends of the Guide Pillar. This will
complete the feature creation of the Guide Pillar.

8. Turn on the display of the Bottom Plate and switch back to the Assembly Design
workbench. The Guide Pillar in the assembly is shown in Figure 11-86.

Creating the Guide Bush
It is evident from Figure 11-80, that Guide Bush will be placed over the Guide Pillar.
Therefore, the geometry of the Guide Pillar will be used to create the Guide Bush.

1. Start another part file inside the assembly file and rename it as Guide Bush. Invoke the
Part Design workbench.

2. Select the top face of the Guide Pillar as the sketching plane and draw two concentric
circles. Make the inner circle coincident with the outer edge of the Guide Pillar and
apply dimension to the outer circle, as shown in the Figure 11-87.

3. Exit the Sketcher workbench and extrude the sketch to 60 units. Now apply chamfers at
both outer edges of the Guide Bush.

4. This completes the feature creation of the Guide Bush as shown in Figure 11-88. Return
to the assembly workbench by double clicking on Press tool in the Specification Tree.

Figure 11-86  Final Guide Pillar
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Figure 11-88  Final Guide BushFigure 11-87  Sketch of Pad feature for creating
Guide Bush

Creating Second set of Guide Bush and Guide Pillar
In the Press Tool Base assembly, Guide Bush and Guide Pillar are used in pairs. Therefore
to create the second set of Guide Bush and Guide Pillar, you will use the Reuse Pattern
tool. The advantage of using this tool is that the second set of components will be places
at the desired location without applying any constraints between them.

1. Expand the branch of Bottom Plate in the Specification Tree to display the
Rectangular Pattern used for creating holes.

2. Press and hold down the CTRL key from the keyboard. Select the RecPattern2 and Guide
Pillar from the Specification Tree.

3. Choose the Reuse Pattern button from the Constraints toolbar; the Instantiation
on a pattern dialog box is displayed. Choose the OK button to place another
Guide Pillar in the second hole.

4. Similarly, assemble the second Guide Bush over the newly placed Guide Pillar using
the Resume Pattern tool by selecting the rectangular pattern and Guide Bush from the
Specification Tree.

Once both the components are duplicated, you can close the expanded branch of the
Specification Tree. Figure 11-89 shows the assembly model, after placing the second set
of  Guide Pillar and Guide Bush.

Creating the Top Plate
Top Plate is the last component that will be created in the Press Tool Base assembly. You
will use the reference of the geometries of Bottom Plate and Guide Bush to draw the
sketch for the Pad feature of the Top Plate.

1. Start another part inside the assembly file and rename it as Top Plate. Invoke the Part
Design workbench.
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2. Select the top face of the Guide Pillar as the sketching plane and invoke the Sketcher
workbench.

3. Extract four side edges of the Bottom Plate and the outer circular edge of the  Guide
Bush using the Project 3D Elements tool, as shown in Figure 11-90.

4. Exit the Sketcher workbench and extrude the sketch by 30 units by flipping its direction
of extrusion. Now, create a hole on the top face of the Top Plate.

This completes the feature creation of the Top Plate.

5. Switch back to the Assembly Design workbench. The final assembly is shown in the
Figure 11-91.

Figure 11-89  Assembly after placing the second
set of Guide Pillar and Guide Bush

Figure 11-90  Sketch of the Pad feature for
creating Top Plate

Figure 11-91  The final Press Tool Base assembly
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Figure 11-92  The Save As confirmation box

Saving the Assembly File
1. Choose the Save button from the Standard toolbar. You need to make sure that you are in

the Assembly Design workbench before saving the assembly. The Save As dialog box is
displayed.

2. Browse the location of the Press Tool Base folder that you created in the beginning of this
tutorial.

3. Choose the Save button from the Save As dialog box. The Save As confirmation box is
displayed, as shown in Figure 11-92.

4. Choose the Yes button from this confirmation box to save the assembly file, along with
all the Part files.

5. Close the assembly file by choosing File > Close from the menu bar.

SELF-EVALUATION TEST
Answer the following questions and then compare your answers with those given at the
end of this chapter.

1. In the bottom-up assembly design approach all parts are created in separate part files
and then inserted in to the product file. (T/F)

2. While creating a top-down assembly in CATIA V5, all individual parts created in the
assembly needs to be saved separately, after saving the Product file. (T/F)

3. The Angle constraint can be used to make two surfaces parallel to each other. (T/F)

4. The Manipulation tool is used to move and rotate a part present inside an assembly.
(T/F)

5. You cannot select a component to fix it at its original position, while exploding an
assembly model. (T/F)
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6. The __________constraint is used to place two planar faces at a specified angle with
respect to each other.

7. You can place multiple instances of a component over a predefined pattern by using the
__________tool.

8. The __________option is selected from the Type drop-down list in the Explode dialog
box to explode all components of assembly along the 2D plane, which is currently parallel
to screen.

9. The edges of a component can be snapped on to an edge of another component by using
the __________ tool.

10. If two parts having the same name are inserted into the assembly file then __________
dialog box is displayed.

REVIEW QUESTIONS
Answer the following questions.

1. The __________ constraint is used to make two cylindrical surfaces concentric.

2. Select the component and then choose the __________ button to hide it from the geometry
area.

3. The __________ tool can be used to move a component and also apply a constraint to it.

4. The cross-section of an assembly model can be viewed using the __________ tool.

5. An existing part can be inserted into a Product file using the _________ button.

6. Which tool is used to calculate the interference between two mating components?

(a) Measure (b) Clash
(c) Smart Move (d) Snap

7. Which button is used to replace a constraint by another constraint?

(a) Reuse Pattern (b) Replace Component
(c) Change Constraint (d) Replace Constraint

8. Which button is used to apply the most appropriate constraint to the current selection
set?

(a) Quick Constraint (b) Change Constraint
(c) Contact Constraint (d) None of these
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Figure 11-93  The Radial Engine assembly

Exercise 1

9. After selecting the Reuse Pattern button, which dialog box is displayed?

(a) Instantiation on a pattern (b) Reuse pattern
(c) Constraint properties (d) Constraint definition

10. Which constraint is used to fix the position of a part in 3D space?

(a) Contact (b) Fix
(c) Coincidence (d) Angle

EXERCISE

Create the assembly of the Radial Engine shown in Figure 11-93. The assembly in the
exploded state is shown in Figure 11-94. Note that this exploded view is provided only for
your understanding and has not been generated using CATIA. The dimensions of various
parts of this assembly model are given in Figure 11-96 through Figure 11-99.

         (Expected time: 3 hr 30 min)
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Figure 11-94  Exploded view of the Radial Engine assembly

Figure 11-95  Positioning of the Articulated Rods



11-62        CATIA for Designers (Evaluation Chapter F007/004)

Ev
al

ua
ti

on
 c

ha
pt

er
. 

Lo
go

n 
to

 w
w

w
.c

ad
ci

m
.c

om
 f

or
 m

or
e 

de
ta

ils

Figure 11-96  Views and dimensions of the Master Rod
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Figure 11-97   Views and dimensions of the Piston

Figure 11-98   Views and dimensions of the Articulated Rod
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Figure 11-99   Views and dimensions of the other components

Answers to Self-Evaluation Test
1. T, 2. F, 3. T, 4. T, 5. F, 6. Angle, 7. Reuse Pattern, 8. 2D, 9. Snap, 10. Part number conflicts


