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Generative Shape

Design

 Learning Objectives 
After completing this chapter, you will be able to:
• Create Wireframe Elements
• Create Volumes
• Create Surfaces
• Perform Operations on Shape Geometry
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THE GENERATIVE SHAPE DESIGN WORKBENCH
The Generative Shape Design workbench allows you to quickly model both simple and complex
shapes using wireframe and surface features. Because of its wide range of functional sets, it 
provides a large set of tools for creating and editing shape designs. CATIA V5-Generative 
Shape Design is a complete surfacing tool for novice and advanced shape designers. Due to its 
interoperability with other products such as Part Design and FreeStyle Shaper and Optimizer, 
it meets the requirements of solid-based hybrid modeling.

In this chapter, you will learn about wireframe, surface, and solid geometry modeling tools to 
fully capture the design intent. 

CREATING WIREFRAME ELEMENTS
Start a new session of  CATIA V5 and close the new product file, which is opened by default. Next, 
choose Generative Shape Design from Start > Shape in the menu bar to start a new file in the 
Generative Shape Design workbench. On invoking the Generative Shape Design workbench, 
the Wireframe toolbar is displayed, as shown in Figure 17-1. The tools in this toolbar are used 
to create wireframe geometries and curves. These geometries and curves play a major role in 
creating surfaces. The tools for constructing wireframe geometries are Line, Polyline, Circle, 
Spline, Helix, and so on. Some of these tools are discussed in Chapter 10.

Figure 17-1  The Wireframe toolbar

Creating a Corner
  Menubar:  	 Insert > Wireframe > Corner	                                                       
  Toolbar:	 Wireframe > Circle-Conic sub-toolbar > Corner    

In the Generative Shape Design workbench, the Corner tool is used to create an arc of 
specific radius, which is tangent continuous with two elements. The elements can be 
wireframe lines or curves, sketch lines or curves, solid edges, surface boundaries, and 

edges. To create a corner, choose the Corner tool from the Circle-Conic sub-toolbar of the 
Wireframe toolbar, refer to Figure 17-2; the Corner Definition dialog box will be displayed, as 
shown in Figure 17-3. In this dialog box, the Corner On Support option is selected by default 
in the Corner Type drop-down list. Select the 3D Corner option from the Corner Type 
drop-down list if you want to create a corner between two 3D curves. After selecting the corner 
type, you need to select a curve or a point as the first element. Select a curve as the first element 
from the graphics window; the selection will get displayed in the Element 1 selection box. Next, 
you will be prompted to select the second curve. Select the second curve in the Element 2 
selection box and preview will be displayed. The Corner On Vertex check box is used to remove 
sharp corners of the selected curve. After selecting this check box, you need to select a point or 
a curve in the Element 1 selection box. The Element 2 selection box, Trim element 1 check 
box, and Trim element 2 check box are disabled when you select the Corner on Vertex check 
box. The Trim element 1 and Trim element 2 check boxes are used to trim the referencing 
curves from the point of tangency. You can also create curves by choosing any one of the options 
from the contextual menu which is displayed when you right-click in the corresponding selection box 
in the Corner Definition dialog box. The Support selection box is used to select the surface on 
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which the fillet corner is to be placed in case of a non coplanar curve. In this case, the selected 
elements must lie on the surface. In case there are more than one solution, the corner closest 
to the selected point will be created. Choose the Next Solution button from the Corner Definition 
dialog box to get the desired solution and choose OK to create the corner, as shown in 
Figures 17-4 and 17-5.

Figure 17-3  The Corner Definition dialog boxFigure 17-2  The Circle-Conic sub-toolbar

Figure 17-4  Corner created between two 	
planar elements

Figure 17-5  3D corner created between 	
two non-planar elements

Note
1. If selected elements are coplanar, the corresponding support plane gets selected by default. 

2. If selected elements are non coplanar elements then you can select any surface as support geometry.

Creating a Connect Curve
  Menubar: 	 Insert > Wireframe > Connect Curve			     
  Toolbar:	 Wireframe > Circle-Conic sub-toolbar > Connect Curve	  

The Connect Curve tool is used to connect two points or two curves with a curve. You 
can specify tangency and curvature constrains of the connect curve with reference curves. 
You can also control the transition of the connected curve by specifying the tension factor 
for the connected curve. 
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To create a connect curve, choose the Connect Curve tool

Figure 17-6  The Connect Curve 
Definition dialog box

from the Circle-Conic sub-toolbar of the Wireframe toolbar; 
the Connect Curve Definition dialog box will be displayed, 
as shown in Figure 17-6. By default, Normal is selected in the 
Connect type drop-down list and you will be prompted to 
select the first point. You can also select the Base Curve option 
from the Connect type drop-down list and select a reference 
curve in the Base Curve selection box, if you want to create 
a connect curve with same orientation as the selected base 
curve. Now, select a predefined point. Alternatively, you can 
right-click in the Point selection box to create a new point 
using the options available in the contextual menu. After 
selecting the first point, you will be prompted to select the 
first curve. Select the curve in the Curve selection box; you 
will be prompted to select the second point. Select the second 
point in the Point selection box in the Second Curve area; 
you will be prompted to select the second curve, refer to 
Figure 17-7. Select the second curve in the Curve selection 
box under the Second Curve area; the connect curve will be 
created between the elements. Note that if the selected points 
are the end points of the reference curves, the curve will be 
selected by default in the Curve selection box. You can apply 
continuity between the end points of the connect curve by using the options available in the 
Continuity drop-down list. You can also specify a factor of tension in the Tension spinner in 
the First Curve and Second Curve areas. Select the Reverse Direction button to reverse the 
direction of the connect curve at the tangent end. Choose the Trim elements check box to trim 
the reference curves from the point of tangency.

Figure 17-7  Curves selected to create the connect curve

Creating a Conic Curve                                                            
  Menubar:	 Insert > Wireframe > Conic		                                                                                              
  Toolbar:	 Wireframe > Circle-Conic sub-toolbar > Conic     

The Conic tool is used to create conic-type curves such as parabolas, ellipses, or hyperbolas. 
To create a conic curve, choose the Conic tool from the Circle-Conic sub-toolbar of the 
Wireframe toolbar; the Conic Definition dialog box will be displayed, as shown in 
Figure 17-8. The options in this dialog box are discussed next.
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Support 
In this selection box, you can select a plane or planar

Figure 17-8  The Conic Definition 
dialog box

 
surface as support geometry on which the curve is to be 
placed. You can also use the options from the contextual 
menu by right-clicking in the Support selection box 
to create a new plane or a planar surface.

Constraint Limits
In the Constraint Limits area, you can specify the start 
and end points for the conic curve in the Start and End 
selection boxes under the Points option. Next, you need 
to define the tangency definitions for the corresponding 
start and end points in the Start and End selection boxes 
under the Tangents option. Usually, the tangent of the 
start and end points is defined by a line. If you select the 
Tgt Intersection Point check box, the Point selection box gets activated and the Start and End 
selection boxes get deactivated. Now, choose a point to define an intersection point of the start 
and end tangents. 

Intermediate Constraints
The Intermediate Constraints area in the Conic Definition dialog box is used to define the 
conic parameter between the start and end points of the conic curve. Select the Parameter 
check box and enter a value between 0 to 1. The value in the Parameter spinner will determine 
whether the resulting curve will be a parabola, ellipse or hyperbola. If the Parameter check box 
is not selected, then you can select guide points for the conic curve using the Point 1, Point 2, 
and Point 3 selection boxes. These points have to be selected in a logical order so that the curve 
passes through the start point, then through Point 1, Point 2, Point 3 and then the end point. 
Note that it is not necessary to specify all three points for the resulting curve. If you have selected 
only two points using the Point 1 and Point 2 selection boxes then you can assign tangency 
constraints to the points using the Tangent 1 and Tangent 2 selection boxes. By default, the 
Default Parabolic Result check box is already selected. You can clear the Default Parabolic 
Result check box if you do not want the resulting conic curve to be parabolic.

Note
Conic curves are defined by five constraints: start and end points, start and end tangents, passing 
points or a parameter. The elements necessary to define these curves are two points, start and end 
tangents, and a parameter; two points, start and end tangents, and a passing point, two points, 
a tangent intersection point, and a parameter; two points, a tangent intersection point, and a 
passing point; four points and a tangent; or five points.

Creating a Spiral Curve
  Menubar: 	 Insert > Wireframe > Spiral		                                                         
  Toolbar:	 Wireframe > Curves sub-toolbar > Spiral    

The Spiral tool is used to create spiral curves with the help of center point and support 
surface or plane. To create a spiral curve, choose the Spiral tool from the Curves 
sub-toolbar of the Wireframe toolbar; the Spiral Curve Definition dialog box will be 
displayed, as shown in Figure 17-9.
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Figure 17-9  The Spiral Curve Definition dialog box

Select a plane or planar surface as support for spiral curve from the graphics window; the selection 
will get displayed in the Support selection box. Next,  select a point to define the center of the 
spiral in the Center point selection box. Select a straight line, edge boundary, or plane in the 
Reference direction selection box. The start point of the spiral curve will lie in the reference 
direction selected. Next, you need to specify a value for the start radius in the Start radius edit 
box. Note that the starting point of the spiral will be positioned in the reference direction at a 
distance from the center point that is defined as the start radius of the spiral curve. Select the 
orientation of the spiral as Clockwise or Counterclockwise from the Orientation drop-down list. 
The options in the Type area are used to define the end angle, end radius, pitch and number 
of revolutions for the resulting spiral. Next, choose the OK button to generate the spiral curve.

Creating a Spine Curve
  Menubar: 	 Insert > Wireframe > Spine		                                                             
  Toolbar:	 Wireframe > Curves sub-toolbar > Spine    

The Spine tool is used to create spines and curves which are normal to a series of ordered 
planes or planar curves. These spines are useful for controlling the swept and lofted 
surfaces. With the help of a spine, you can orient the swept profile normal to the spine.

Choose the Spine tool from the Curves sub-toolbar; the Spine Curve Definition dialog box 
will be displayed, as shown in Figure 17-10. Also you will be prompted to select a plane, curve 
or a start point.

Select the planes, planar sections, and non-planar sections in a logical order under the 
Section/Plane selection area and choose the OK button to create the spine curve, refer to 
Figure 17-11. However, if you want to specify the starting point of the spine, select a point, 
vertex or extremity using the Start point selection box, the resulting spine will originate from 
the selected point. To create a spine using guide curves, click in the Guide selection area and 
successively select two or more guiding curves; the preview of the resulting spine is immediately 
displayed in the geometry area.
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Figure 17-11  The Spine Curve created 
using planar sections and planes with a 
start point

Figure 17-10  The Spine Curve 
Definition dialog box

Creating an Isoparametric Curve
  Menubar: 	 Insert > Wireframe > Isoparametric Curve	                                                                                       
  Toolbar:	 Wireframe > Curves sub-toolbar > Isoparametric Curve    

The Isoparametric Curve tool is used to create curves

Figure 17-12  The Isoparametric 
curve definition dialog box

 
that are associated with a support surface and are 
isoparametric in nature. Whenever the support 

surface is modified or updated, the isoparametric curve 
also gets updated itself. Choose the Isoparametric curve 
tool from the Curve sub-toolbar; the Isoparametric curve 
dialog box will be displayed, as shown in Figure 17-12. 
Select a surface from the graphics window; the selection 
will get displayed in the Support selection box. Next, you 
will be prompted to select a point. You can select a point 
by clicking at the desired location on the support surface 
or you can create a point using the point button available 
next to the Point selection box. After selecting the point, 
a curve with a manipulator upon the surface will be displayed, as shown in Figure 17-13. By 
default, line is selected in the Direction selection box but you can also create a line for direction 
reference by using the Line button next to the Direction selection box. Choose the Swaps Curve 
Direction button if you want to swap U and V parameter values of the curve, refer to Figure 17-14. 
In case you are selecting multiple joined surfaces as support geometry, the SwappedCells 
selection box will display the cells where the isoparametric propagation direction has been 
swapped from the nearest isoparametric propagation direction to the farthest isoparametric 
propagation direction, as shown in Figure 17-15.
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Figure 17-13  The isoparametric curve 
created on the surface

Figure 17-14  The isoparametric curve created 
using the Swaps UV Direction option

Figure 17-15   The isoparametric curve created using the SwappedCells option 

Note
In Figure 17-15, the isoparametric propagation direction has been swapped from the nearest 
isoparametric propagation direction to the farthest isoparametric propagation direction in the 
selected cell.

Creating a Parallel Curve
  Menubar: 	 Insert > Wireframe > Parallel Curve			    
  Toolbar:	 Wireframe > Curve Offsets sub-toolbar > Parallel Curve	

The Parallel Curve tool is used to create curves that

Figure 17-16 The Parallel Curve 
Definition dialog box

 
are parallel to the referencing elements such as curves 
and edges. The created parallel curve follows the 

selected support surface. The distance between the curves 
can be defined by a value, a law, or with reference to a selected 
point or vertex. Choose the Parallel Curve tool from the 
Curve Offsets sub-toolbar of the Wireframe toolbar; the 
Parallel Curve Definition dialog box will be displayed, as 
shown in Figure 17-16.

To create a parallel curve, select a reference curve from 
which the parallel distance will be measured. Next, select the 
support surface in the Support selection box. Enter an offset 
value in the Constant edit box. The offset behavior along the 
guide curve can also be specified by a law defined using the 
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Law button next to the Constant edit box. If you want the curve to pass through a selected point 
then select the point in the Point selection box; the Constant edit box will get disabled and the 
curve will be generated passing through the selected point. In the Parameters area, you can 
select the Euclidean or Geodesic option in the Parallel mode drop-down list. In the Euclidean 
mode, the shortest path between the parallel curve and the reference curve is measured while 
in the Geodesic mode, the offset distance is measured along the support surface, as shown in 
Figure 17-17 and 17-18. If you select the Euclidean option in the Parallel mode drop-down list, 
you can select the Sharp or Round option from the Parallel corner type drop-down list. Next, 
you can define smoothing parameters in the Smoothing area of the Parallel Curve Definition 
dialog box. If you select the None radio button, the resulting curve will not be smoothened. While 
selecting the Tangency radio button, the tangent continuity will be improved and on selecting 
the Curvature radio button, the curvature continuity will be improved. The Deviation edit box 
and the 3D Smoothing check box in the Smoothing area will become available on selecting the 
Tangency or the Curvature radio button, as shown in Figure 17-19. Select the 3D Smoothing 
check box for the better continuity of the resultant curve.

Choose the Reverse Direction button from the graphics area to reverse the direction of the 
generated curve. Alternatively, you can also click the arrow on the reference curve from the 
geometry area to reverse the direction of the curve. If you choose the Both Sides check box, 
parallel curves will be created at the same time on both sides of the reference curve.

Figure 17-17  The distance measured 
in the Euclidean mode

Figure 17-18  The distance measured 
in the Geodesic mode

Figure 17-19  The Deviation edit box
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Creating a Rolling Offset
  Menubar: 	 Insert > Wireframe > Rolling Offset		                                                                  
  Toolbar:	 Wireframe > Curve Offsets sub-toolbar > Rolling Offset    

The Rolling Offset tool is used to create a rolling curve at an offset distance from a 
reference curve. Choose the Rolling Offset tool from the Curve Offsets sub-toolbar of 
the Wireframe toolbar; the Rolling Offset Definition dialog box will be displayed, as 

shown in Figure 17-20. After invoking the dialog box, you are prompted to select curves for 
rolling offset. Select the curves from the graphics window; the selection will get displayed in the 
Curves selection box. Next, you will be prompted to select the support surface. Note that you 
can select multiple items at a time by clicking on the button next to the Curves selection box. 
Next, select a surface as support geometry in the Support selection box. If the reference curve 
is located on a planar surface then the support geometry is automatically selected, and if the 
reference curve is located on a non-planar surface, you will have to manually select the surface 
as the support geometry. Next, specify an offset value in the Offset edit box and choose the OK 
button to complete the definition of the rolling offset curve, as shown in Figure 17-21. 

Figure 17-21  The Rolling Offset curve 
created upon a surface

Figure 17-20 The Rolling Offset 
Definition dialog box

Creating a 3D Curve Offset
  Menubar: 	 Insert > Wireframe > 3D Curve Offset    		                  
  Toolbar:	 Wireframe > Curve Offsets sub-toolbar > 3D Curve Offset                                                                            

The 3D Curve Offset tool is used to create parallel curves in a defined direction. The 
parallel curve is created in a specified direction on the basis of tangent continuous curves, 
boundaries, or edges. Choose the 3D Curve Offset tool from the Curve Offsets 

sub-toolbar of the Wireframe toolbar; the 3D Curve Offset Definition dialog box will be 
displayed, as shown in Figure 17-22. 

Select a reference curve using the Curve selection box; you will be prompted to select the pulling 
direction. Select a plane or a line as the reference direction in the Pulling direction selection 
box or right-click in the Pulling direction selection box to invoke the contextual menu for 
creating a direction reference. The direction of offset will be aligned to the selected direction. 
Next, enter a value for the offset in the Offset edit box and choose the Preview button. Choose 
the Reverse direction button if the curve is not displayed in the desired direction after selecting 
the Preview button. In the 3D corner parameters area, you can define the parameters for the 
radius and tension for the generated curve. If the offset value is larger than the curve radius, 
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the generated curve may obtain a sharp corner as a result. You can enter a value in the Radius 
field to remove the corner to improve the curve propagation, refer to Figure 17-23. Enter a value 
in the Tension edit box to specify the tangency effect with neighboring curves at the location 
of radius transition.

Figure 17-22  The 3D Curve Offset 
Definition dialog box

Figure 17-23  The 3D curve offset created with 
radius and tension factor specified

Creating a Combine Curve
  Menubar: 	 Insert > Wireframe > Combine    		              
  Toolbar:	 Wireframe > Project-Combine sub-toolbar > Combine   

The combine curve is an intersection curve between the extrusion of the selected curves 
in virtual perpendicular directions. To create a combine curve, choose the Combine tool 
from the Project-Combine sub-toolbar, the Combine Definition dialog box will be 

displayed, as shown in Figure 17-24. Also, you will be prompted to select the curves to combine. 
Select the curves in the Curve1 and Curve2 selection box and choose the OK button to create 
the combine curve. By default, Normal is selected in the Combine type drop-down list. If you 
select Along directions in the Combine type drop-down list, you need to specify the directions 
for each curve in the Direction1 and Direction2 selection boxes. The combination of two curves 
is shown in Figure 17-25.  

Figure 17-25 The Combine curve 
created from curve 1 and curve 2

Figure 17-24 The Combine 
Definition dialog box
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Creating a Reflect Line
  Menubar: 	 Insert > Wireframe > ReflectLine   	               	                                      
  Toolbar:	 Wireframe  > Project-Combine sub-toolbar > ReflectLine                                 

Reflection lines and curves can be used to create guide curves or silhouettes and to check 
surface quality. Choose the ReflectLine tool from the Project-Combine sub-toolbar of 

the Wireframe toolbar; the Reflect Line Definition dialog box is displayed, as shown in 
Figure 17-26. Also, you are prompted to select the support to build the reflect line.

In the Type area of the Reflect Line Definition dialog box, the Cylindrical radio button 
is selected by default. Cylindrical lines tend to reflect curves with a light source at infinite 
distance whereas Conical lines tend to reflect curves with a point light source located at a finite 
distance. Select a surface in the Support selection box; you will prompted to select the reflect 
line direction. Next, select a direction reference using the Direction selection box. Specify the 
value of angle in the Angle edit box. By default, the Normal radio button is selected in the 
Angle Reference area. If you want the reflect line to be tangent to the support and the selected 
direction, choose the Tangent radio button and choose the OK button to create the reflect line, 
as shown in Figure 17-27. 

Figure 17-27  The Cylindrical type reflect lines 
created upon a surface

Figure 17-26  The Reflect Line 
Definition dialog box

Note that if you select the Conical radio button from the Type area, the Direction selection 
box will change into the Origin selection box and you need to select a point as the origin of the 
light source. If the resulting feature is divided into sub-elements, choose the OK button; the 
Multi-Result Management dialog box will appear, as shown in Figure 17-28. You can use this 
dialog box to decide which sub-element is to be kept. When you choose the OK button in the 
Multi-Result Management dialog box, the Near/Far Definition dialog box appears, as shown 
in Figure 17-29. In this dialog box, select the Near radio button to create an entity nearest to 
the reference element or the Far radio button to create an entity farthest from the reference 
element. Next, select the element that is made up from several elements. Choose a reference 
element whose position is either close or far from the sub-element that you want to create and 
choose the OK button to create the element.
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Note
The Near/Far Definition dialog box is automatically displayed when a non-connex element is 
detected at the time of creation. You can directly choose the element to be created from the dialog box.

Figure 17-28  The Multi-Result Management 
dialog box

Figure 17-29  The Near/Far 
Definition dialog box

Creating Silhouette
  Menubar: 	 Insert > Wireframe > Silhouette   			    
  Toolbar:	 Wireframe > Project-Combine sub-toolbar > Silhouette 	

Silhouette is a 3D wireframe curve. The silhouette command computes reflect lines and 
extracts edges that define the contour and removes non-visible areas of the contour. Select 
Silhouette in the Project-Combine sub-toolbar in the Wireframe toolbar, the Silhouette 
Definition dialog box will be displayed, as shown in Figure 17-30.

In this dialog box, select the type of silhouette to be created under the Type area. Cylindrical 
type of silhouette is created by an infinite light source while Conical type of silhouette is created 
with the help of a finite point light source. On invoking the dialog box, you will be prompted 
to select a support. Select the support geometry in the Elements selection box. Note that you 
can select multiple items at a time by clicking on the button next to the Elements selection box. 
Next, select a point, axis or a plane in the Direction selection box. Note that if you select the 
Cylindrical radio button in the Type area, you need to select an axis or plane as the direction. 
If you select Conical from the Type area, you need to select a point in the Origin selection 
box. In case of cylindrical silhouette, select a planar element in the Projection plane selection 
box; the filtered silhouettes will be projected on this plane. In case of a cylindrical silhouette, 
select the 1D or 2D radio button from the Result area to create the desired silhouette. Select 
the options in the Result filters area to obtain the desired result. Selecting the External check 
box  will create the external silhouette edges. You can select the Internal check box to create 
the internal silhouette edges. To create the silhouette edges other than internal and external 
ones, choose the Inner check box  in the Result filters area. Next, choose the OK button to 
create the silhouette, as shown in Figure 17-31.
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Figure 17-30  The Silhouette Definition 
dialog box

Figure 17-31 The Cylindrical Silhouette 
created on a plane

CREATING VOLUMES
The volume tools are available in the Generative Shape Design workbench. These tools allow 
you to use some of the part design features without changing workbenches. Any volumetric 
feature can be modified into another volumetric feature with the help of modification and 
transformation features. This gives the user a better flexibility to integrate solid modelling with 
surface features. The methods for creating volumes are discussed next.

Creating a Volume Extrude
  Menubar: 	 Insert > Volumes > Volume Extrude     
  Toolbar:	 Volumes  > Volume Extrude	                                                        

The Volume Extrude tool is used to create a volume by extruding a closed planar profile 
or surface. Choose the Volume Extrude tool from the Volumes toolbar; the Extruded 
Volume Definition dialog box will be displayed, as shown in Figure 17-32. Select the 

profile to be extruded from the graphics window; the selection will get displayed in the Profile 
selection box. Next, specify the direction of extrusion in the Direction selection box. You can 
select a line to take its orientation as the extrusion direction or a plane to take its normal as 
extrusion direction. After selecting the direction reference, you need to specify the extrusion 
limits. Set the extrusion limits by selecting the options from the Type drop-down lists under the 
Limit 1 and Limit 2 areas. If you select Dimension in the Type drop-down list, you need to 
define the value of extrusion in the Dimension spinner. If you select Up-to element in the Type 
drop-down list, you need to select a geometry as the limit of extrusion. The geometry can be a 
point, a plane, or a surface. Note that the dimension values can also be specified with the Up-to 
element option, as shown in Figure 17-33. Next, choose the OK button from this dialog box to 
complete the feature.
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Figure 17-33  The Extruded Volume Definition 
dialog box with limits selected as Up-to element

Figure 17-32  The Extruded Volume Definition 
dialog box with limits selected as Dimension

Creating a Volume Revolve                                                
  Menubar: 	 Insert > Volumes > Volume Revolve   	  
  Toolbar:	 Volumes  > Volume Revolve		

The Volume Revolve tool is used to create a volume

Figure 17-34  The Revolve Volume 
Definition dialog box

 
by revolving a non self-intersecting closed planar 
profile, a surface, or a sketch about an axis. Choose 

the Volume Revolve tool from the Volumes toolbar, the 
Revolve Volume Definition dialog box will be displayed, as 
shown in Figure 17-34. Select the profile, surface, or sketch 
to be revolved; you will be prompted to select a line as a 
revolution axis. Next, select an axis of revolution in the 
Revolution axis selection box. Now, select required option 
from the Type drop-down list. By default the Dimension 
option is selected in the Type drop-down list and you will be 
prompted to specify the angular limit value. Specify the 
required angular limit values in the Angle 1 and Angle 2 
spinners in the Limit 1 and Limit 2 area respectively. You 
can also use graphic handles to define angular limits. If you 
select the Up-to element option from the Type drop-down 
list; the Up-to element selection box will be displayed under this drop-down list and you will 
be prompted to specify a surface, a point or a plane to limit the revolution. Specify the required 
limit. Next, choose the OK button to complete the feature.
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Creating the Multi-Sections Volume
  Menubar: 	 Insert > Volumes > Multi-Sections Volume      
  Toolbar:	 Volumes  > Multi-Sections Volume	                                     

The Multi-Sections Volume tool is used to create a multi-sections volume by sweeping 
one or more closed section curves along an automatically computed or user-defined spine. 
The volume can be made to follow one or more guide curves. Choose the Multi-Sections 

Volume tool from the Volumes toolbar; the Multi-Sections Volume Definition dialog box will 
be displayed, as shown in Figure 17-35. 

Select one or more planar curves in the curve selection

Figure 17-35  The Multi-Sections Volume 
Definition dialog box

area. A closing point can be selected for closed section 
curves. Next, select the continuity type for each support 
surface. By default, the continuity is set to Tangent. You 
can select one or more guide curves in the Guides tab 
of the Multi-Sections Volume Definition dialog box. 
Note that the guide curves must intersect each section 
curve and must be point continuous. You can define 
smoothing parameters in the Smooth parameters area. 
Select the Angular correction option to smooth the 
lofting along the reference guide curves. This may be 
needed when small discontinuities are detected with 
respect to the spine tangency or the reference guide 
curve’s normal. Specify a deviation value to smooth the 
loft by deviating it from the guide curve. Next, choose 
OK to create the multi-sections volume.

Note
For further information about the other tabs and options in the Multi-Sections Volume Definition 
dialog box, refer to Chapter 9.

Creating a Volume Sweep
  Menubar: 	 Insert > Volumes > Volume Sweep     
  Toolbar:	 Volumes  > Volume Sweep	                                                    

The Volume Sweep tool is used to create the swept volumes that use an explicit or an 
implicit circular or linear profile. The swept volumes are created by sweeping a closed 
profile having spines normal to the profile plane while considering user-defined 

parameters such as guide curves and reference elements. Choose this tool from the Volumes 
toolbar; the Swept Volume Definition dialog box will be displayed, as shown in Figure 17-36. 
The options in this dialog box are discussed next.

Profile Type
In this area, three buttons corresponding to three profile types are available, Explicit, Line and 
Circle. These buttons are discussed next.
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Explicit 
Choose this button to create swept surfaces using explicit user-defined profile. In the 
Subtype drop-down list, three options are available which are discussed next.

Figure 17-36  The Swept Volume Definition dialog box

With reference surface: By default, this 

Figure 17-37  The swept volume created using 
the With reference surface option

option is selected in the Subtype drop-down 
list. Select a profile with the help of the Profile 
selection box. Next, you need to select a guide 
curve in the Guide curve selection box. Choose 
the Preview button to view the swept volume, 
as shown in Figure 17-37. You can also select a 
surface to control the position of the profile 
during sweep. By default, the reference surface 
is the mean plane of the spine.

With two guide curves: When you select 
the With two guide curves option in subtype 
drop-down list, the options in the Swept 
Volume Definition dialog box will get modified accordingly, refer to Figure 17-38. Select 
the profile to be swept. Next, you need to select the guide curves using the Guide curve 1 
and Guide curve 2 selection boxes. Choose Preview to view the swept volume, as displayed 
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in Figure 17-39. By default, the anchor point is calculated by itself but you can also specify 
anchor points for each guide separately. These anchor points are intersection points between 
the guides and the profile’s plane or the profile itself through which the guiding curves 
will pass. 

Figure 17-38  The Swept Volume Definition dialog 
box on selecting the With two guide curves option

Figure 17-39  The swept volume created using 
the With two guide curves option

You can select the Two points or Point and direction option in the Anchoring type 
drop-down list. If you select Two points then you need to select anchor points on the profile 
that will match the Guide curve 1 and Guide curve 2 respectively. In case the profile is 
an open profile, these points are optional and the end points of the profile are used as 
anchoring. If you select the Point and direction option in the Anchoring type drop-down 
list, you need to select an anchor point on the profile which will match the Guide curve 1 
and anchor direction.

With pulling direction: On selecting this option, a modified Swept Volume Definition 
dialog box will be displayed, as shown in Figure 17-40. This option is equivalent to the With 
reference surface option with a reference plane normal to the pulling direction. In this 
dialog box, select the profile that is to be swept from the Profile selection box. Next, select 
a guide curve in the Guide curve selection box and a direction reference in the Direction 
selection box and choose OK to create the sweep volume, as shown in Figure 17-41.
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Figure 17-40  The Swept Volume Definition 
dialog box displayed on selecting the With pulling 
direction option

Figure 17-41  The swept volume created 
using the With pulling direction option

Line (Linear Profile)
This type of profile is used to create swept volumes with a draft in a specified direction. 
Choose the Line button in the Profile type area if not already chosen; the Swept 

Volume Definition dialog box will be displayed, as shown in Figure 17-42. In this dialog 
box, With draft direction is selected as the default subtype. Now, select a closed planar 
curve or any surface (planar or non planar) as the guide curve in the Guide selection box 
and a direction reference (a line, a plane, or a component) in the Draft direction selection 
box. In the Draft computation mode, select the Square or Cone radio button to specify the 
draft method. The Square mode uses  a plane normal to the draft direction as the reference 
surface and the projection of the guide curve onto this plane is used as the spine. In the 
Cone mode, envelope of cones are defined along a given curve. You can specify an angular 
definition for the sweep. In the Wholly defined tab, the angular value varies during the 
whole sweeping operation. In the G1-Constant tab, a different draft value for every G1 
section can be specified. In the Location values tab, angular values can be defined at 
specified points located on the curve. You can also choose the Next or Previous button in 
the Angular sector area to preview the four solutions based on the values given for the 
angle and length, refer to Figure 17-43.
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Figure 17-42 The Swept Volume Definition dialog 
box with the With  draft direction option selected

Figure 17-43  The sweep created using xy plane 
as draft direction and 15 deg as draft angle

If required, you can define relimiters (points or planes) in order to longitudinally reduce 
the domain of the sweep, refer to Figure 17-44.

In the Smooth sweeping area, you can choose the Angular correction and the Deviation 
from guide(s) check boxes and specify a correction and deviation value next to their 
respective edit boxes.

In the Twisted areas management area, on selecting the Remove cutters on Preview check 
box, the twisted areas will be removed from the swept volume.

Note
The Location values tab is only activated in the square computation mode and will work only 
for G1 curves.



Introduction to Generative Shape Design		       17-21

Figure 17-44  The sweep created using the From curve option

Circle (Circular Profile)
The Circle profile type creates swept

Figure 17-45  The Swept Volume Definition 
dialog box with the Circle button selected

volumes using implicit circular profiles. 
Choose the Circle button from the Profile 
type area of the Swept Volume Definition 
dialog box; the Swept Volume Definition 
dialog box will be displayed, as shown in 
Figure 17-45. In this dialog box, two options 
are available in the Subtype drop-down, 
Center and reference curve and Center and 
radius. 

For the Center and reference curve subtype, 
select a center curve and a reference curve with 
the help of their respective selection boxes. 
You may also specify a fixed radius if required. 
Choose OK to create the swept volume, as 
shown in Figures 17-46 and 17-47.

For the Center and radius subtype, select a 
center curve in the Center curve selection 
box. Specify a radius value and choose OK to 
create the swept volume. The swept volume 
created using the Center and radius subtype 
is shown in Figure 17-48.
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Figure 17-46  The swept volume created using 
the Center and reference curve subtype with 
no fixed radius

Figure 17-47  The swept volume created using 
the Center and reference curve subtype with 
fixed radius of 55mm

Figure 17-48  The swept volume created using 
the Center and radius subtype

CREATING SURFACES
The Generative Shape Design workbench has some additional tools

Figure 17-49 The Surfaces 
toolbar

 
compared to the Wireframe and Surface Design workbench. The 
Surfaces toolbar in the Generative Shape Design workbench is 
shown in Figure 17-49. The tools in this toolbar are used to create 
rich and complex surface geometries. The methods to create surfaces 
using these tools are discussed next.

Creating Variable Offset Surfaces
  Menubar: 	 Insert > Surfaces > Variable Offset  		      
  Toolbar:	 Surfaces  > Offsets sub-toolbar > Variable Offset	    

The Variable Offset tool is used to create a variable surface that is offset between other 
offset surfaces. Using this tool, you can create variable and constant offset surfaces in one 
operation. To do so, choose the Variable Offset tool from the Offsets sub-toolbar in the 

Surfaces toolbar; the Variable Offset Definition dialog box will be displayed, as shown 
in Figure 17-50. Next, select a base surface in the Base Surface selection box. If the base surface 



Introduction to Generative Shape Design		       17-23

was created using multiple surfaces then you can select the sub-parts of the surface in the 
Parameters tab. Next, specify the offset type from the Offset drop-down list and a value in the 
spinner next to it. The Offset drop-down list has two options, Variable and Constant. If the 
sub-part to offset is an element, such as a line, curve, or edge, then the Constant (Border) and 
Constant (Inner) options will also be available in the Offset drop-down list. You can use the 
Add Before or Add After radio button to add a surface before or after the selected surface. You 
can choose the Replace radio button to replace the selected surface by another surface. You can 
select the Offset law type using the Linear or S type radio button. By default, the S type radio 
button is selected in this field. You can choose the Reverse Direction button to reverse the 
direction of the offset surface. Choose the OK button to complete the feature, as shown in 
Figure 17-51. 

Figure 17-50 The Variable Offset Definition dialog box

Figure 17-51 The Variable Offset created
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In case, the offset encounters a problem while creating a variable surface, a warning dialog box 
will appear and the sub-elements of the offset surface will display warnings with flag notes to 
remove sub-elements, as shown in Figures 17-52 and 17-53. If you move the cursor over a flag 
note, a message giving an accurate diagnosis is displayed. The elements with warnings will be 
displayed under the Sub-Elements To Remove tab of the Variable Offset Definition dialog 
box, as shown in Figure 17-54.

You can also create an offset surface whose sub-elements may have several constant values. For 
this, you need to choose the Constant option with an offset value for each sub-part in the Offset 
drop-down list. The resulting offset surfaces will automatically get connected to each other.

Figure 17-52  The erroneous Warning box

Figure 17-53  The Variable Offset 
displaying warning flag notes

Figure 17-54  The Sub-Elements To Remove 
tab displaying sub-elements with warning

Creating Rough Offset Surfaces
  Menubar: 	 Insert > Surfaces > Rough Offset  		   
  Toolbar:	 Surfaces  > Offsets sub-toolbar > Rough Offset	

The Rough Offset tool creates an offset surface which approximates the initial surface to 
keep its main characteristics. To create a rough offset surface, choose the Rough Offset 
tool from the Offsets sub-toolbar in the Surfaces toolbar; the Rough Offset Surface Definition 

dialog box will be displayed, as shown in Figure 17-55. Select a reference surface that is to be 
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offset in the Surface selection box; an arrow upon the selected

Figure 17-55 The Rough Offset 
Definition dialog box

 
surface indicating the proposed direction of the 
offset will be displayed. Click on it if you want to reverse the 
direction. Next, you need to specify an offset distance in the 
Offset edit box. Set an approximation tolerance by specifying 
a value in the Deviation spinner. The default value is 1mm 
and the minimum acceptable value is 0.2mm. Note that the 
offset value must be larger than the deviation value. Choose 
the Preview button; the Update in progress window will be 
displayed, as shown in Figure 17-56. As the topology updating 
gets finished, the preview of the offset surface will be displayed. 
In some cases, when the deviation exceeds its maximum value, 
the Deviation Analysis check box will become active. When 
you select the Deviation Analysis check box to display and analyze the deviation at specific 
points, the Deviation Analysis color scale appears in the geometry area, as shown in Figure 17-57. 
Choose the OK button to create the surface and the resulting rough offset, refer to 
Figures 17-58 and 17-59.

Figure 17-56 The Update in progress window Figure 17-57 The Deviation 
Analysis color scale

Figure 17-58 The surface to be offset Figure 17-59 The resulting 
Rough Offset surface
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Creating Mid Surfaces
  Menubar: 	 Insert > Surfaces > Mid Surface  		   
  Toolbar:	 Surfaces  > Offsets sub-toolbar > Mid Surface	

The Mid Surface tool is used to create a mid surface

Figure 17-60 The Mid Surface 
Definition dialog box

 
from a pair of faces that are offset from each other. 

To create a mid surface, choose the Mid Surface tool from 
the Offsets sub-toolbar in the Surfaces toolbar; the Mid 
Surface Definition dialog box will be displayed, as shown 
in Figure 17-60. Also, you will be prompted to select a 
volume feature, a body, or a solid feature. Select a solid 
feature, a volume feature, or a body that contains a pair of 
faces with the help of the Support selection box. Next, select 
the Face Pairs option in the Creation Mode drop-down list 
and select one or more pairs of faces from which the 
mid-surface will be extracted. Note that a face can belong 
to more than one pair. Within a pair, faces are ordered as 
the Main Side and the Other Side and are always offset from 
each other. When you select the main side, the Mid Surface 
tool automatically selects the other side and generates a 
mid surface according to the specified offset ratio. Next, 
you need to specify a value in the Offset ratio spinner. The 
value of the offset ratio should be between 0 and 1. Choose 
OK to generate the mid surface, as shown in Figures 17-61 
to 17-63.

Figure 17-61 The Mid 
Surface with offset 
ratio=0.3

Figure 17-62 The Mid 
Surface with offset 
ratio=0.5

Figure 17-63 The Mid 
Surface with offset 
ratio=0.7

You can create a mid surface by selecting a set of faces and setting an offset ratio. This is useful 
for complex models which may not contain parallel faces to form a pair. To create a mid surface 
from a set of faces, select the Faces to offset option in the Creation Mode drop-down list; the 
Mid Surface Definition dialog box will be displayed, as shown in Figure 17-64. Select a volume 
feature, a body, or a solid feature in the Support selection box. Next, select one or more faces 
in the Faces to Offset selection box. Choose Manual or Automatic from the Computation 
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Mode drop-down list and specify an offset distance in the Offset edit box and choose Preview 
to preview the result. 

 

Figure 17-64 The Mid Surface Definition dialog box 
with the Faces To Offset option selected

To create a mid surface if you select the Automatic option in the Creation Mode drop-down 
list, the Mid Surface Definition dialog box will be displayed, as shown in Figure 17-65. Next, 
you need to specify a thickness threshold in the Thickness Threshold for the resulting surface. 
This thickness threshold acts as maximum distance for the selection of pairs of faces to create 
the mid surface. By default, the Automatic Thickness Threshold check box is selected which 
calculates the default thickness threshold value. On clearing this check box, the Thickness 
Threshold spinner gets activated. You can specify the value of thickness threshold in this spinner.
  

Figure 17-65 The Mid Surface Definition dialog box 
with the Automatic option selected

You can manage the mid-surface creation of ribs using an existing connex mid-surface. To do 
so, choose the Create a new rib mid surface after OK radio button from the Ribs management 
area and choose OK; the Mid Surface Definition dialog box appears again with Mid Surface.1 
selected in the Limiting mid surface selection box. In the Face Pairs area, select a pair of faces 
to form the rib. During the mid-surface creation of ribs, offset ratio is set to 0.5 by default. 
Choose the OK button to complete the feature.
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Creating Adaptive Swept Surfaces
  Menubar: 	 Insert > Surfaces > Adaptive Sweep  		      	   
  Toolbar:	 Surfaces  > Sweeps sub-toolbar > Adaptive Sweep	         

Adaptive surface is a surface which can adapt the changing dimensions of the parent 
profile. The dimensions applied on the sketched profile affect the resulting swept surface. 
You can vary the cross-section of the sweep along the guide curve by defining the user 
sections. The user-section inherits the constrains of the parent sketch and allows you to 

modify them independently. To create an adaptive sweep, choose the Adaptive Sweep tool from 
the Sweeps sub-toolbar in the Surfaces toolbar; the Adaptive Sweep Definition dialog box is 
displayed, as shown in Figure 17-66. Select a guide curve in the Guiding Curve selection box. 
If no guiding curve already exists, right-click in the Guiding curve selection field to invoke the 
contextual menu for creating a guide curve. You can select a spine with the help of the Spine 
selection box. By default, the spine is selected as the guiding curve. Selection of reference surface 
is optional. The reference surface is the surface on which the guide curve lies and is used to 
define the axis system in which the swept surface will be created. Next, select a sketch to be swept 
along the guiding curve in the Sketch selection box. As you select the sketch, an axis system is 
displayed defining the plane on which the first section is created. Select the end point of the 
guiding curve to create another section. You may also drag the axis system along the guiding 
curve by using the drag handles in the graphics area. Right-click on the manipulator to display 
the contextual menu. The options in the contextual menu are discussed next.

Figure 17-66  The Adaptive Sweep Definition dialog box

Create a section here
Choose this option to create a section at the manipulator’s place. The section is created at a 
point on the guide curve with the corresponding ratio.



Introduction to Generative Shape Design		       17-29

Use interpolated manipulator
Move the manipulator along the guide curve to visualize the section parameters.

Show all sections’ constraints
This option allows you to visualize all the sections with their constraints.

The Sections tab of the Adaptive Sweep Definition dialog box displays the sections created 
along the guiding curve.

  Choose this button to remove the current section.

  Choose this button to rename the current section.

  Choose this button to activate or deactivate the current section.

Specify a value of deviation in the Deviation spinner. Decreasing the value of deviation increases 
the precision. Select the Angular correction check box to specify a value for the angular 
correction. Specifying angular correction may be necessary when small discontinuities are 
detected with respect to the spine. By default, the value of angular correction is 0.5 degree. 
In the Adaptive Sweep Definition dialog box, choose the Parents tab to display the elements 
which are creating the sweep. You can update or replace the parent by selecting the parents and 
choosing the   button at the top right corner of the Parents tab. Choose the Parameters tab 
to display and redefine the constraints on a given section. Select a section using the Current 
Section drop-down list; the constraints will be displayed with their respective values. Choose 
the Relimitation tab to limit the swept surface at specified location and choose the OK button 
to complete the feature, as shown in Figure 17-67.

Figure 17-67 The adaptive sweep created using four user sections

In case, you want to exit the Adaptive Sweep after creating the sketches using the Create Sketch 
contextual menu, with the sketches retained, choose the To cancel the command but keep the 
sketch, use:  button in the Adaptive Sweep definition dialog box.
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Tip
It is advised to create the input sketch while the Adaptive Sweep tool is active in order to 
benefit from the automatic positioning of the sketch. This will improve the robustness of the 
adaptive sweep. 

PERFORMING OPERATIONS ON SHAPE GEOMETRY
The Operations toolbar belongs to the Wireframe and Surface Design and Generative Shape 
Design workbenches.

The operations offer functions for connecting, extending, trimming, filleting, translating, 
revolving, scaling and mirroring of surfaces, volumes, and wireframe geometries. The scope of 
operations offered by the Wireframe and Surface Design workbench is smaller than that offered 
by the Generative Shape Design workbench. Some of the tools in the Operations toolbar are 
discussed next.

Creating the Shape Fillet
  Menubar: 	 Insert > Operations > Shape Fillet  		   
  Toolbar:	 Operations  > Fillets sub-toolbar > Shape Fillet    	

The Shape Fillet tool is used to create fillet surfaces with constant radius between two 
support surfaces. To do so, choose this tool from the Fillets sub-toolbar in the Operations 
toolbar; the Fillet Definition dialog box will be displayed, as shown in Figure 17-68. By 

default, the BiTangent Fillet option is selected in the Fillet type drop-down list. Next, select a 
surface as the first support and then select the second surface as the second support. As you 
select the surfaces, an arrow will be displayed on each surface indicating the location of the fillet, 
as shown in Figure 17-69. Specify the value of fillet in the Radius spinner. If you select the 
Chordal radio button, the Radius edit box changes into the Length edit box. Next, select the 
Conic parameter check box, if you need to vary the section of the fillet. If the value of parameter 
is 0.5, the resulting curve will be a parabola. For the value between 0 to 0.5, the resulting curve 
will be an arc of ellipse. For the value between 0.5 to 1, the resulting curve will be a hyperbola. 
In the Extremities drop-down list, four options are available which are discussed next. 

Figure 17-69  The fillet applied between two surfacesFigure 17-68  The Fillet Definition dialog box
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Smooth
This option is used to apply a tangency constraint at the connection point between the fillet 
surface and the support surface. This will create a smooth connection between the support 
surface and the fillet surface, as shown in Figure 17-70.

Straight
On selecting this option, the tangency constraint will not be applied at the connection point 
between the support surface and the fillet surface. This will generate a sharp angle at the 
connection point, as shown in Figure 17-71.

Figure 17-71  Fillet applied using the 
Straight option

Figure 17-70  Fillet applied using the Smooth 
option

Maximum
On selecting this option, the fillet surface is limited by the longest selected support’s edge, as 
shown in Figure 17-72.

Minimum
On selecting this option, the fillet surface is limited by the shortest selected support’s edge, as 
shown in Figure 17-73.

Figure 17-72  The fillet applied using 
the Maximum option

Figure 17-73  The fillet applied using 
the Minimum option
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Choose the More button to display additional options available in the Fillet Definition dialog 
box. You can choose a guide curve for the fillet boundary with the help of the Hold Curve 
selection box. If a radius propagation is defined with Hold Curve, a spine has to be defined. You 
can limit the fillet by defining points for limiting the fillet geometry using the Law Relimiter 1 
and Law Relimiter 2 selection boxes. Note that a law has to be defined for applying relimiter 
to fillet geometry.

If you are creating a fillet with multi-ribbons, the Update Error message box might be displayed 
with a message to process each ribbon in a separate operation, as shown in Figure 17-74. Choose 
OK in the message box; the solutions will be displayed in red color in the graphics area, as 
shown in Figure 17-75. In the Faces to keep field, select the face(s) you want to keep to create the 
shape fillet, refer to Figure 17-76. Choose OK to complete the feature, as shown in Figure 17-77.

Figure 17-74  The Update Error message box Figure 17-75  The possible solutions shown 
in red color

Figure 17-77  The multi-ribbon fillet createdFigure 17-76  Selecting faces to keep for 
multi-ribbon fillet

Creating the Edge Fillet
  Menubar: 	 Insert > Operations > Edge Fillet  		   
  Toolbar:	 Operations  > Fillets sub-toolbar > Edge Fillet    	

The edge fillet operation in the Generative Shape Design workbench can be used to fillet edges 
with a constant radius for a surface or volume element. A constant radius fillet is obtained by 
rolling a sphere over the selected edge. Note that all the edges must belong to one single surface. 
To create a fillet between two edges, choose the Edge Fillet tool from the Fillets sub-tool bar 
in the Operations toolbar; the Edge Fillet Definition dialog box will be displayed, as shown 
in Figure 17-78.
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Figure 17-78 The Edge Fillet Definition dialog box

In this dialog box, select the edges to be filleted in the Object(s) to fillet selection box. Note that 
on selecting an edge, the geometry will be automatically selected from the Support selection 
box. Next, select the desired type of extremity for the fillet in the Extremities drop-down list. 
Specify a value for the fillet radius in the Radius spinner; a preview of the fillet will be displayed 
as shown in Figure 17-79. Next, you need to choose the Propagation type from the Propagation 
drop-down list. There are two options available in the Propagation drop-down list.

Figure 17-79 Preview of the fillet applied

Tangency
This option is used to create a fillet that is propagated up to the first edge that is not continuous 
in tangency.

Minimal
This option is used to create a fillet that is propagated up to the first geometric limitation.
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In the Variation field, select the points where you want to vary the fillet geometry. Select the 
points in the Points selection box. The values for the fillet at the selected points can be defined 
only by double-clicking on the value in the graphics area, as shown in Figure 17-80.

Figure 17-80  Variable radius fillet applied to the selected edge

Select the Conic parameter check box in the Options area to vary the section of the fillet. If the 
value of the parameter is 0.5, the resulting profile will be a parabola. For the value between 0 
to 0.5, the resulting profile will be an elliptical arc. If the value is between 0.5 to 1, the resulting 
profile will be a hyperbola. Select the Trim support check box to relimit the support elements 
and assemble them to the fillet, if it is not selected by default. Choose OK to create the fillet 
feature, the fillet is applied to the edge, as shown in Figure 17-81. You may also need to indicate 
the edges that should not be filleted. But if the radius is too large, you will not be able select the 
boundary edges that you want to keep. Once you have selected the edges to be filleted, select 
More>> to expand the dialog box, then select the edges you want to keep in the Edge(s) to 
keep field. The edges selected are displayed pink in the graphics area.

Figure 17-81  Fillet applied to the selected edge

If the Conic parameter check box is selected in the Options area, the Edge(s) to keep display 
box will be disabled. Similarly, if the Edge(s) to keep field is selected, the Conic parameter 
check box will be disabled.
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You can limit the resulting fillet by using the Limiting element(s) selection box. These elements 
can either be surfaces, planes, or points on edges. You can select one or more limiting elements. 
Limiting element can also be defined by selecting a point on one of the selected edges to be 
filleted. Click on the arrow to retain opposite side of the fillet or to inverse it. Next, choose the 
OK button to create the limited fillet, as shown in Figure 17-82.

Figure 17-82 Fillet created with a limited boundary

TUTORIALS
Tutorial 1

In this tutorial, you will create the model using various tools available in the Generative Shape 
Design workbench. The model to be created is shown in Figure 17-83 and its views and dimensions 
are shown in Figure 17-84.				     	            (Expected time: 1hr)

Figure 17-83  Model for Tutorial 1
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Figure 17-84 Views and dimensions of the model for Tutorial 1

	 The following steps are required to complete this tutorial:

a.	 Create the base surface of the model by revolving the sketch using the Revolve tool through 
170 degrees.

b.	 Create the second surface feature.
c.	 Trim the extruded surface using the Trim tool.
d.	 Add fillet to the trimmed base surface.
e.	 Create a plane at an offset distance of 40 mm from the xy plane.
f.	 Create a multi-sections surface.
g.	 Trim the base feature using the lofted feature and create a fill surface on the top of the lofted 

feature.
h.	 Join all surfaces together and add remaining fillets to the surface model.
i.	 Add thickness to the surface.

Creating the Base Surface
	 To create this model, first you need to create the base surface. The base surface will be 

created by revolving a sketch created on the xy plane. 
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1.	 Start a new file in the Generative Shape Design workbench by choosing  Shape > Generative 
Shape Design from the Start menu.

2.	 Invoke the sketcher environment using the xy plane as the sketching plane and create the 
sketch of the base surface, as shown in Figure 17-85.

Figure 17-85  Sketch of the base surface

3.	 Exit the sketch workbench and choose the Revolve tool from the Extrude-Revolution 
sub-toolbar in the Surfaces toolbar; the Revolution Surface Definition dialog box is 
displayed.

4.	 Select the sketch using the Profile selection box and then select the horizontal axis from 
the Revolution axis selection box. Next, specify the value of angle in the Angle 1 spinner 
in the Angular Limits area as 180.

5.	 Choose the OK button from the Revolution Surface Definition dialog box. Figure 17-86 
shows the resulting revolved base feature.

Figure 17-86  Revolved base surface 
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Creating the Second Surface Feature
	 The second surface feature is an extruded surface. This surface will be created by extruding 

a sketch created on the xy plane.

1.	 Select the xy plane as the sketching plane and invoke the sketch workbench.

2.	 Create the sketch of the second surface feature, as shown in Figure 17-87. 

Figure 17-87  Sketch of the second surface feature

3.	 Next, exit the sketcher workbench and choose the Extrude tool from the Surfaces toolbar; 
the Extruded Surface Definition dialog box is displayed.

4.	 Select the sketch in the Profile selection box if not selected by default and select the xy plane 
as the direction of extrusion. 

5.	 Set 40 in the Dimension spinner of the Limit1 area and choose the OK button from the 
Extruded Surface Definition dialog box; the Multi-Result Management dialog box is 
displayed. Choose OK; the Near/Far Definition dialog box is displayed. Choose the Cancel 
button to complete the feature.

	 The surface created after extruding the sketch is shown in Figure 17-88.

Figure 17-88  Extruded surface 
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Trimming the Base Surface Using the Extruded Surface
	 Next, you need to trim the unwanted portions from the base surface by using the extruded 

surface.

1.	 Choose the Trim tool from the Trim-Split sub-toolbar in the Operations toolbar; the Trim 
Definition dialog box is invoked.

2.	 Select the base and extruded surfaces from the drawing area; the name of the selected surfaces 
displayed in the Trimmed elements selection box. The element to be trimmed becomes 
translucent. Next, choose the Other side/ Previous element button to retain desired side 
of the surface. Refer to Figure 17-89.

3.	 Choose the OK button from the Trim Definition dialog box. The model after trimming 
the base surface is displayed in Figure 17-90.

Figure 17-89  Surfaces selected for trimming Figure 17-90  Model after trimming the base 
surface

Filleting the Edges of the Trimmed Surface
	 Next, you need to fillet the edges created at the intersection of the base surface and the 

extruded surfaces. 

1.	 Choose the Edge Fillet tool from the Fillets sub-toolbar in the Operations toolbar; the 
Edge Fillet Definition dialog box is displayed.

2.	 Select the edges to fillet, as shown in Figure 17-91.

3.	 Set 5 in the Radius spinner and then choose the OK button from the Edge Fillet Definition 
dialog box. Figure 17-92 shows the model after adding the fillet. 
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Figure 17-91  Edges to be filleted Figure 17-92  Resultant fillet feature

Creating the Lofted Surface
	 Next, you need to create a lofted surface. The lofted surface will be created between two 

curves. The first curve is to be created on the xy plane and projected on the surface. The 
next curve is to be created on an offset plane.

1.	 Create a plane at an offset distance of 40 mm from the xy plane and then invoke the 
sketch workbench using the newly created plane as the sketching plane.

2.	 Create the sketch, as shown in Figure 17-93, and exit the sketch workbench.

Figure 17-93  Sketch to create the projected curve

	 Next, you need to project this sketch on the base surface.

3.	 Choose the Projection tool from the Wireframe toolbar; the Projection Definition dialog 
box is displayed. 

4.	 Select the Along a direction option from the Projection type drop-down list.
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5.	 Select the sketch using the Projected selection box and then select the base surface in the 
Support selection box.

6.	 Select xy plane as the projection direction in the Direction selection box. Choose the OK 
button from the Projection Definition dialog box; the projected curve is created on the 
surface.

	 Next, you need to create the second curve for creating the loft surface.

7.	 Invoke the sketch workbench with the newly created plane as the sketching plane and then 
create the sketch, as shown in Figure 17-94, and exit the sketching environment. If required, 
you can hide the first sketch after projection for the ease of creating the second sketch.

Figure 17-94 First sketch for the loft surface

8.	 Choose the Multi-Sections Surface tool from the Surfaces toolbar; the Multi-Sections 
Surface Definition dialog box is displayed.

9.	 Select the sections, as shown in Figure 17-95, and choose the OK button from the 
Multi-Sections Surface Definition dialog box. Figure 17-96 shows the model after creating 
the lofted surface.

Figure 17-95 Sections selected for multi-section surfaces



17-42				          	                               CATIA V5-6R2021 for Designers

Figure 17-96  Resultant lofted surface

Trimming the Base Surface Using the Lofted Surface
	 Next, you need to trim the base surface by using the lofted surface. 

1.	 Choose the Trim tool from the Trim-Split sub-toolbar in the Operations toolbar to invoke 
the Trim Definition dialog box.

2.	 Select the lofted surface and the base surface using the Trimmed elements selection box. 
Choose the Other side / next element or Other side / previous element button to retain 
the desired side of the trimmed surface if required.

3.	 Choose the OK button from the Trim Definition dialog box and hide the sketches you 
created for the loft feature.

4.	 Select the sketches and the projection you created for the loft feature and choose Hide/
Show from the shortcut menu to hide the selected sketches. Figure 17-97 shows the model 
after the base feature has been trimmed by using the lofted surface.

Figure 17-97  Model after trimming the base surface

Creating the Fill Surface
	 Next, you need to create the fill surface by using the top edges of the lofted surface.
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1.	 Choose the Fill tool from the Surfaces toolbar; the Fill Surface Definition dialog box is  
displayed.

2.	 Select the edges, as shown in Figure 17-98, to create the fill surface; the selected edges 
display a flag note for the closed counter in the graphics area.

Figure 17-98  Edges selected to create the fill surface

3.	 Choose the OK button from the Fill Surface Definition dialog box to create the fill surface, 
as shown in Figure 17-99.

Figure 17-99  Resultant fill surface



17-44				          	                               CATIA V5-6R2021 for Designers

Joining and Filleting the remaining Surfaces
	 Next, you need to join the lofted surface and the fill surface together by using the Join tool 

to create fillets on the edges. Note that if you want to add wall thickness to the surface model 
created using multiple surfaces, you need to join all the surfaces first.

1.	 Choose the Join tool from the Join-Healing sub-toolbar in the Operations toolbar; the Join 
Definition dialog box is displayed.

2.	 Select the lofted surface and the fill surface from the drawing area; the names of the selected 
surfaces are displayed in the Elements To Join selection box.

3.	 Next, choose the OK button from the Join Definition dialog box; the selected surfaces are 
joined.

4.	 Choose the Edge Fillet tool from the Operations toolbar and add the required fillets to the 
model. For dimensions of the fillets, refer to Figure 17-84. The final surface model after 
adding the fillets is shown in Figure 17-100

Figure 17-100  Final surface model

Adding Thickness to the Surface Model
	 Next, you need to add thickness to the surface model. 

1.	 Choose the Thick Surface tool from the Volumes toolbar to invoke the ThickSurface 
Definition dialog box.

2.	 Select the surface model and then set 1 in the First Offset spinner.

3.	 Choose the OK button from the ThickSurface Definition dialog box.

	 If required you can hide the sketches used for creating features of the model. Figure 17-101 
shows the rotated view of the final model after thickening the surface.
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Figure 17-101  The rotated view of the final model after thickening the surface 

 Tutorial 2
In this tutorial, you will create the model shown in Figure 17-102 in the Generative Shape 
Design workbench. Its orthographic views are shown in Figure 17-103.
								              (Expected time: 45 min)

Figure 17-102 Model for Tutorial 2

The following steps are required to complete this tutorial:

a.	 Create the base feature on the zx plane by using the extruded surface tool.
b.	 Create the second feature using the Multi-Sections Surface tool and mirror it about the yz 

plane.
c.	 Create the third feature by using the Fill tool.
d.	 Create a cut feature on the lofted surface and trim it with base surface. 
e.	 Trim the base feature and join all surfaces of the model.
f.	 Add the fillet and thickness feature to the surface edges.
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Figure 17-103  Top, front, and right side views of the surface model

Creating the Base Feature
The base feature is an extruded surface whose profile will be drawn on the zx plane.

1.	 Start CATIA part document in the Generative Shape Design workbench .

2.	 Invoke the sketcher environment using the zx plane as the sketching plane and create the 
sketch of the base surface, as shown in Figure 17-104.

3.	 Exit sketch workbench and choose the Extrude tool from the Surfaces toolbar; the 
Extruded Surface Definition dialog box is displayed.

4.	 In the Profile selection box, select the sketch and while retaining the default direction enter 
120 as the value in the Dimension spinner in the Limit 1 area.  Choose the Mirrored Extent 
check box to extrude the sketch symmetrically to a depth of 240 mm.

5.	 Choose the OK button from the Extruded Surface Definition dialog box. Figure 17-105 
shows the resulting extruded base feature.
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Figure 17-104  Sketch of the base surface

Figure 17-105  Extruded base surface

Creating the Second Surface Feature
	 Now, you need to create the multi-sections surface.

1.	 Create a sketch on the front face of the extruded surface and a second sketch on an offset 
plane created at an offset distance of 65 mm from the front plane. Refer to Figure 17-103 
for dimensions. 

2.	 After drawing the sketches, as shown in Figure 17-106, choose the Multi-Sections Surface 
tool from the Surfaces toolbar. Select both of the sketches to create a lofted surface, as shown 
in Figure 17-107.

3.	 Select the lofted surface and choose the Symmetry tool from the Operations toolbar. Now, 
select the yz plane as reference and choose OK to create the mirrored surface, refer to 
Figure 17-108.
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The lofted surface and the extruded base surface has to be trimmed so that they can be 
used as a single surface body.

4.	 Choose the Trim tool from the Operations toolbar; the Trim Definition dialog box is 
displayed. Select the extruded and lofted surface and specify the side of the surfaces to be 
trimmed.

Figure 17-106  Two sketches selected for multi-sections surface

Figure 17-107  Multi-sections surface created Figure 17-108  Mirror surface created

Creating the Fill Surfaces 
	 Next, you need to create the fill surface to close the ends of the extruded surface.

1.	 Choose the Line tool from the Wireframe toolbar. Select the open end points of the base 
surface. Choose OK to create a line, refer to Figure 17-109. Similarly create another line 
on the other side.

2.	 Choose the Fill tool from the Surfaces toolbar. Select the edges of the surface and the line 
that you created in the previous step; a flag note in the geometry area displays Closed 
Counter. 

3.	 Choose OK to complete the definition of the fill surface and repeat the process on the other 
side of the extruded surface. Similarly create another fill surface on the other side.

4.	 Choose the Join tool to merge the fill surface with the base surface. The resultant surface 
is displayed in Figure 17-110.
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Figure 17-109 Line created for Fill surface Figure 17-110 Fill surface created

Creating a Cut Feature on the Lofted Feature
	 In this step, you need to create the extruded surfaces. These surfaces will be used for trimming 

the lofted surface. 

1.	 Select xy plane and draw the sketch for the extruded surface. For dimensions, refer to 
Figure 17-103.

2.	 Choose the Extrude tool from the Surfaces toolbar; the Extruded Surface Definition dialog 
box is displayed. Select the sketches using the Profile selection box, keeping the direction 
as default in the Direction selection box. Enter 40 in the Dimension spinner under the 
Limit1 Type drop-down list and enter 0 in the Dimension spinner under the Limit2 Type 
drop-down list and choose the OK button; the Multi-Result Management dialog box is 
displayed. Select the keep all the sub elements option from this dialog box and choose the 
OK button . Figure 17-111 shows the extruded surfaces.

Figure 17-111 The extruded surfaces
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Trimming and Joining the Surfaces
1.	 Choose the Trim tool from the Operations toolbar; the Trim Definition dialog box is 

displayed.

2.	 Select the extruded and lofted surface using the Trimmed elements selection box and if 
required, choose the Other side/ next element button to keep the desired side of surface. 

3.	 Choose the OK button from the Trim Definition dialog box. The model after trimming 
the base surface is displayed in Figure 17-112. 

Figure 17-112 The model after trimming

Adding the Fillet and Thick Feature
1.	 Choose the Edge Fillet tool from the Operations toolbar, the Edge Fillet Definition dialog 

box is displayed. 

2.	 Select the edges of the surface model and apply fillet to the selected edges, for dimensions 
refer to Figure 17-103. The model after applying fillet to the selected edges is shown in 
Figure 17-113.

3.	 Choose the Thick Surface tool from the Volumes toolbar; the Thick Surface Definition 
dialog box is displayed. 

4.    Specify 1 in First Offset spinner and select the surface under the Objects to offset selection 
box and choose the OK button. 

	
	 The rotated view of the model after applying thickness is shown in Figure 17-114.
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Figure 17-113 The final surface model after 
applying fillet

Figure 17-114 The rotated view of the model 
after applying thick feature

 

Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 The 3D Curve Offset tool is used to create _______in a defined direction.

2.	 If the offset value is larger than the offset distance, the generated curve results into a 
_______ corner.

3.	 _______type of profile is used to create swept surfaces with draft direction.

4.	 The Conic tool is used to create conic-type curves such as_______.

5.	 Silhouette is a _______ curve.

6.	 _______ lines are curves that can be used to create guide curves or silhouettes.

7.	 The Spine tool cannot be used to create curves that pass at right angles through planes or 
section planes. (T/F)

8.	 The Corner tool is used to create an arc of specific radius which is continuously tangent 
with two elements. (T/F)

9.	 The Connect Curve tool is used to connect two points or two curves with a curve. (T/F)

10.	 The Swap UV button allows you to change the values for the U and V parameters of the 
curve. (T/F)
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 Review Questions 
Answer the following questions: 

1.	 Which of the following tools is only available in CATIA V5 Generative Shape Design 
workbench?

		  (a) Extrude				    (b) Edge Fillet
		  (c) Revolve				    (d) Sweep

2.	 If the support surface is modified or updated, the isoparametric curve gets_______ itself.

3.	 The tools in the Volumes toolbar allows you to use some of the _______ functionality without 
changing workbenches.

4.	 Minimum acceptable value for creating a rough offset is _______mm.

5.	 The Variable offset surface is an offset surface between the ________.

6.	 The ________ tool is used to extend the boundaries of an existing surface.

7.	 The ________ tool is used to create a law between two curves.

8.	 You can select a point, vertex, or extremity as the starting point of the spine. (T/F)

9.	 The Mid Surface tool is used to create a surface between two parallel faces of a solid model. 
(T/F)

10.	 Using the Join tool, you can join multiple surfaces together.  (T/F)

EXERCISES
 Exercise 1
In this exercise, create the model of binoculars shown in Figure 17-115. First, create a closed 
surface model and join all the surfaces together and then solidify it. The views and dimensions 
of the model are shown in Figure 17-116.	     		          (Expected time: 1.5 hr)
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Figure 17-115  Model for Exercise 1

Figure 17-116  Views and dimensions of the model for Exercise 1
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Answers to Self-Evaluation Test
1. parallel curves, 2. sharp, 3. Linear, 4. Parabolas, Ellipses or Hyperbolas, 5. 3D wireframe, 
6. Reflection, 7. F, 8. T, 9. T, 10. F


